Clicking on "Submit" DOES NOT save changes (v1.5)

Discussion in 'General' started by JohnyBeGood, Mar 27, 2009.

  1. JohnyBeGood

    Joined:
    May 18, 2008
    Messages:
    134
    Likes Received:
    0
    Hi all!

    I never had this problem in any of other older versions.
    Fresh install (v1.5 stable). I've created 2 extensions 100 and 200.
    When I try to call 100 or vice versa call goes to voicemail, if change in follow me "Destination if no answer:" to ie. "Phonebook Directory:" then instead of voicemail I hear "Welcome to the phonebook...."
    I think part of the problem is that I can't enable call waiting. Every time I select enable and hit submit it automaticly swithes back to disable in other words no changes are saved. See this video to see what I'm talking about (Use Full screen and HD options) >>
    Code:
    http://www.youtube.com/watch?v=ZITJ7B9gaF0
    Here's CLI log

    Code:
    Last login: Thu Mar 26 23:12:06 2009 from 192.168.1.100
    
    Welcome to Elastix 
    ----------------------------------------------------
    
    For access to the Elastix web GUI use this URL
    http://192.168.1.104
    
    [root@elastix ~]# asterisk -r
    Asterisk 1.4.23.2, Copyright (C) 1999 - 2008 Digium, Inc. and others.
    Created by Mark Spencer <markster@digium.com>
    Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
    This is free software, with components licensed under the GNU General Public
    License version 2 and other licenses; you are welcome to redistribute it under
    certain conditions. Type 'core show license' for details.
    =========================================================================
    Connected to Asterisk 1.4.23.2 currently running on elastix (pid = 2484)
    Verbosity is at least 3
        -- Remote UNIX connection
        -- Remote UNIX connection disconnected
        -- Executing [100@from-internal:1] GotoIf("SIP/200-0a1a0818", "0?ext-local|100|1") in new stack
        -- Executing [100@from-internal:2] Macro("SIP/200-0a1a0818", "user-callerid|") in new stack
        -- Executing [s@macro-user-callerid:1] Set("SIP/200-0a1a0818", "AMPUSER=200") in new stack
        -- Executing [s@macro-user-callerid:2] GotoIf("SIP/200-0a1a0818", "0?report") in new stack
        -- Executing [s@macro-user-callerid:3] ExecIf("SIP/200-0a1a0818", "1|Set|REALCALLERIDNUM=200") in new stack
        -- Executing [s@macro-user-callerid:4] Set("SIP/200-0a1a0818", "AMPUSER=") in new stack
        -- Executing [s@macro-user-callerid:5] Set("SIP/200-0a1a0818", "AMPUSERCIDNAME=") in new stack
        -- Executing [s@macro-user-callerid:6] GotoIf("SIP/200-0a1a0818", "1?report") in new stack
        -- Goto (macro-user-callerid,s,11)
        -- Executing [s@macro-user-callerid:11] GotoIf("SIP/200-0a1a0818", "0?continue") in new stack
        -- Executing [s@macro-user-callerid:12] Set("SIP/200-0a1a0818", "__TTL=64") in new stack
        -- Executing [s@macro-user-callerid:13] GotoIf("SIP/200-0a1a0818", "1?continue") in new stack
        -- Goto (macro-user-callerid,s,20)
        -- Executing [s@macro-user-callerid:20] NoOp("SIP/200-0a1a0818", "Using CallerID "device" <200>") in new stack
        -- Executing [100@from-internal:3] GotoIf("SIP/200-0a1a0818", "1?skipdb") in new stack
        -- Goto (from-internal,100,5)
        -- Executing [100@from-internal:5] Set("SIP/200-0a1a0818", "__NODEST=") in new stack
        -- Executing [100@from-internal:6] Set("SIP/200-0a1a0818", "__BLKVM_OVERRIDE=BLKVM/100/SIP/200-0a1a0818") in new stack
        -- Executing [100@from-internal:7] Set("SIP/200-0a1a0818", "__BLKVM_BASE=100") in new stack
        -- Executing [100@from-internal:8] Set("SIP/200-0a1a0818", "DB(BLKVM/100/SIP/200-0a1a0818)=TRUE") in new stack
        -- Executing [100@from-internal:9] Set("SIP/200-0a1a0818", "RRNODEST=") in new stack
        -- Executing [100@from-internal:10] Set("SIP/200-0a1a0818", "__NODEST=100") in new stack
        -- Executing [100@from-internal:11] Set("SIP/200-0a1a0818", "RecordMethod=Group") in new stack
        -- Executing [100@from-internal:12] Macro("SIP/200-0a1a0818", "record-enable||Group") in new stack
        -- Executing [s@macro-record-enable:1] GotoIf("SIP/200-0a1a0818", "1?check") in new stack
        -- Goto (macro-record-enable,s,4)
        -- Executing [s@macro-record-enable:4] AGI("SIP/200-0a1a0818", "recordingcheck|20090327-002033|1238138433.6") in new stack
        -- Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
      recordingcheck|20090327-002033|1238138433.6: No DB Entry AMPUSER//recording - Not Recording for , checking for others
        -- AGI Script recordingcheck completed, returning 0
        -- Executing [s@macro-record-enable:5] MacroExit("SIP/200-0a1a0818", "") in new stack
        -- Executing [100@from-internal:13] Set("SIP/200-0a1a0818", "RingGroupMethod=ringallv2") in new stack
        -- Executing [100@from-internal:14] Set("SIP/200-0a1a0818", "_FMGRP=100") in new stack
        -- Executing [100@from-internal:15] GotoIf("SIP/200-0a1a0818", "0?doconfirm") in new stack
        -- Executing [100@from-internal:16] Macro("SIP/200-0a1a0818", "dial||tr|") in new stack
        -- Executing [s@macro-dial:1] GotoIf("SIP/200-0a1a0818", "1?dial") in new stack
        -- Goto (macro-dial,s,3)
        -- Executing [s@macro-dial:3] AGI("SIP/200-0a1a0818", "dialparties.agi") in new stack
        -- Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
      dialparties.agi: Starting New Dialparties.agi
      == Parsing '/etc/asterisk/manager.conf': Found
      == Parsing '/etc/asterisk/manager_additional.conf': Found
      == Parsing '/etc/asterisk/manager_custom.conf': Found
      == Manager 'admin' logged on from 127.0.0.1
      dialparties.agi: Caller ID name is 'device' number is '200'
      dialparties.agi: Methodology of ring is  'ringallv2'
        --  dialparties.agi: Extension 100 cf is disabled
        --  dialparties.agi: Extension 100 do not disturb is disabled
      dialparties.agi: Extension 100 has ExtensionState: 4
        --  dialparties.agi: Checking CW and CFB status for extension 100
      dialparties.agi: Failed to DbSet CALLTRACE/100 to 200 (0)
        --  dialparties.agi: Filtered ARG3: 100
      dialparties.agi: Setting default NOANSWER DIALSTATUS since no extensions available
      == Manager 'admin' logged off from 127.0.0.1
        -- AGI Script dialparties.agi completed, returning 0
        -- Executing [s@macro-dial:4] NoOp("SIP/200-0a1a0818", "Returned from dialparties with no extensions to call and DIALSTATUS: NOANSWER") in new stack
        -- Executing [100@from-internal:17] Goto("SIP/200-0a1a0818", "nextstep") in new stack
        -- Goto (from-internal,100,19)
        -- Executing [100@from-internal:19] Set("SIP/200-0a1a0818", "RingGroupMethod=") in new stack
        -- Executing [100@from-internal:20] GotoIf("SIP/200-0a1a0818", "0?nodest") in new stack
        -- Executing [100@from-internal:21] Set("SIP/200-0a1a0818", "__NODEST=") in new stack
        -- Executing [100@from-internal:22] DBdel("SIP/200-0a1a0818", "BLKVM/100/SIP/200-0a1a0818") in new stack
        -- DBdel: family=BLKVM, key=100/SIP/200-0a1a0818
        -- DBdel: Error deleting key from database.
        -- Executing [100@from-internal:23] Goto("SIP/200-0a1a0818", "ext-local|vmu100|1") in new stack
        -- Goto (ext-local,vmu100,1)
        -- Executing [vmu100@ext-local:1] Macro("SIP/200-0a1a0818", "vm|100|NOANSWER|") in new stack
        -- Executing [s@macro-vm:1] Macro("SIP/200-0a1a0818", "user-callerid|SKIPTTL") in new stack
        -- Executing [s@macro-user-callerid:1] Set("SIP/200-0a1a0818", "AMPUSER=200") in new stack
        -- Executing [s@macro-user-callerid:2] GotoIf("SIP/200-0a1a0818", "0?report") in new stack
        -- Executing [s@macro-user-callerid:3] ExecIf("SIP/200-0a1a0818", "0|Set|REALCALLERIDNUM=200") in new stack
        -- Executing [s@macro-user-callerid:4] Set("SIP/200-0a1a0818", "AMPUSER=") in new stack
        -- Executing [s@macro-user-callerid:5] Set("SIP/200-0a1a0818", "AMPUSERCIDNAME=") in new stack
        -- Executing [s@macro-user-callerid:6] GotoIf("SIP/200-0a1a0818", "1?report") in new stack
        -- Goto (macro-user-callerid,s,11)
        -- Executing [s@macro-user-callerid:11] GotoIf("SIP/200-0a1a0818", "1?continue") in new stack
        -- Goto (macro-user-callerid,s,20)
        -- Executing [s@macro-user-callerid:20] NoOp("SIP/200-0a1a0818", "Using CallerID "device" <200>") in new stack
        -- Executing [s@macro-vm:2] Set("SIP/200-0a1a0818", "VMGAIN=""") in new stack
        -- Executing [s@macro-vm:3] GotoIf("SIP/200-0a1a0818", "1?vmx|1") in new stack
        -- Goto (macro-vm,vmx,1)
        -- Executing [vmx@macro-vm:1] GotoIf("SIP/200-0a1a0818", "0?s-NOANSWER|1") in new stack
        -- Executing [vmx@macro-vm:2] Set("SIP/200-0a1a0818", "MODE=unavail") in new stack
        -- Executing [vmx@macro-vm:3] GotoIf("SIP/200-0a1a0818", "1?notdirect") in new stack
        -- Goto (macro-vm,vmx,5)
        -- Executing [vmx@macro-vm:5] NoOp("SIP/200-0a1a0818", "Checking if ext 100 is enabled: ") in new stack
        -- Executing [vmx@macro-vm:6] GotoIf("SIP/200-0a1a0818", "1?s-NOANSWER|1") in new stack
        -- Goto (macro-vm,s-NOANSWER,1)
        -- Executing [s-NOANSWER@macro-vm:1] Macro("SIP/200-0a1a0818", "get-vmcontext|100") in new stack
        -- Executing [s@macro-get-vmcontext:1] Set("SIP/200-0a1a0818", "VMCONTEXT=") in new stack
        -- Executing [s@macro-get-vmcontext:2] GotoIf("SIP/200-0a1a0818", "1?200:300") in new stack
        -- Goto (macro-get-vmcontext,s,200)
        -- Executing [s@macro-get-vmcontext:200] Set("SIP/200-0a1a0818", "VMCONTEXT=default") in new stack
        -- Executing [s-NOANSWER@macro-vm:2] VoiceMail("SIP/200-0a1a0818", "100@default|u") in new stack
        -- <SIP/200-0a1a0818> Playing 'vm-theperson' (language 'en')
        -- <SIP/200-0a1a0818> Playing 'digits/1' (language 'en')
        -- <SIP/200-0a1a0818> Playing 'digits/0' (language 'en')
        -- <SIP/200-0a1a0818> Playing 'digits/0' (language 'en')
        -- <SIP/200-0a1a0818> Playing 'vm-isunavail' (language 'en')
        -- <SIP/200-0a1a0818> Playing 'vm-intro' (language 'en')
        -- <SIP/200-0a1a0818> Playing 'beep' (language 'en')
        -- Recording the message
        -- x=0, open writing:  /var/spool/asterisk/voicemail/default/100/tmp/CvTddf format: wav49, 0xa0e8928
        -- x=1, open writing:  /var/spool/asterisk/voicemail/default/100/tmp/CvTddf format: wav, 0xa0c21e0
        -- User hung up
      == Spawn extension (macro-vm, s-NOANSWER, 2) exited non-zero on 'SIP/200-0a1a0818' in macro 'vm'
      == Spawn extension (ext-local, vmu100, 1) exited non-zero on 'SIP/200-0a1a0818'
    

    Code:
    elastix*CLI> sip show peers
    Name/username              Host            Dyn Nat ACL Port     Status               
    200/200                    192.168.1.100    D   N      15480    OK (100 ms)           
    100/100                    192.168.1.103    D   N      5060     OK (7 ms)            
    2 sip peers [Monitored: 2 online, 0 offline Unmonitored: 0 online, 0 offline]
    elastix*CLI> 
    
     
  2. jagonza

    Joined:
    Mar 27, 2009
    Messages:
    4
    Likes Received:
    0
    I had a similar problem.
    Can you see the database?

    CLI> database show

    I found that was not possible to access to the database
    Finally I found that the /var/lib/asterisk has not write and access allowed.
    I changed the owner:
    # chowner -R asterisk:asterisk /var/lib/asterisk
    after that I changed the configuration of extensions and all worked again...
    Please tell me if that works for you...
    Jose
     
  3. JohnyBeGood

    Joined:
    May 18, 2008
    Messages:
    134
    Likes Received:
    0
    Thank you!!!!
    Yes, it works.
    Most likely you mis-typed it.
    I had to use chown -R asterisk:asterisk /var/lib/asterisk
    I could not see any DB with database show

    From Reports -> Asterisk Logs:
    Code:
    Mar 27 00:00:01  	VERBOSE  	[2507] logger.c:  	
    
    -- Remote UNIX connection
    
    Mar 27 00:00:02 	VERBOSE 	[3378] logger.c: 	
    
    -- Remote UNIX connection disconnected
    
    Mar 27 00:00:50 	WARNING 	[2606] db.c: 	
    
    Unable to open Asterisk database '/var/lib/asterisk/astdb': Permission denied
    
    Mar 27 00:00:50 	WARNING 	[2606] db.c: 	
    
    Database unavailable
    
    Mar 27 00:00:51 	VERBOSE 	[3381] logger.c: 	
    
    == Parsing '/etc/asterisk/manager.conf': [Mar 27 00:00:51] VERBOSE[3381] logger.c: Found
    
    Mar 27 00:00:51 	VERBOSE 	[3381] logger.c: 	
    
    == Parsing '/etc/asterisk/manager_additional.conf': [Mar 27 00:00:51] VERBOSE[3381] logger.c: Found
    
    Mar 27 00:00:51 	VERBOSE 	[3381] logger.c: 	
    
    == Parsing '/etc/asterisk/manager_custom.conf': [Mar 27 00:00:51] VERBOSE[3381] logger.c: Found
    
    Mar 27 00:00:51 	WARNING 	[3381] config.c: 	
    
    Unknown directive '#permit=192.168.1.0/255.255.255.0' at line 18 of /etc/asterisk/manager_custom.conf
    
    Mar 27 00:00:51 	VERBOSE 	[3381] logger.c: 	
    
    == Manager 'admin' logged on from 127.0.0.1
    
    Mar 27 00:00:51 	VERBOSE 	[3383] logger.c: 	
    
    == Parsing '/etc/asterisk/manager.conf': [Mar 27 00:00:51] VERBOSE[3383] logger.c: Found
    
    Mar 27 00:00:51 	VERBOSE 	[3383] logger.c: 	
    
    == Parsing '/etc/asterisk/manager_additional.conf': [Mar 27 00:00:51] VERBOSE[3383] logger.c: Found
    
    Mar 27 00:00:51 	VERBOSE 	[3383] logger.c: 	
    
    == Parsing '/etc/asterisk/manager_custom.conf': [Mar 27 00:00:51] VERBOSE[3383] logger.c: Found
    
    Mar 27 00:00:51 	WARNING 	[3383] config.c: 	
    
    Unknown directive '#permit=192.168.1.0/255.255.255.0' at line 18 of /etc/asterisk/manager_custom.conf
    
    Mar 27 00:00:51 	VERBOSE 	[3383] logger.c: 	
    
    == Manager 'admin' logged on from 127.0.0.1
    
    Mar 27 00:00:51 	VERBOSE 	[3383] logger.c: 	
    
    == Manager 'admin' logged off from 127.0.0.1
    
    Mar 27 00:00:51 	VERBOSE 	[3381] logger.c: 	
    
    == Manager 'admin' logged off from 127.0.0.1
    
    Mar 27 00:01:04 	VERBOSE 	[3389] logger.c: 	
    
    == Parsing '/etc/asterisk/manager.conf': [Mar 27 00:01:04] VERBOSE[3389] logger.c: Found
    
    Mar 27 00:01:04 	VERBOSE 	[3389] logger.c: 	
    
    == Parsing '/etc/asterisk/manager_additional.conf': [Mar 27 00:01:04] VERBOSE[3389] logger.c: Found
    
    Mar 27 00:01:04 	VERBOSE 	[3389] logger.c: 	
    
    == Parsing '/etc/asterisk/manager_custom.conf': [Mar 27 00:01:04] VERBOSE[3389] logger.c: Found
    
    Mar 27 00:01:04 	WARNING 	[3389] config.c: 	
    
    Unknown directive '#permit=192.168.1.0/255.255.255.0' at line 18 of /etc/asterisk/manager_custom.conf
    
    Mar 27 00:01:04 	VERBOSE 	[3389] logger.c: 	
    
    == Manager 'admin' logged on from 127.0.0.1
    
    Mar 27 00:01:04 	VERBOSE 	[3391] logger.c: 	
    
    == Parsing '/etc/asterisk/manager.conf': [Mar 27 00:01:04] VERBOSE[3391] logger.c: Found
    
    Mar 27 00:01:04 	VERBOSE 	[3391] logger.c: 	
    
    == Parsing '/etc/asterisk/manager_additional.conf': [Mar 27 00:01:04] VERBOSE[3391] logger.c: Found
    
    Mar 27 00:01:04 	VERBOSE 	[3391] logger.c: 	
    
    == Parsing '/etc/asterisk/manager_custom.conf': [Mar 27 00:01:04] VERBOSE[3391] logger.c: Found
    
    Mar 27 00:01:04 	WARNING 	[3391] config.c: 	
    
    Unknown directive '#permit=192.168.1.0/255.255.255.0' at line 18 of /etc/asterisk/manager_custom.conf
    
    Mar 27 00:01:04 	VERBOSE 	[3391] logger.c: 	
    
    == Manager 'admin' logged on from 127.0.0.1
    
    Mar 27 00:01:04 	WARNING 	[3389] db.c: 	
    
    Unable to open Asterisk database '/var/lib/asterisk/astdb': Permission denied
    
    Mar 27 00:01:04 	WARNING 	[3389] db.c: 	
    
    Unable to open Asterisk database '/var/lib/asterisk/astdb': Permission denied
    
    Mar 27 00:01:04 	WARNING 	[3389] db.c: 	
    
    Unable to open Asterisk database '/var/lib/asterisk/astdb': Permission denied
    
    Mar 27 00:01:04 	WARNING 	[3389] db.c: 	
    
    Unable to open Asterisk database '/var/lib/asterisk/astdb': Permission denied
    
    

    Would this be a Elastix bug?
     
  4. jagonza

    Joined:
    Mar 27, 2009
    Messages:
    4
    Likes Received:
    0
    Hi again,
    I see that several problems posted in the forum, have the same raison:
    The directory /var/lib/asterisk don't has the right owner in the stable version of elastix.
    But I don't know how or to who communicate this probable bug. You know it?
     
  5. JohnyBeGood

    Joined:
    May 18, 2008
    Messages:
    134
    Likes Received:
    0
    Hello,

    I would think bugs are reported here http://bugs.elastix.org
    Its odd that only you replied to this thread, does that mean only two of us have this problem?
    Is your Elastix on Dell optiplex gx270 ?

    Thanks
     
  6. robclay

    Joined:
    Mar 25, 2009
    Messages:
    36
    Likes Received:
    0
    I think i have the same problem... How do I get to the CLI?

    I typed "Asterisk -rvvvv" at the actual box running the software but that says:

    "-bash bad command" or something like that...
     
  7. JohnyBeGood

    Joined:
    May 18, 2008
    Messages:
    134
    Likes Received:
    0
    Try this asterisk -r
     
  8. robclay

    Joined:
    Mar 25, 2009
    Messages:
    36
    Likes Received:
    0
    That worked...

    database show had no database found.
    I then exited the CLI and typed in chown -R asterisk:asterisk /var/lib/asterisk
    It seemed to take.

    I typed asterisk -r and typed database show again... and this time there were no error messages... although nothing was displayed. That is probably correct because I just made the database accessible I guess.

    ANyway... I am rebooting the system and will report more in a minute.

    I just downloaded and installed 1.5 stable for the first time on a new system for anyone that is reading this and wondering if it could effect them.
     
  9. JohnyBeGood

    Joined:
    May 18, 2008
    Messages:
    134
    Likes Received:
    0
    Try this chown -R asterisk:asterisk /var/lib/asterisk
    then database show will show DB info.
     
  10. robclay

    Joined:
    Mar 25, 2009
    Messages:
    36
    Likes Received:
    0
    Re:Clicking on

    jagonza wrote:
    ib/asterisk has not write and access allowed.
    I changed the owner:
    # chowner -R asterisk:asterisk /var/lib/asterisk
    after that I changed the configuration of extensions and all worked again...
    Please tell me if that works for you...
    Jose[/quote]

    How do you reapply the configurations? Is there an easy way, or do I delete and start over?

    Thanks!
     
  11. JohnyBeGood

    Joined:
    May 18, 2008
    Messages:
    134
    Likes Received:
    0
    Re:Clicking on

    I'm not sure what do you mean with reapply configurations.
     
  12. robclay

    Joined:
    Mar 25, 2009
    Messages:
    36
    Likes Received:
    0
    Re:Clicking on

    I just deleted all my extensions to start over..
    x3001 = x-lite
    x3002 = Grandstream 2020

    Now I am able to dial from x3001 to x3002, but not from x3002 to x3001.

    I had re-booted the x-lite, but not the grandstream 2020. I rebooted and now I can call each extension.

    - Robert
     
  13. JohnyBeGood

    Joined:
    May 18, 2008
    Messages:
    134
    Likes Received:
    0
    Re:Clicking on

    I'm glad you got it working!
     
  14. repask

    Joined:
    Apr 1, 2009
    Messages:
    8
    Likes Received:
    0
    Re:Clicking on

    yep there is database owner root mistake in the stable 1.5 elastix. Just finished clean install and couldnt place a call, after chown -R asterisk:asterisk /var/lib/asterisk everythin looks like ok.

    thx
     
  15. Aleph

    Joined:
    Feb 28, 2009
    Messages:
    2
    Likes Received:
    0
    Re:Clicking on

    hello all


    i had the same problem with callwaiting ( can't set to enable )

    can't record extension call , and can't show database in the CLI> database show.

    now after changing the owner folder with chown command


    # chown -R asterisk:asterisk /var/lib/asterisk


    i can record , set call waiting and show database
     

Share This Page