click to dial not working

Discussion in 'General' started by tbooth, Feb 17, 2009.

  1. tbooth

    Joined:
    Feb 24, 2007
    Messages:
    338
    Likes Received:
    0
    elastix 1.3 with sugarcrm 4.5.od
    Cannot get the click to dial work work in contacts, doesn't even show the phone icon. Anyone have this working? Here are my setting under System Settings:

    Asterisk® / VoiceRD®
    Enable Asterisk / VoiceRD Integration? (checked)
    Asterisk Server:192.168.0.240
    Asterisk Port:5038
    Asterisk Username:501
    Asterisk Secret:xxxxxx
    Asterisk Context:from-internal
    Asterisk Prefix:9
    Asterisk Phone Icon: (checked) but no icon appears??
    Asterisk Popup Timer: 20

    There is no info at Sugars website on setup.

    Any help would be greatly appreciated.
     
  2. Chilling_Silence

    Joined:
    Sep 23, 2008
    Messages:
    488
    Likes Received:
    0
    Username / Secret are wrong, check in /etc/asterisk/managers.conf and the related files :)

    You're establishing a connection to the AMI, not as an Ext but as an Asterisk Administrator. The usernames / passwords you can use are in managers*.conf :)

    Or, you can add a new entry, just make sure you dont allow more than you have to ;)
     
  3. tbooth

    Joined:
    Feb 24, 2007
    Messages:
    338
    Likes Received:
    0
    I see the password (secret) in the file. Would the user name be admin?
    Can I change the secret?
     
  4. tbooth

    Joined:
    Feb 24, 2007
    Messages:
    338
    Likes Received:
    0
    I made the changes and did a restart and still no phone icon for click to dial from the contacts.
     
  5. tbooth

    Joined:
    Feb 24, 2007
    Messages:
    338
    Likes Received:
    0
    ok I have the phone icon by the contacts phone number. When I click the icon the pop opens and says dialing 9+ 775-4321 but it doe not dial out. here is the log:



    [root@host ~]# asterisk -rvv
    Asterisk 1.4.22-rc5, Copyright (C) 1999 - 2008 Digium, Inc. and others.
    Created by Mark Spencer <markster@digium.com>
    Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
    This is free software, with components licensed under the GNU General Public
    License version 2 and other licenses; you are welcome to redistribute it under
    certain conditions. Type 'core show license' for details.
    =========================================================================
    == Parsing '/etc/asterisk/asterisk.conf': Found
    == Parsing '/etc/asterisk/extconfig.conf': Found
    Connected to Asterisk 1.4.22-rc5 currently running on host (pid = 14113)
    Verbosity is at least 3
    -- Remote UNIX connection disconnected
    == Parsing '/etc/asterisk/manager.conf': Found
    == Parsing '/etc/asterisk/manager_additional.conf': Found
    == Parsing '/etc/asterisk/manager_custom.conf': Found
    == Parsing '/etc/asterisk/manager.conf': Found
    == Parsing '/etc/asterisk/manager_additional.conf': Found
    == Parsing '/etc/asterisk/manager_custom.conf': Found
    == Connect attempt from '192.168.0.240' unable to authenticate
    == Connect attempt from '192.168.0.240' unable to authenticate
    == Parsing '/etc/asterisk/manager.conf': Found
    == Parsing '/etc/asterisk/manager_additional.conf': Found
    == Parsing '/etc/asterisk/manager_custom.conf': Found
    == Connect attempt from '192.168.0.240' unable to authenticate
    -- Remote UNIX connection
    -- Remote UNIX connection disconnected
    host*CLI>
     
  6. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    For AMI users and passwords have a look at /etc/asterisk/manager.conf (and also the rest of manager*.conf)
    The admin default password is elastix456
     
  7. Chilling_Silence

    Joined:
    Sep 23, 2008
    Messages:
    488
    Likes Received:
    0
    Thats because the user "admin" can only be logged in-as from the box its running on. Whilst SugarCRM is hosted on the Elastix box, its probably initiating the connection to the AMI from your PC on port 5038

    change:
    To:
    We've gone and created individual accounts for our additional applications in /etc/asterisk/manager_custom.conf

    Hope this helps


    Chill.
     
  8. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    tbooth, try the following:
    1. login into sugar crm
    2. click on: "Admin" -> system settings
    3. put the following info:
    Enable Asterisk / VoiceRD Integration?: ON
    Enable Asterisk / VoiceRD Pro Version: OFF
    Asterisk Server: localhost (since sugar crm is on the same elastix server)
    Asterisk Port: 5038
    Asterisk Username: admin
    Asterisk Secret: elastix456
    Asterisk Context: from-internal
    Asterisk Prefix: leave it blank...
    Asterisk Phone Icon: ON
    Asterisk Popup Timer: 20
    4. save button
    5. click on: "My Account"
    6. edit button, put the following info:
    Asterisk Phone Extension: 503 (this is my extension, no need to set the protocol)
    7. save button
     
  9. Terry

    Joined:
    May 25, 2007
    Messages:
    174
    Likes Received:
    0
    I am follow your step by step rule
    How can I test click and dial
    Where can i start ?
    Thanks
    Terry
     
  10. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Hi,
    To start testing, login into sugarcrm web interface and on the left shortcut area click on "create contact", and then fill up the basic information of your contact (name, phone number,etc). Just take into account that the phone number should match with the outbound rules that you have already defined on the Elastix web interface
     
  11. cysuser

    Joined:
    Sep 16, 2010
    Messages:
    3
    Likes Received:
    0
    Hi all,

    I am a new user of Asterisk + SugarCRM. Sorry for refloat this old thread but I also found the same problem: My click-to-dial from SugarCRM only shows a pop-up window telling me that is Dialing...[Extn] but nothing happens!

    I followed the instructions from http://www.voicerd.org/index.php/VoiceRD_/_Asterisk_Integration_for_SugarCRM and I think it is OK. I also configured Asterisk following several instrucions + forums.

    Let me paste some clues:

    Asterisk 1.6.2.7

    I configured some SIP extensions (1001, 1002, 1003, 1004). The context is "from-internal". We can dial from one extension to other using X-Lite SIP phone (Asterisk works!). We also can dial from one SIP extension to a CISCO Call Manager extension (Dial plan and trunks also works!).

    I configured manager.conf with the following:

    [sugaruser]
    secret = secretpass
    permit=0.0.0.0/0.0.0.0 <-- allow ALL for test purposes
    ;permit=127.0.0.1/255.255.255.0 <-- commented
    ;permit=10.0.0.155/255.255.248.0 <-- commented
    read = system,call,log,verbose,command,agent,user
    write = system,call,log,verbose,command,agent,user

    SugarCRM 5.5.1 with Asterisk Voice RD Integration (http://www.sugarforge.org/frs/?group_id=204)

    Admin --> System Settings (Asterisk)

    Enable Asterisk Integration [X]
    Enable Asterisk Pro [] (unchecked, I have sugarcrm CE)
    Asterisk Server: [IP address]
    Asterisk Port: 5038
    Asterisk Username: sugaruser
    Asterisk Secret: secretpass
    Asterisk Internal context: from-internal
    Asterisk External Context: from-internal
    Asterisk Phone Icon [X]

    There is no place to configure a timeout.

    Finally, we configured "My Account" to have the Extension "SIP/1004" and created a contact with the phone "1003" (we also tried using "SIP/1003").

    From Asterisk, when increasing the trace level (we used 26 "v"! -verbose-):

    cd /etc/asterisk
    asterisk -vvvvvvvvvvvvvvvvvvvvvvvvvvr

    The only output is:

    localhost*CLI>
    == Manager 'sugaruser' logged on from 10.0.0.155 <-- the IP from the user trying to call
    == Manager 'sugaruser' logged off from 10.0.0.155


    Asterisk full log file:
    [Sep 16 14:46:30] VERBOSE[4539] manager.c: == Manager 'sugaruser' logged on from 10.0.0.155
    [Sep 16 14:46:30] VERBOSE[4539] manager.c: == Manager 'sugaruser' logged off from 10.0.0.155

    are we missing something?

    Thanks a lot!

    * PS: Sorry for my english!
     
  12. cysuser

    Joined:
    Sep 16, 2010
    Messages:
    3
    Likes Received:
    0
    Re: click to dial not working [SOLVED]

    Hello,

    The problem is solved. It is necessary to add "originate" permissions to the user in manager.conf

    Thank you
     
  13. cysuser

    Joined:
    Sep 16, 2010
    Messages:
    3
    Likes Received:
    0
    Re: click to dial not working [SOLVED]

    REPEATED, sorry
     
  14. siggy

    Joined:
    May 24, 2010
    Messages:
    4
    Likes Received:
    0
    Hi All;))

    Chilling_Silence had it right for X Lite 3.0

    X Lite 3.0
    You have to match the "secret" in asterisk with the password in properties, account, password
    Domain Proxy
    Check the Register with domain box
    Then set to Target Domain, under Domain proxy

    but make sure and copy your old script before changing, and saving it somewhere, just in case.

    SugarCRM

    I use WinSCP
    /<root>/etc/asterisk/manager.conf

    Thats because the user "admin" can only be logged in-as from the box its running on. Whilst SugarCRM is hosted on the Elastix box, its probably initiating the connection to the AMI from your PC on port 5038

    [admin]
    secret = elastix456
    deny=0.0.0.0/0.0.0.0
    permit=127.0.0.1/255.255.255.0
    read = system,call,log,verbose,command,agent,user
    write = system,call,log,verbose,command,agent,user
    To:
    [admin]
    secret = elastix456
    deny=0.0.0.0/0.0.0.0
    permit=127.0.0.1/255.255.255.0 192.168.0.1/255.255.255.0
    read = system,call,log,verbose,command,agent,user
    write = system,call,log,verbose,command,agent,user

    We've gone and created individual accounts for our additional applications in /etc/asterisk/manager_custom.conf[/color]
     
  15. siggy

    Joined:
    May 24, 2010
    Messages:
    4
    Likes Received:
    0
    Hi All;))

    Chilling_Silence had it right for X Lite 3.0

    X Lite 3.0
    You have to match the "secret" in asterisk with the password in properties, account, password
    Domain Proxy
    Check the Register with domain box
    Then set to Target Domain, under Domain proxy

    but make sure and copy your old script before changing, and saving it somewhere, just in case.

    SugarCRM

    I use WinSCP
    /<root>/etc/asterisk/manager.conf

    Thats because the user "admin" can only be logged in-as from the box its running on. Whilst SugarCRM is hosted on the Elastix box, its probably initiating the connection to the AMI from your PC on port 5038

    [admin]
    secret = elastix456
    deny=0.0.0.0/0.0.0.0
    permit=127.0.0.1/255.255.255.0
    read = system,call,log,verbose,command,agent,user
    write = system,call,log,verbose,command,agent,user
    To:
    [admin]
    secret = elastix456
    deny=0.0.0.0/0.0.0.0
    permit=127.0.0.1/255.255.255.0 192.168.0.1/255.255.255.0
    read = system,call,log,verbose,command,agent,user
    write = system,call,log,verbose,command,agent,user

    We've gone and created individual accounts for our additional applications in /etc/asterisk/manager_custom.conf[/color]
     
  16. Stdesampa

    Joined:
    May 12, 2011
    Messages:
    4
    Likes Received:
    0
    Re: Re:click to dial not working

    I have elastix 2.2
    Asterisk 1.8
    Sugarcrm 5.5
    all this on one compueter together.

    I try voicerd integration asterisk-sugarcrm, but still not working.
    Need some help

    in manager.conf i have:
    [general]
    enabled = yes
    port = 5038
    bindaddr = 0.0.0.0
    displayconnects=yes ;only effects 1.6+

    [admin]
    secret = schm1234
    deny=0.0.0.0/0.0.0.0
    permit=127.0.0.1/255.255.255.0 172.28.228.1/255.255.255.0
    read = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate
    write = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate

    [sugaruser]
    secret = secret
    deny=0.0.0.0/0.0.0.0
    permit=127.0.0.1/255.255.255.0 172.28.228.1/255.255.0.0
    ;permit=127.0.0.1/255.255.255.255
    read = system,call,log,verbose,command,agent,user
    write = system,call,log,verbose,command,agent,user


    in sugarcrm i have:

    i fill that information on voicerd like this:
    Enable Asterisk / VoiceRD Integration?: ON
    Enable Asterisk / VoiceRD Pro Version: OFF
    Asterisk Server: 127.0.0.1 (since sugar crm is on the same elastix server)
    Asterisk Port: 5038
    Asterisk Username: sugaruser
    Asterisk Secret: secret
    Asterisk Context: from-internal
    Asterisk Prefix: leave it blank...
    Asterisk Phone Icon: ON
    Asterisk Popup Timer: 20

    and fill the check proxi too.
    Server: 127.0.0.1
    autentification: check
    user: admin
    pass: schm1234

    on cli just say:

    -- Remote UNIX connection
    -- Remote UNIX connection disconnected
    host*CLI>

    Any ideas??
    Thanks

    Stuart
     
  17. Stdesampa

    Joined:
    May 12, 2011
    Messages:
    4
    Likes Received:
    0
    Re: Re:click to dial not working

    update

    cli just said
    manager usersugar log on
    Manager usersugar log off
     
  18. Stdesampa

    Joined:
    May 12, 2011
    Messages:
    4
    Likes Received:
    0
    Re: Re:click to dial not working

    update

    in my acount i check autopickup asterisk and im enable now to make a call

    But went my sip phone ring and aswer the call drop up
    I change the context from internal to ptsn and my sip phone ring im answer the call and sound my ivr..

    Help?
     

Share This Page