Clean install 1.6.2RC2 breaks after first yum

Discussion in 'General' started by antone, Jul 23, 2010.

  1. antone

    Joined:
    Mar 1, 2010
    Messages:
    17
    Likes Received:
    0
    After trying Elastix 2RC3, I got problems after first update, so I installed 1.6.2RC2 and the same happens.
    I have 2 cards: TDM800P (8 FXO modules) and a HFC ISDN card.
    Without doing any config, I just :
    • install from CD
      detects TDM800P and gives usual ISDN message (Elastix hardware detection)
      do a /etc/init.d/dahdi restart (all fine)
      do a yum (default repos)
      do a /etc/init.s/dahdi restart
      modules fail like below, Elastix hardware detection detects no cards.

    I tried to rebuild dadhi, kernel, whatever but could not get it to work.
    Tried reinstalling about 10 times with 2.0RC3 and 1.6.2RC2 but everytime after 1st yum update, this hapens. I suspect it is because of the ISDN card.

    ANYONE HAVE A FIX FOR THIS? I'VE READ EVERY DADHI/ISDN SITE/FORUM I COULD FIND, BUT NOTHING SEEMED TO HELP. (No, this is not shouting, just compensating for weak bold ;-) )

    /etc/init.d/dahdi restart
    Unloading DAHDI hardware modules: ERROR: Module wctdm24xxp is in use
    ERROR: Module wctdm24xxp is in use
    ERROR: Module dahdi_voicebus is in use by wctdm24xxp
    ERROR: Module dahdi_echocan_oslec is in use
    ERROR: Module dahdi is in use by dahdi_echocan_oslec,wctdm24xxp,dahdi_voicebus
    ERROR: Module dahdi_echocan_oslec is in use
    ERROR: Module echo is in use by dahdi_echocan_oslec
    error
    Loading DAHDI hardware modules:
    FATAL: Module dahdi not found.
    wct4xxp: FATAL: Module wct4xxp not found. [FAILED]
    opvxd115: FATAL: Module opvxd115 not found. [FAILED]
    wcte12xp: FATAL: Module wcte12xp not found. [FAILED]
    wct1xxp: FATAL: Module wct1xxp not found. [FAILED]
    wcte11xp: FATAL: Module wcte11xp not found. [FAILED]
    wctdm24xxp: FATAL: Module wctdm24xxp not found. [FAILED]
    wcfxo: FATAL: Module wcfxo not found. [FAILED]
    wctdm: FATAL: Module wctdm not found. [FAILED]
    wcb4xxp: FATAL: Module wcb4xxp not found. [FAILED]
    wctc4xxp: FATAL: Module wctc4xxp not found. [FAILED]
    xpp_usb: FATAL: Module xpp_usb not found. [FAILED]
    opvxa1200: FATAL: Module opvxa1200 not found. [FAILED]
    ystdm8xx: FATAL: Module ystdm8xx not found. [FAILED]
    ystdm16xx: FATAL: Module ystdm16xx not found. [FAILED]
    ap400: FATAL: Module ap400 not found. [FAILED]
    dahdi_dynamic_eth: FATAL: Module dahdi_dynamic_eth not found.[FAILED]
    dahdi_dynamic_ethmf: FATAL: Module dahdi_dynamic_ethmf not found.[FAILED]
    ax1600p: FATAL: Module ax1600p not found. [FAILED]
    rxt1: FATAL: Module rxt1 not found. [ OK ]
    r1t1: FATAL: Module r1t1 not found. [ OK ]
    rcbfx: FATAL: Module rcbfx not found. [ OK ]
    Running dahdi_cfg: [ OK ]



    After this error, I try:
    [root@voip ~]# depmod
    [root@voip ~]# modprobe dahdi
    FATAL: Module dahdi not found.
    [root@voip ~]# modprobe wctdm24xxp
    FATAL: Module wctdm24xxp not found.

    [root@voip ~]# dahdi_cfg module
    Notice: Configuration file is /etc/dahdi/system.conf
    line 0: Unable to open master device '/dev/dahdi/ctl'


    [root@voip ~]# dahdi_genconf
    Empty configuration -- no spans
    Empty configuration -- no spans


    [root@voip ~]# dahdi_hardware
    pci:0000:00:09.0 wctdm24xxp- d161:0800 Wildcard TDM800P
    pci:0000:00:0b.0 zaphfc- 1397:2bd0 HFC-S ISDN BRI card

    [root@voip ~]# dahdi_tool
    Unable to open /dev/dahdi/ctl: No such file or directory

    [root@voip ~]# dahdi_scan
    Unable to open /dev/dahdi/ctl: No such file or directory

    [root@voip ~]# dahdi_maint
    DAHDI Tools Version - 2.3.0
     
  2. MrEmbedded

    Joined:
    Jan 15, 2009
    Messages:
    4
    Likes Received:
    0
    Did you ever fix this issue. I am having a similar problem with dahdi.
     
  3. MrEmbedded

    Joined:
    Jan 15, 2009
    Messages:
    4
    Likes Received:
    0
    I rolled back to kernel 2.6.18-164 and reconfigured all the dahdi stuff and its working again. Hope that helps someone
     
  4. antone

    Joined:
    Mar 1, 2010
    Messages:
    17
    Likes Received:
    0
    I downloaded latest Elastix install and it did not happen again.
     

Share This Page