Cisco 7940, What do i do wrong ?

Discussion in 'General' started by mvrossum, Mar 28, 2009.

  1. mvrossum

    Joined:
    Mar 20, 2009
    Messages:
    5
    Likes Received:
    0
    Goodmorning,

    I try to get a Cisco 7940 to work, but without success.
    1) I use a clean elastix installation (1.5-9 it says) with a X100P FXO card on a dedicated pc
    2) Set up the network parameters, hostname, fixed ip address, dns server address en default gateway.
    3) in hardware detection, i check:Replace file chan_dahdi.conf box and thecard is detected an reported in use.
    4) In General setting i change the country to: Netherlands, allow anonymous sip calls to: yes
    5) Create generic sip device
    6) User extention : 100, Display name : Mike, Secret : 100
    7) Submit, and apply changes
    8) Endpointscan, slect my phone, set type and extension. Result: Configured without incident.
    9) User extention : 101, Display name : Ivon, Secret : 101
    10) configure Bol2000 softfone, and when i dial from it to 9(anything) i can call the world !!
    so only 10 easy steps to get the softphone and dialout trunk to work.

    For the 7940 however i ran into some problems. it says Phone Unprovisioned.
    In the tftpboot directory there is a <mac-address>.cnf file created. unfortunately with the mac-address in lower-case and without the SIP in front of it. Looking in the file it looks more like a SIPDefault.cnf file to me because there is no specific line or phone information in it.
    So i renamed it from <mac-address>.cnf to SIP<mac-address>.cnf, and added the line and user information in it.
    Code:
    line1_displayname: "100"
    line1_name: "100"
    line1_shortname: "100"
    line1_authname: "100"
    line1_password: "100"
    
    with the result a semi working phone named 100 with line 100 and an X next to the line number, indicating it is not registerd.
    So, what do i do wrong ?

    Thanks,
    Mike
     
  2. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
    in your extension check that:

    qualify = no
    nat = yes/no depending on your network

    in the tftp directory you will need a SIPDefault and a SIPmac

    The SIP Default has all the general config of your network, the SIPmac will have the line info


    Also, please change your secret by something strong, and DO NOT use the extension number as secret. You'll be sorry if you do...
     
  3. mvrossum

    Joined:
    Mar 20, 2009
    Messages:
    5
    Likes Received:
    0
    Thanks, success at last.

    Best regards,
    Mike.

    (still wondering what the Qualify checkbox is for though.)
     

Share This Page