cisco 2801 fxo-fxs funcioando con elastix

Discussion in 'Elastix 2.x' started by nelsonjoya, Jul 18, 2010.

  1. nelsonjoya

    Joined:
    Jun 25, 2010
    Messages:
    3
    Likes Received:
    0
    cordial saludo
    amigos del foro

    me didijo a ustedes para comentarles como configure un router cisco 2801 el cua cuenta 1 tarjeta vic24fxo y una tarjeta vic fxs/did la cuales quedaron funcioando con elastix
    recuerden que los puertos de las tarjetas no son iguales ej. 0/0/0 0/0 esto depende del tipo d tarjeta que instalen en su router cisco para que la cambien segun en mi configuracion
    puertos 0/0/0 0/0/1 0/0/2 0/0/3 son las fxo
    puertos 0/1/0 0/1/1 0/1/2 0/1/3 son las fxs

    esta es la configuracion de mi router cisco 2801

    !This is the running config of the router: 10.1.1.1
    !----------------------------------------------------------------------------
    !version 12.4
    service config
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname NELSONJOYA
    !
    boot-start-marker
    boot-end-marker
    !

    no aaa new-model
    clock timezone PCTime -5
    !
    !
    dot11 syslog
    ip source-route
    !
    !
    !
    !
    ip cef
    ip domain name yourdomain.com
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    voice call send-alert
    voice rtp send-recv
    !
    voice service pots
    !
    voice service voip
    !
    !
    voice class codec 1
    codec preference 1 g711ulaw
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice-card 0
    !
    !
    application
    service dsapp
    param callWaiting TRUE
    !
    global
    service default dsapp
    !
    !
    !
    !
    username cisco privilege 15 view root secret 5 cisco
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 10.1.1.1 255.255.255.0 --direccion ip router cisco
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface FastEthernet0/3/0
    !
    interface FastEthernet0/3/1
    !
    interface FastEthernet0/3/2
    !
    interface FastEthernet0/3/3
    !
    interface Vlan1
    no ip address
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 10.1.1.2 --direccion ip router o modem internet
    ip http server
    ip http access-class 23
    ip http authentication local
    no ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 0/0/0
    supervisory disconnect dualtone mid-call
    cptone PE
    timing hookflash-out 500
    connection plar 1104 --extencion trunk pstn tarjeta fxo
    station-id name 1104
    caller-id enable
    !
    voice-port 0/0/1
    !
    voice-port 0/0/2
    !
    voice-port 0/0/3
    !
    voice-port 0/1/0
    mwi
    timeouts call-disconnect 5
    station-id name fxs cisco
    station-id number 1100 --extencion 1100 tarjeta fxs
    caller-id enable
    !
    voice-port 0/1/1
    mwi
    timeouts call-disconnect 5
    station-id name PSTN
    station-id number 1101 --extencion 1101 tarjeta fxs
    caller-id enable
    !
    voice-port 0/1/2
    !
    voice-port 0/1/3
    !
    ccm-manager fax protocol cisco
    !
    mgcp fax t38 ecm
    !
    !
    !
    dial-peer voice 10 pots --el dial peer es para validar el sip de la extencion elastix
    destination-pattern 1100
    port 0/1/0
    !
    dial-peer voice 11 pots --cuando creen la extencion sip dejarla sin password
    destination-pattern 1101
    port 0/1/1
    !
    dial-peer voice 100 voip
    destination-pattern 1...
    voice-class codec 1
    session protocol sipv2
    session target sip-server
    dtmf-relay sip-notify rtp-nte
    no vad
    !
    dial-peer voice 12 pots
    destination-pattern 1102 --extencion 1102 tarjeta fxs
    port 0/1/2
    !
    dial-peer voice 13 pots
    destination-pattern 1103 ----extencion 1103 tarjeta fxs
    port 0/1/3
    !
    dial-peer voice 14 pots
    description LLAMADAS FIJOS
    destination-pattern [2-8]...... --aca se meten los prejijos o sea que marque de 2 a 8 digitos para pstn
    incoming called-number .
    no digit-strip
    direct-inward-dial
    port 0/0/0
    forward-digits all
    !
    dial-peer voice 16 pots
    destination-pattern 1104
    port 0/0/0
    !
    !
    sip-ua
    authentication username cisco password 7 070C285F4D06485744 --el pass es cisco123
    retry invite 3
    retry response 3
    retry bye 3
    retry cancel 3
    timers trying 1000
    mwi-server ipv4:10.1.1.3 expires 3600 port 5060 transport udp
    registrar ipv4:10.1.1.3:5060 expires 3600
    sip-server ipv4:10.1.1.3
    !
    !
    !
    gatekeeper
    shutdown
    !
    banner login ^CBIENVENIDO A LA CONFIGURACION ROUTER CISCO 2801 Njr --mensaje de acceso telnet o hiperterminal ^C
    !
    line con 0
    login local
    line aux 0
    line vty 0 4
    privilege level 15
    login local
    transport input telnet
    line vty 5 15
    privilege level 15
    login local
    transport input telnet
    !
    scheduler allocate 20000 1000
    end


    en elastix crean una troncal sip y meten los siguientes datos:
    dial rules
    NXXXXXX esto es para que se marque un numero de 7 digitos y tome la fxo cisco PSTN

    trunkname
    el que deceen yo la llamo cisco fxo-fxs

    peer details
    allow=ulaw
    canreinvite=no
    context=from-internal
    disallow=all
    dtmfmode=rfc2833
    host=10.1.1.1
    insecure=very
    qualify=yes
    secret=cisco123
    type=peer
    username=cisco

    user details
    dejenlo en blanco

    espero les sirva esta configuracion ya que me tomo bastante tiempo hacerla funcionar, igualmente les informo que las extenciones sip tienen que ser de 4 digitos ya que cisco no acepta menos de esto o si no les funcionara la configuracion mis extenciones inician de 1100 en adelante.
    cuando creen las extenciones sip para las tarjetas fxs dejenlas sin password para que no les genere problemas.
    cualquier duda me comentan

    cordialmente
    nelson joya
     
  2. pinkita

    Joined:
    Aug 6, 2010
    Messages:
    2
    Likes Received:
    0
    Hola, te hago una consulta, configure un router 1751 con una VIC-2FXS, la forma de registrarse con elastix es como la tuya, pero si reinicio el router con un reload solo puedo realizar llamadas de los telefonos del router hacia otros internos pero de otros internos a las extensiones del router da error de unavailable. En el router figura con que los peer estan registrados. Lo mismo me pasa si no lo reinicio pero dejo esperar un tiempo, entro en el FOP de elastix y figuran en color verde pero claro, no puedo recibir llamadas pero puedo realizarlas desde las extensiones del router. Sabras que puede estar pasando?
    Te agradeceria si me puedes ayudar.
    Saludos
    Sebastian
     
  3. nelsonjoya

    Joined:
    Jun 25, 2010
    Messages:
    3
    Likes Received:
    0
    el error es por que las extenciones quedan registradas en elastix si reinicias el route puas pierden registro hasta que el router las registre igualmente la configuracion que di es para que funcione con asterisk no con call manager cualquier cosa me preguntas
     
  4. grupohzone

    Joined:
    Feb 1, 2012
    Messages:
    14
    Likes Received:
    0
    Hola amigo tengo una duda ya configure mis fxs tomando en base este post.

    Funcionan las FXS recibiendo llamadas de otras extensiones

    Pero NO pueden realizar llamadas las fxs a otras extensiones al parecer toma linea directa de la fxo. que me falta para enrutar. ???

    Saludos

    configuración:

    Voice Port
    #############################################

    voice-port 0/1/1
    mwi
    timeouts call-disconnect 5
    description OFICINA 2 FXS 1
    station-id name fxs CISCO-3101
    station-id number 3101
    caller-id enable
    !
    voice-port 0/1/2
    mwi
    timeouts call-disconnect 5
    description OFICINA 3 FXS 2
    station-id name fxs CISCO-3102
    station-id number 3102
    !
    voice-port 0/1/3
    mwi
    timeouts call-disconnect 5
    description OFICINA 4 FXS 3
    station-id name fxs CISCO-3103
    station-id number 3103
    caller-id enable

    dial-peer voice pots
    ################################################

    dial-peer voice 3101 pots
    description Extension para Elastix 3101
    destination-pattern 3101
    port 0/1/1
    !
    dial-peer voice 3102 pots
    description Extension para Elastix 3102
    destination-pattern 3102
    port 0/1/2
    !
    dial-peer voice 3103 pots
    description Extension para Elastix 3103
    destination-pattern 3103
    port 0/1/3
     

Share This Page