CID Superfecta 2.2.0 Not showing caller id

Discussion in 'General' started by amartin, Sep 14, 2009.

  1. amartin

    Joined:
    Sep 11, 2008
    Messages:
    37
    Likes Received:
    0
    I installed CID Superfecta and tested it with debug and that works great.
    I also tried:
    https://10.0.40.2/admin/modules/superfecta
    /bin/callerid.php?thenumber=XxxXxxXxxx

    that works also.

    I added RewriteCond %{REQUEST_URI} !(/admin/modules/superfecta/*) /etc/httpd/conf.d/elastix.conf

    Here is a read out from my CLI any help would be appreciated.

    Code:
    Verbosity is at least 3
        -- Executing [0200800221xxxx@from-pstn:1] NoOp("SIP/BandtelE-0a2dc538", "Catch-All DID Match - Found 0200800221xxxx - You probably want a DID for this.") in new stack
        -- Executing [020080022xxxx@from-pstn:2] Goto("SIP/BandtelE-0a2dc538", "ext-did|s|1") in new stack
        -- Goto (ext-did,s,1)
        -- Executing [s@ext-did:1] Set("SIP/BandtelE-0a2dc538", "__FROM_DID=s") in new stack
        -- Executing [s@ext-did:2] ExecIf("SIP/BandtelE-0a2dc538", "1 |Set|CALLERID(name)=6031234567") in new stack
        -- Executing [s@ext-did:3] Ringing("SIP/BandtelE-0a2dc538", "") in new stack
        -- Executing [s@ext-did:4] Wait("SIP/BandtelE-0a2dc538", "1") in new stack
        -- Executing [s@ext-did:5] Set("SIP/BandtelE-0a2dc538", "__CALLINGPRES_SV=allowed_not_screened") in new stack
        -- Executing [s@ext-did:6] SetCallerPres("SIP/BandtelE-0a2dc538", "allowed_not_screened") in new stack
        -- Executing [s@ext-did:7] Set("SIP/BandtelE-0a2dc538", "_RGPREFIX=Incoming:") in new stack
        -- Executing [s@ext-did:8] Set("SIP/BandtelE-0a2dc538", "CALLERID(name)=Incoming:6031234567") in new stack
        -- Executing [s@ext-did:9] Goto("SIP/BandtelE-0a2dc538", "timeconditions|1|1") in new stack
        -- Goto (timeconditions,1,1)
        -- Executing [1@timeconditions:1] GotoIfTime("SIP/BandtelE-0a2dc538", "08:15-17:00|mon-fri|*|*?ivr-2|s|1") in new stack
        -- Goto (ivr-2,s,1)
        -- Executing [s@ivr-2:1] Set("SIP/BandtelE-0a2dc538", "MSG=custom/Intro&custom/If_you_know_Parties_Extension&custom/sales&custom/press1&custom/support&custom/press2&custom/for_accounting&custom/press3&custom/for_dial_by&custom/press4&custom/for_asstance&custom/press0") in new stack
        -- Executing [s@ivr-2:2] Set("SIP/BandtelE-0a2dc538", "LOOPCOUNT=0") in new stack
        -- Executing [s@ivr-2:3] Set("SIP/BandtelE-0a2dc538", "__DIR-CONTEXT=default") in new stack
        -- Executing [s@ivr-2:4] Set("SIP/BandtelE-0a2dc538", "_IVR_CONTEXT_ivr-2=") in new stack
        -- Executing [s@ivr-2:5] Set("SIP/BandtelE-0a2dc538", "_IVR_CONTEXT=ivr-2") in new stack
        -- Executing [s@ivr-2:6] GotoIf("SIP/BandtelE-0a2dc538", "0?begin") in new stack
        -- Executing [s@ivr-2:7] Answer("SIP/BandtelE-0a2dc538", "") in new stack
        -- Executing [s@ivr-2:8] Wait("SIP/BandtelE-0a2dc538", "1") in new stack
        -- Executing [s@ivr-2:9] Set("SIP/BandtelE-0a2dc538", "TIMEOUT(digit)=3") in new stack
        -- Digit timeout set to 3
        -- Executing [s@ivr-2:10] Set("SIP/BandtelE-0a2dc538", "TIMEOUT(response)=10") in new stack
        -- Response timeout set to 10
        -- Executing [s@ivr-2:11] Set("SIP/BandtelE-0a2dc538", "__IVR_RETVM=") in new stack
        -- Executing [s@ivr-2:12] ExecIf("SIP/BandtelE-0a2dc538", "1|Background|custom/Intro&custom/If_you_know_Parties_Extension&custom/sales&custom/press1&custom/support&custom/press2&custom/for_accounting&custom/press3&custom/for_dial_by&custom/press4&custom/for_asstance&custom/press0") in new stack
        -- <SIP/BandtelE-0a2dc538> Playing 'custom/Intro' (language 'en')
    
     
  2. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
    Sorry, I haven't seen your question earlier.

    Did you select in your inbound route (catch all in that case), the CID source as Superfecta?

    Also, what sources did you choose in the superfecta setup page? Do you have by any chance the Trunk_provided enabled near the top of your list?
    It seems that your provider is giving in addition to a CID number, a CID name that is the same.
    If you've selected Trunk_provided, it will keep-it.
    There's a new version of Trunk_provided that should be available for online upgrade tomorrow that will ignore a trunk provided if the CID name = CID number.
     

Share This Page