chanspy

mattrh

Joined
Jul 15, 2008
Messages
175
Likes
0
Points
0
#1
Hello all,

So i upgraded from Elastix 1.3 to 1.6. Everything looks like its working except chanspy. I press 555 and i am only able to hear one side of the conversation. any ideas?

thanks all
 

grufftech

Joined
Jan 13, 2010
Messages
2
Likes
0
Points
0
#2
i did the same -- had 1.3 for about two years running our primary office, we were moving buildings over new years day weekend, so i figured we'd rebuild to get the latest software upgrades and a clean install.... Upon doing so however everything works like a charm, and i LOVE some of the new additions, however ChanSpy only monitors one side of the phone call.

[app-chanspy-custom]
exten => 5555,1,Answer
exten => 5555,2,Wait(1)
exten => 5555,3,Goto(custom-app-enh-chanspy,s,1)
exten => 5555,4,Hangup

[custom-app-enh-chanspy]
exten => s,1,BackGround(please-enter-the)
exten => s,n,Read(SPYNUM|extension)
exten => s,n,ChanSpy(SIP/${SPYNUM}|q)

I have my own ChanSpy app in my extensions_custom.conf, however i have this problem with both the built-in ChanSpy as well as my custom one.

Anyone know whats up?

I'm using the most recent Elastix install (as of 2 weeks ago) with Broadvox SIP trunks.
 

mattrh

Joined
Jul 15, 2008
Messages
175
Likes
0
Points
0
#3
i just did a yum update and there was an asterisk update that fixed the issue. give that a try. also do you use streaming MOH? (mpg123) mine doesnt work at all and freaks out when i try to use it. i have tried different source ip's but still same result. let me know
 

grufftech

Joined
Jan 13, 2010
Messages
2
Likes
0
Points
0
#4
i have not tried that yet however i don't really have a need for it.

will try the update tonight to make see if it works.
 

jgutierrez

Joined
Feb 28, 2008
Messages
5,737
Likes
0
Points
0
#5
Yes that is correct, there was an internal bug (on our side) with the chanspy application, it was corrected on asterisk 1.4.28.1, by the way, in that version we have already enabled the backport feature from asterisk 1.6 that lets you hear only the outbound voice from the channel that you are spying, try it using option o (that was the reason for the bug) :blush:
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top