Chanspy and whisper mode

Discussion in 'General' started by alfil2k, Nov 23, 2009.

  1. alfil2k

    Joined:
    Aug 17, 2009
    Messages:
    25
    Likes Received:
    0
    Hi all,

    I have some problems when I try to setup whisper mode for chanspy funtion. The extension_custom.conf is like that:

    [spy]
    exten => 779,1,Macro(user-callerid)
    exten => 779,2,Authenticate(2143)
    exten => 779,3,Read(SPYNUM,,3)
    exten => 779,4,ChanSpy(SIP/${SPYNUM},v2)
    exten => 779,5,Hangup()
    exten => _778X.,1,Macro(user-callerid)
    exten => _778X.,n,ChanSpy(SIP/${EXTEN:3},w)
    exten => _778X.,n,Hangup()

    I can hear the conversation, but the agent is not hearing me. The debug show:

    [Nov 18 14:13:37] DEBUG[7164] audiohook.c: Failed to get 160 samples from write factory 0xb6d319bc
    [Nov 18 14:13:37] DEBUG[7164] channel.c: Internal timing is disabled (option_internal_timing=0 chan->timingfd=35)
    [Nov 18 14:13:37] DEBUG[7164] audiohook.c: Failed to get 160 samples from write factory 0xb6d319bc
    [Nov 18 14:13:37] DEBUG[7164] channel.c: Internal timing is disabled (option_internal_timing=0 chan->timingfd=35)
    [Nov 18 14:13:37] DEBUG[7164] audiohook.c: Failed to get 160 samples from write factory 0xb6d319bc
    [Nov 18 14:13:37] DEBUG[7164] channel.c: Internal timing is disabled (option_internal_timing=0 chan->timingfd=35)
    [Nov 18 14:13:37] DEBUG[7164] audiohook.c: Failed to get 160 samples from write factory 0xb6d319bc
    [Nov 18 14:13:37] DEBUG[7164] channel.c: Internal timing is disabled (option_internal_timing=0 chan->timingfd=35)
    [Nov 18 14:13:37] DEBUG[7164] audiohook.c: Failed to get 160 samples from write factory 0xb6d319bc
    [Nov 18 14:13:37] DEBUG[7164] channel.c: Internal timing is disabled (option_internal_timing=0 chan->timingfd=35)
    [Nov 18 14:13:37] DEBUG[7164] audiohook.c: Failed to get 160 samples from write factory 0xb6d319bc

    Somebody have any idea about this? I need to configure something more?

    Thanks,
    :(
     
  2. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
  3. alfil2k

    Joined:
    Aug 17, 2009
    Messages:
    25
    Likes Received:
    0
    Thanks Patrick_elx, can you tell me what is the correct process to install this version on elastix 1.5.2 ?

    Regards,
     
  4. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
    There's no easy way as of today. You will need to download the source from digium and compile it on your Elastix server. You may break a lot of things.

    Better wait a few weeks for a new rpm that will be available on the Elastix repository and easily uploadable with a simple yum update
     
  5. alfil2k

    Joined:
    Aug 17, 2009
    Messages:
    25
    Likes Received:
    0
    Ok, I hope that the new rpm for update is cooming soon, because I have a lot request for that function in our instalation.

    Have you some idea about how long I wait for this update?

    Regards,
     
  6. andreslie1

    Joined:
    Dec 27, 2007
    Messages:
    17
    Likes Received:
    0
    on elastix 1.5.2
    all you need to do is put this on extensions_custom.conf



    [espia]

    exten => 1236,1,Answer
    exten => 1236,2,Wait(1)
    exten => 1236,3,BackGround(please-enter-the)
    exten => 1236,4,Read(SPYNUM|extension)
    exten => 1236,5,ChanSpy(SIP/${SPYNUM}|p)
    exten => 1236,6,Hangup

    [wisper]

    exten => 1235,1,Answer
    exten => 1235,2,Wait(1)
    exten => 1235,3,BackGround(please-enter-the)
    exten => 1235,4,Read(SPYNUM|extension)
    exten => 1235,5,ChanSpy(SIP/${SPYNUM},w|p)
    exten => 1235,6,Hangup


    then on any ext you dial 1236 for chan spy or 1235 for wisper
     
  7. alfil2k

    Joined:
    Aug 17, 2009
    Messages:
    25
    Likes Received:
    0
    Andreslie1, how you can see above I have a similar code on extension_custom. The problem isn't this code it is the bug on version asterisk 1.4.26.

    Thanks anyway,
    :cheer:
     

Share This Page