Chanskype on Elastix

Discussion in 'General' started by nikeshjha, Jul 9, 2007.

  1. nikeshjha

    Joined:
    Jun 5, 2007
    Messages:
    1
    Likes Received:
    0
    Has anyone tried chanskype on Elastix ? I have used it on Trixbox and was trying to install it on Elastix but it is missing the asterisk-devel package and I cannot install it using yum install asterisk-devel.
     
  2. gbarriers

    Joined:
    Jul 15, 2007
    Messages:
    3
    Likes Received:
    0
    I could successfully install chanskype in trixbox 2.2, back when skype for linux 1.3 was out. Skype for linux 1.4 (current) fails to install due to unresolved dependencies. I got the same issue with Elastix.

    This is what I had to do in Elastix to get started:

    1. Edit /etc/yum.repos.d/CentOS-Base.repo and comment out all occurrences of

    #exclude=kernel*

    2. Install asterisk-devel.i386

    yum install asterisk-devel.i386

    3. Install kernel-devel.i686

    yum install kernel-devel.i686

    All required rpms (according to trix-skype) install successfully. Only skype fails with the following message:

    --> Finished Dependency Resolution
    Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package skype
    Error: Missing Dependency: qt4-x11 >= 4.2 is needed by package skype
    Error: Missing Dependency: libsigc-2.0.so.0 is needed by package skype
    Error: Missing Dependency: libQtGui.so.4 is needed by package skype
    Error: Missing Dependency: libQtDBus.so.4 is needed by package skype
    Error: Missing Dependency: libstdc++.so.6(GLIBCXX_3.4.4) is needed by package skype
    Error: Missing Dependency: libQtNetwork.so.4 is needed by package skype
    Error: Missing Dependency: libQtCore.so.4 is needed by package skype

    I have absolutely no experience with Linux. I guess kernel updates are disabled by default for a reason. Make sure it imposes no security risks.
     
  3. gbarriers

    Joined:
    Jul 15, 2007
    Messages:
    3
    Likes Received:
    0
    I could successfully install chanskype in trixbox 2.2, back when skype for linux 1.3 was out. Skype for linux 1.4 (current) fails to install due to unresolved dependencies. I got the same issue with Elastix.

    This is what I had to do in Elastix to get started:

    1. Edit /etc/yum.repos.d/CentOS-Base.repo and comment out all occurrences of

    #exclude=kernel*

    2. Install asterisk-devel.i386

    yum install asterisk-devel.i386

    3. Install kernel-devel.i686

    yum install kernel-devel.i686

    All required rpms (according to trix-skype) install successfully. Only skype fails with the following message:

    --> Finished Dependency Resolution
    Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package skype
    Error: Missing Dependency: qt4-x11 >= 4.2 is needed by package skype
    Error: Missing Dependency: libsigc-2.0.so.0 is needed by package skype
    Error: Missing Dependency: libQtGui.so.4 is needed by package skype
    Error: Missing Dependency: libQtDBus.so.4 is needed by package skype
    Error: Missing Dependency: libstdc++.so.6(GLIBCXX_3.4.4) is needed by package skype
    Error: Missing Dependency: libQtNetwork.so.4 is needed by package skype
    Error: Missing Dependency: libQtCore.so.4 is needed by package skype

    I have absolutely no experience with Linux. I guess kernel updates are disabled by default for a reason. Make sure it imposes no security risks.
     

Share This Page