chan_mobile help for install

Joined
Dec 3, 2007
Messages
8,069
Points
88
hi

i be back:whistle:

I resolving also all problem (hard...mother board is down..)
I do reinstall so elastix (Vs TB2.6 don't working very good) Elastix is a little beter.

So... with another mother board and a new config clean , i installing succesfully a card "Eicon Divas Server BRI V2".

Now I would like installed "chan-mobile".(present on TB2.6 and asterisk 1.4.x.)
Curently, chan_mobile is not installed.

how do i installed chan_mobile simply?
RPM? compiling?

Can you help me plaese?

thanks

Franck<br><br>Post edited by: danardf, at: 2008/04/26 11:59
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
Chan_mobile is up.

grrrrr and now.. Astrisk is down.
after installing asterisk-addons chan_mobile.

it's this???

I have this result after reboot :
SETTING FILE PERMISSIONS
Permissions OK

STARTING ASTERISK
Asterisk ended with exit status 127
Asterisk died with code 127.
Automatically restarting Asterisk.
mpg123: no process killed
Asterisk ended with exit status 127
Asterisk died with code 127.
Automatically restarting Asterisk.
mpg123: no process killed

-----------------------------------------------------
Asterisk could not start!
Use 'tail /var/log/asterisk/full' to find out why.
-----------------------------------------------------
[root@elastix asterisk]#
[root@elastix asterisk]# tail /var/log/asterisk/full'
>
[root@elastix asterisk]# tail /var/log/asterisk/full
[Apr 26 09:29:29] VERBOSE[3299] logger.c: == Registered translator 'alawtoulaw' from format alaw to ulaw, cost 1
[Apr 26 09:29:29] VERBOSE[3299] logger.c: == Registered translator 'ulawtoalaw' from format ulaw to alaw, cost 1
[Apr 26 09:29:29] VERBOSE[3299] logger.c: codec_a_mu.so => (A-law and Mulaw direct Coder/Decoder)
[Apr 26 09:29:29] VERBOSE[3299] logger.c: == Registered file format g723sf, extension(s) g723|g723sf
[Apr 26 09:29:29] VERBOSE[3299] logger.c: format_g723.so => (G.723.1 Simple Timestamp File Format)
[Apr 26 09:29:29] VERBOSE[3299] logger.c: == Registered application 'SayUnixTime'
[Apr 26 09:29:29] VERBOSE[3299] logger.c: == Registered application 'DateTime'
[Apr 26 09:29:29] VERBOSE[3299] logger.c: app_sayunixtime.so => (Say time)
[Apr 26 09:29:29] VERBOSE[3299] logger.c: == Registered application 'ChannelRedirect'
[Apr 26 09:29:29] VERBOSE[3299] logger.c: app_channelredirect.so => (Channel Redirect)
What's append?

Thanks for your great help

Franck
 

lek

Guest
Could you please update asterisk to the last available version in the Elastix repos? (1.4.19)

After upgrading please report if the problem still exists.
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
yes..
but not immediatly because my server is down. :(
i have not some chance.
After a fist crash to motherboard, i replace it, and same probleme with the new motherboard down some time after have repare. (motherboard or CPU or RAM ?)
I must doing change all my configuration hardware. (new tower, mother board, ram, CPU ..Etc)

Booooowwwwww :(

i still you inform

thanks for yout help

Franck
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Points
36
Edgar,

Running 1.0.17 - Yum updated from a clean install of 1.0 Stable.

================================
Connected to Asterisk 1.4.19 currently running on elastix (pid = 2572)
Verbosity was 3 and is now 10
================================

The issue still exists, in that Asterisk will die (with nothing in the standard logs) as soon as Chan_mobile loaded.

If you want help to resolve this issue, pleased to help, with whatever feedback or reports are required.

Bob
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
grrrrrr

I install the last elastix version and same problem.!!
install to VMWARE for try it.

asterisk down after reboot server.:angry:

I don't know why!!!

only one question: Why don't include this module with elastix distro 1.0.1 directly?
Asterisk 1.4.x include chan_mobile nativ non?

if you have any solution....

Thanks

Franck<br><br>Post edited by: danardf, at: 2008/05/01 22:06
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
For information.
[root@elastix ~]# tail /var/log/asterisk/full
[May 1 18:52:23] ERROR[2815] config.c: *********** YOU SHOULD REALLY READ THIS ERROR ***********
[May 1 18:52:23] ERROR[2815] config.c: Future versions of Asterisk will treat a #include of a file that does not exist as an error, and will fail to load that configuration file. Please ensure that the file 'sip_custom.conf' exists, even if it is empty.
[May 1 18:52:23] ERROR[2815] config.c: *********** YOU SHOULD REALLY READ THIS ERROR ***********
[May 1 18:52:23] ERROR[2815] config.c: *********************************************************
[May 1 18:52:23] ERROR[2815] config.c: *********************************************************
[May 1 18:52:23] ERROR[2815] config.c: *********** YOU SHOULD REALLY READ THIS ERROR ***********
[May 1 18:52:23] ERROR[2815] config.c: Future versions of Asterisk will treat a #include of a file that does not exist as an error, and will fail to load that configuration file. Please ensure that the file 'sip_additional.conf' exists, even if it is empty.
[May 1 18:52:23] ERROR[2815] config.c: *********** YOU SHOULD REALLY READ THIS ERROR ***********
[May 1 18:52:23] ERROR[2815] config.c: *********************************************************
[May 1 18:52:23] WARNING[2815] chan_sip.c: tos value at line 20 is deprecated. See doc/ip-tos.txt for more information.
[root@elastix ~]#
So, sip_additional.conf is not present.
I create sip_additional.conf
and amportal start.

Asterisk always down but with an other type error:

tail /var/log/asterisk/full
[May 1 18:54:47] VERBOSE[2935] logger.c: == Registered application 'UserEvent'
[May 1 18:54:47] VERBOSE[2935] logger.c: app_userevent.so => (Custom User Event Application)
[May 1 18:54:47] VERBOSE[2935] logger.c: == Registered custom function TIMEOUT
[May 1 18:54:47] VERBOSE[2935] logger.c: func_timeout.so => (Channel timeout dialplan functions)
[May 1 18:54:47] VERBOSE[2935] logger.c: == Registered custom function VMCOUNT
[May 1 18:54:47] VERBOSE[2935] logger.c: == Registered application 'HasVoicemail'
[May 1 18:54:47] VERBOSE[2935] logger.c: == Registered application 'HasNewVoicemail'
[May 1 18:54:47] VERBOSE[2935] logger.c: app_hasnewvoicemail.so => (Indicator for whether a voice mailbox has messages in a given folder.)
[May 1 18:54:47] VERBOSE[2935] logger.c: == Registered custom function MATH
[May 1 18:54:47] VERBOSE[2935] logger.c: func_math.so => (Mathematical dialplan function)
<br><br>Post edited by: danardf, at: 2008/05/01 22:52
 
Joined
Feb 25, 2008
Messages
111
Points
0
I am testing chan_mobile over Elastix 1.0.17 VMWare image, and I get the same error.

Asterisk died on code 127, when Asterisk begin to run.

When I try to run from console, with asterisk -gvv, the last messages say:

asterisk: symbol lookup error: /usr/lib/asterisk/modules/chan_mobile.so: undefined symbol: hci_get_route

When I do:
[root@elastix asterisk]# ldd /usr/lib/asterisk/modules/chan_mobile.so linux-gate.so.1 => (0x00982000)
libc.so.6 => /lib/libc.so.6 (0x00456000)
/lib/ld-linux.so.2 (0x003a4000)

Seems to be there is no dependency with bluetooth library, is it ?

What can we do ?

thanks!<br><br>Post edited by: JoseVelasco, at: 2008/05/19 00:50
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
hi

like me, i wait a solution :(
exemple: TB 2.6.0.7 this function chan_mobile running a litle.
for me it's unstable.

i look at link (chan-mobile.org) and the real version's asterisk is 1.6.x (and not 1.4.x) :angry:

Chan-mobile on 1.4 is a beta.<br><br>Post edited by: danardf, at: 2008/05/24 00:49
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
thanks for this help.

I try this solution this weekend. ;)<br><br>Post edited by: danardf, at: 2008/06/11 07:02
 
Joined
Feb 22, 2008
Messages
38
Points
0
Hi,
with the new packages it still dies for me with error 127. Using Elastix 1.1, latest asterisk-1.4.19-1 and rpm -q says that asterisk-addons and asterisk-addons-chan_mobile are both at 1.4.7-1
I can't find anything interesting (regarding chan_mobile) in /var/log/asterisk/full
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
have you got make a clean install elastix and apply the new patch, or using an existing configuration and applying patch?
 
Joined
Feb 22, 2008
Messages
38
Points
0
Hi, I used my test-environement, which is a fully backupped semi-production machine (an association open for 2 evenings per week). Therefore, I applied the rpms over an existing config.
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
heeee one little question:

Like http://www.chan-mobile.org/ website saying.

chan-mobile requires that the bluez headers and libraries are installed on your system. If the configure step above does not detect them, then you will be unable to select chan_mobile in the menu.
the library's bluez is it implemented into elastix's package?
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
Hi,

I trying to use the solution, but nothing.
I used Elastix 1.1 beta for try.
I installed the patch : asterisk-addons and asterisk-addons-chan_mobile. but same problem.

there are one step of less.

yum -y install blue-utils.

With chan-mobile, bluez must be present

on this error 127, i have this one:
tail /var/log/asterisk/full
[Jun 14 02:08:46] VERBOSE[4947] logger.c: == Registered application 'ReadFile'
[Jun 14 02:08:46] VERBOSE[4947] logger.c: app_readfile.so => (Stores output of file into a variable)
[Jun 14 02:08:46] VERBOSE[4947] logger.c: == Registered application 'TxFAX'
[Jun 14 02:08:46] VERBOSE[4947] logger.c: app_txfax.so => (Trivial FAX Transmit Application)
[Jun 14 02:08:46] VERBOSE[4947] logger.c: == Registered application 'TestClient'
[Jun 14 02:08:46] VERBOSE[4947] logger.c: == Registered application 'TestServer'
[Jun 14 02:08:46] VERBOSE[4947] logger.c: app_test.so => (Interface Test Application)
[Jun 14 02:08:46] VERBOSE[4947] logger.c: == Manager registered action PlayDTMF
[Jun 14 02:08:46] VERBOSE[4947] logger.c: == Registered application 'SendDTMF'
[Jun 14 02:08:46] VERBOSE[4947] logger.c: app_senddtmf.so => (Send DTMF digits Application)
otherise, if i try to run asterisk CLI, i have an error symbolic lookup:
app_senddtmf.so => (Send DTMF digits Application)
asterisk: symbol lookup error: /usr/lib/asterisk/modules/chan_mobile.so: undefined symbol: hci_get_route
<br><br>Post edited by: danardf, at: 2008/06/15 10:02
 

Members online

No members online now.

Forum statistics

Threads
30,992
Messages
131,106
Members
17,716
Latest member
Orbit114
Top