Centos2Elastix fails to install on new kernel

Discussion in 'General' started by dmnet, Oct 10, 2008.

  1. dmnet

    Joined:
    Oct 9, 2008
    Messages:
    2
    Likes Received:
    0
    Hi All

    I found that Centos2Elastix only installs on Centos 5.1, the latest kernel for 5.2 fails with a dependency error:

    Verifying the kernel version installed
    Installing kernel-2.6.18-53.1.19.el5
    warning: /usr/src/CentOS/kernel-2.6.18-53.1.19.el5.i686.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
    error: Failed dependencies:
    kernel < 2.6.18-61 conflicts with ecryptfs-utils-41-1.el5.i386
    Error installing kernel: 2.6.18-53.1.19.el5
    [root@mypbx src]# uname -r
    2.6.18-92.el5xen

    Can someone look into this please ?

    Juri
     
  2. areid

    Joined:
    Apr 11, 2008
    Messages:
    117
    Likes Received:
    0
    dmnet,
    did you solve this problem? we are having the same problem on our centos 5.2. the kernels. I'd created a new thread before seeing your's.
     
  3. dmnet

    Joined:
    Oct 9, 2008
    Messages:
    2
    Likes Received:
    0
    Nope.

    But the work-around is to install from Centos 5.1, run the Centos2Elastix install script, then do:
    1. yum update (which takes Centos to 5.2)
    2. yum update elastix (which takes elastix to 1.3)

    Juri
     
  4. yashar87

    Joined:
    Oct 13, 2008
    Messages:
    1
    Likes Received:
    0
    I have the same problem

    Installing kernel-2.6.18-53.1.19.el5
    warning: /mnt/elastix/CentOS/kernel-2.6.18-53.1.19.el5.i686.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
    error: Failed dependencies:
    kernel < 2.6.18-61 conflicts with ecryptfs-utils-41-1.el5.i386
    Error installing kernel: 2.6.18-53.1.19.el5
     
  5. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
  6. joel1198

    Joined:
    Nov 21, 2009
    Messages:
    11
    Likes Received:
    0
    After this step:

    rpm -ivh --oldpackage kernel-2.6.18-53.1.19.el5.i686.rpm

    We receive the following error:

    kernel < 2.6.18-61 conflicts with ecryptfs-utils-41-1.el5.i386

    We're using CentOS 5.2.

    Any suggestions?
     
  7. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    Update the kernel to: 2.6.18-164.el5 try using this rpm to update
    http://rsync0.elastix.org/elastix/1.6/b ... 5.i686.rpm

    Code:
    rpm -Uvh kernel-2.6.18-164.el5.i686.rpm
    
    New versions of Elastix uses newer versions of the kernel, that might be reason why it didn't work

    regards,

    Rafael
     
  8. Jansito

    Joined:
    May 19, 2010
    Messages:
    27
    Likes Received:
    0
    Hi,

    I´m installing remotly Elastix-1.6.0-x86_64-bin-29oct2009.iso under Centos 5.5
    Kernel 2.6.18-164.11.1.el5


    And I have this problem :

    Transaction Summary
    ==============================================================================================================================================================
    Install 87 Package(s)
    Upgrade 0 Package(s)

    Total size: 271 M
    Total download size: 110 M
    Downloading Packages:
    --------------------------------------------------------------------------------------------------------------------------------------------------------------
    Total 3.6 GB/s | 110 MB 00:00
    Running rpm_check_debug
    Running Transaction Test
    Finished Transaction Test


    Transaction Check Error:
    file /etc/pam.d/imap from install of cyrus-imapd-2.3.7-7.el5_4.3.x86_64 conflicts with file from package courier-imap-3.0.8-cos5.build90090127.18.x86_64
    -----------------------------------------------------------------------------------------------

    Any idea ?

    Regards.
     

Share This Page