Centos 5 Remote Install failing...

ralex

Joined
May 2, 2010
Messages
3
Likes
0
Points
0
#1
I have searched for these errors and find many other errors but not these. I am following the instructions from "http://www.elastix.org/component/option,com_openwiki/Itemid,27/id,how-to_install_elastix_from_centos5/" and did all of the steps. When I attempt to do the line "yum -y --nogpgcheck install asterisk* elastix-* freeze fxload kernel-module-rhino* libmfcr2 lzop perl-HTML-TokeParser-Simple perl-WWW-Mechanize
" I get a dependency error that doesn't make any sense to me. I am not a complete newbie and have installed PBX in a Flash remotely, but want to use Elastix now, first on my backup server, then on my primary (Both are physical dedicated servers).

And by the way this is with the latest 1.6 download from here...

If I break the line up and install each piece separately, everything installs except "elastic-*". When I attempt to install that I get:

Code:
php-imap-5.1.6-24.el5_4.5.i386 from updates has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-24.el5_4.5 is needed by package php-imap-5.1.6-24.el5_4.5.i386 (updates)
php-mbstring-5.1.6-24.el5_4.5.i386 from updates has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-24.el5_4.5 is needed by package php-mbstring-5.1.6-24.el5_4.5.i386 (updates)
php-pdo-5.1.6-24.el5_4.5.i386 from updates has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-24.el5_4.5 is needed by package php-pdo-5.1.6-24.el5_4.5.i386 (updates)
php-gd-5.1.6-24.el5_4.5.i386 from updates has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-24.el5_4.5 is needed by package php-gd-5.1.6-24.el5_4.5.i386 (updates)
php-mysql-5.1.6-24.el5_4.5.i386 from updates has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-24.el5_4.5 is needed by package php-mysql-5.1.6-24.el5_4.5.i386 (updates)
mysql-server-5.0.77-4.el5_4.2.i386 from updates has depsolving problems
  --> Missing Dependency: mysql = 5.0.77-4.el5_4.2 is needed by package mysql-server-5.0.77-4.el5_4.2.i386 (updates)
php-xml-5.1.6-24.el5_4.5.i386 from updates has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-24.el5_4.5 is needed by package php-xml-5.1.6-24.el5_4.5.i386 (updates)
Error: Missing Dependency: mysql = 5.0.77-4.el5_4.2 is needed by package mysql-server-5.0.77-4.el5_4.2.i386 (updates)
Error: Missing Dependency: php-common = 5.1.6-24.el5_4.5 is needed by package php-imap-5.1.6-24.el5_4.5.i386 (updates)
Error: Missing Dependency: php-common = 5.1.6-24.el5_4.5 is needed by package php-gd-5.1.6-24.el5_4.5.i386 (updates)
Error: Missing Dependency: php-common = 5.1.6-24.el5_4.5 is needed by package php-xml-5.1.6-24.el5_4.5.i386 (updates)
Error: Missing Dependency: php-common = 5.1.6-24.el5_4.5 is needed by package php-mbstring-5.1.6-24.el5_4.5.i386 (updates)
Error: Missing Dependency: php-common = 5.1.6-24.el5_4.5 is needed by package php-mysql-5.1.6-24.el5_4.5.i386 (updates)
Error: Missing Dependency: php-common = 5.1.6-24.el5_4.5 is needed by package php-pdo-5.1.6-24.el5_4.5.i386 (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

I also tried with the older 1.5 version in the instructions and I get a similar but different dependency error:

Code:
Finished Dependency Resolution
elastix-1.5.2-2.noarch from /elastix-1.5.2-2.noarch has depsolving problems
  --> Missing Dependency: wanpipe-util = 3.3.15 is needed by package elastix-1.5.2-2.noarch (/elastix-1.5.2-2.noarch)
elastix-1.5.2-2.noarch from /elastix-1.5.2-2.noarch has depsolving problems
  --> Missing Dependency: wanpipe-util = 3.3.15 is needed by package elastix-1.5.2-2.noarch (/elastix-1.5.2-2.noarch)
php-devel-5.1.6-24.el5_4.5.i386 from updates has depsolving problems
  --> Missing Dependency: php = 5.1.6-24.el5_4.5 is needed by package php-devel-5.1.6-24.el5_4.5.i386 (updates)
Error: Missing Dependency: wanpipe-util = 3.3.15 is needed by package elastix-1.5.2-2.noarch (/elastix-1.5.2-2.noarch)
Error: Missing Dependency: php = 5.1.6-24.el5_4.5 is needed by package php-devel-5.1.6-24.el5_4.5.i386 (updates)
I have tried the suggestions at the end and they don't help... I am guessing it's just something I am missing, but I am not sure what... Any help is appreciated!

Randy
 

donhwyo

Joined
Aug 8, 2008
Messages
293
Likes
0
Points
0
#2
What does
Code:
yum list php
show for version of php? What version of centos?

Don
 

ralex

Joined
May 2, 2010
Messages
3
Likes
0
Points
0
#3
5.1.6-23.2.el5_3
 

Jansito

Joined
May 19, 2010
Messages
27
Likes
0
Points
0
#4
Your problem is because in the repo file you must remove Elastix in the route :

Create a file elastix-cd.repo in /etc/yum.repos.d :

# nano /etc/yum.repos.d/elastix-cd.repo
Now paste the follow without a space before each line in:

[elastix-cd]
name=Elastix RPM Repository for CentOS CD
baseurl=file:///mnt/elastix-cd/Elastix/
gpgcheck=0
enabled=1
note: Don
 

ralex

Joined
May 2, 2010
Messages
3
Likes
0
Points
0
#5
No, I had read that somewhere and tried it and it still didn't work. Maybe I didn't have the correct permissions or something peculiar with the Virtual Server. I have given up for now, I am only one person and can't afford to mess with stuff for more than a short amount of time. Thanks for the help though!
 

Jansito

Joined
May 19, 2010
Messages
27
Likes
0
Points
0
#6
Re: Re:Centos 5 Remote Install failing...

Have you installed other aplication or is a clean installation ?.

I was having problems installing remotly if after the installation are other programa installed, like Webmin, Plesk, etc.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top