CDR Data empty

centritech

Joined
Jul 23, 2008
Messages
63
Likes
0
Points
0
#1
I recently migrated a 1.5 install to a new server and also migrated to Elastix 1.6 at the same time. I used the back up and restore module in Elastix and everything seemed to work fine.

However, ever since the upgrade my CDR reports show up empty. I can see all the data that was there before the migration. I just can't see any info since the migration.

I have the same issue in both the Elastix report module and the FreePBX report module. It almost seems like Asterisk is not logging any CDR information.

Any thoughts????

Thanks
Scott
 

centritech

Joined
Jul 23, 2008
Messages
63
Likes
0
Points
0
#2
I have noticed that the Master.csv file in the /var/log/asterisk/cdr-csv seems to be logging the data. How does the data go from that log to the asteriskcdrdb database.

I assume that the Freepbx and the Elastix reporting tools are reading from that database. Is that a correct assumption?

Thanks
Scott
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#3
You need to load cdr_addon_mysql.so, I had a similar problem a few weeks ago. It vanished after the update.
Try from the asterisk console 'module load cdr_addon_mysql.so'. If you get an error, probably you don't have it into your /usr/lib/asterisk/modules dir, then you'll have to copy it from another machine (that's what I did).
 

centritech

Joined
Jul 23, 2008
Messages
63
Likes
0
Points
0
#4
Great!! That works. The only issue I have now is the CDR is not showing my previous few days worth of CDR. I'm hoping this script will be useful in importing the information from Master.csv in to the database.

http://www.johnlange.ca/tech-tips/aster ... mport-v20/

Is this a bug in the upgrade to 1.6 or did I miss something during the migration?

Thanks again:)
Scott
 

nelson67

Joined
Jul 15, 2010
Messages
3
Likes
0
Points
0
#5
I had the same issue a few days ago, but I still had a copy of cdr_addon_mysql.so in /usr/lib/asterisk/modules. A quick reload (instead of 'load' at the CLI) of the cdr_addon_mysql.so module got it working again.

CLI> module load cdr_addon_mysql.so = FAILED!

CLI> module reload cdr_addon_mysql.so = Works! B)
 

eyal

Joined
Feb 4, 2013
Messages
3
Likes
0
Points
1
#6
Had same issue with asterisk 1.8, the mentioned sql so was missing but wasn't the issue, the problem turned to be mismatching mysql passwords in /etc/asterisk/cdr_mysql.conf and web gui password configured under advanced-> security tab, updating password in both sections resolved my issue and calls started to record again in CDR.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top