ccme sip trunk problem

Discussion in 'General' started by baris, Mar 1, 2010.

  1. baris

    Joined:
    Jan 18, 2010
    Messages:
    3
    Likes Received:
    0
    Hi all,
    I have 2801 ccme, c2801-ipvoicek9-mz.124-24.T2.bin
    Trixbox to cme calls working but when i try cme to trixbox, i getting fast busy signal and below error.

    Is there anyone resolve this issue ?

    Br,
    Baris

    Trixbox configs: Allow Anonymous Inbound SIP Calls? = Yes
    [ccme]
    host=192.168.100.200
    secret=1234
    username=1200
    context=from-internal
    disallow=all
    allow=alaw&ulaw
    dtmfmode=auto
    insecure=very
    type=friend
    qualify=yes

    trixbox1*CLI> sip show peers
    Name/username Host Dyn Nat ACL Port Status
    ccme/1200 192.168.100.200 5060 OK (10 ms)
    1200/1200 192.168.100.200 D A 5060 OK (10 ms)
    1050/1050 192.168.100.102 D N A 5060 OK (8 ms)

    debug ccsip error: *Feb 28 19:50:38.935: //-1/xxxxxxxxxxxx/SIP/Error/rtpAvpCodec_to_voipCodec: Unexpected RTP PayloadType :255 in SDP Body
    debug ccsip messages:
    *Feb 28 20:23:08.875: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:7777@192.168.100.205:5060 SIP/2.0
    Via: SIP/2.0/UDP 192.168.100.200:5060;branch=z9hG4bK7313B5
    From: <sip:1001@192.168.100.205>;tag=1A5CDC-2B5
    To: <sip:7777@192.168.100.205>
    Date: Sun, 28 Feb 2010 20:23:08 GMT
    Call-ID: EB69A5BC-23DD11DF-808DE5CE-7FEEA234@192.168.100.200
    Supported: 100rel,timer,resource-priority,replaces,sdp-anat
    Min-SE: 1800
    Cisco-Guid: 3943409814-601690591-2156455374-2146345524
    User-Agent: Cisco-SIPGateway/IOS-12.x
    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
    CSeq: 101 INVITE
    Max-Forwards: 70
    Timestamp: 1267388588
    Contact: <sip:1001@192.168.100.200:5060>
    Expires: 180
    Allow-Events: telephone-event
    Content-Type: application/sdp
    Content-Disposition: session;handling=required
    Content-Length: 314

    v=0
    o=CiscoSystemsSIP-GW-UserAgent 8631 870 IN IP4 192.168.100.200
    s=SIP Call
    c=IN IP4 192.168.100.200
    t=0 0
    m=audio 17076 RTP/AVP 0 8 18 101
    c=IN IP4 192.168.100.200
    a=rtpmap:0 PCMU/8000
    a=rtpmap:8 PCMA/8000
    a=rtpmap:18 G729/8000
    a=fmtp:18 annexb=no
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16

    *Feb 28 20:23:08.883: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Received:
    SIP/2.0 407 Proxy Authentication Required
    Via: SIP/2.0/UDP 192.168.100.200:5060;branch=z9hG4bK7313B5;received=192.168.100.200
    From: <sip:1001@192.168.100.205>;tag=1A5CDC-2B5
    To: <sip:7777@192.168.100.205>;tag=as030f4c80
    Call-ID: EB69A5BC-23DD11DF-808DE5CE-7FEEA234@192.168.100.200
    CSeq: 101 INVITE
    User-Agent: Asterisk PBX
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Supported: replaces
    Proxy-Authenticate: Digest algorithm=MD5, realm="asterisk", nonce="2a79e099"
    Content-Length: 0


    *Feb 28 20:23:08.887: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    ACK sip:7777@192.168.100.205:5060 SIP/2.0
    Via: SIP/2.0/UDP 192.168.100.200:5060;branch=z9hG4bK7313B5
    From: <sip:1001@192.168.100.205>;tag=1A5CDC-2B5
    To: <sip:7777@192.168.100.205>;tag=as030f4c80
    Date: Sun, 28 Feb 2010 20:23:08 GMT
    Call-ID: EB69A5BC-23DD11DF-808DE5CE-7FEEA234@192.168.100.200
    Max-Forwards: 70
    CSeq: 101 ACK
    Allow-Events: telephone-event
    Content-Length: 0


    *Feb 28 20:23:08.891: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:7777@192.168.100.205:5060 SIP/2.0
    Via: SIP/2.0/UDP 192.168.100.200:5060;branch=z9hG4bK74D8F
    From: <sip:1001@192.168.100.205>;tag=1A5CDC-2B5
    To: <sip:7777@192.168.100.205>
    Date: Sun, 28 Feb 2010 20:23:08 GMT
    Call-ID: EB69A5BC-23DD11DF-808DE5CE-7FEEA234@192.168.100.200
    Supported: 100rel,timer,resource-priority,replaces,sdp-anat
    Min-SE: 1800
    Cisco-Guid: 3943409814-601690591-2156455374-2146345524
    User-Agent: Cisco-SIPGateway/IOS-12.x
    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
    CSeq: 102 INVITE
    Max-Forwards: 70
    Timestamp: 1267388588
    Contact: <sip:1001@192.168.100.200:5060>
    Expires: 180
    Allow-Events: telephone-event
    Proxy-Authorization: Digest username="1200",realm="asterisk",uri="sip:7777@192.168.100.205:5060",response="31ad48e84f740c1d40b40668edfdb9a9",nonce="2a79e099",algorithm=MD5
    Content-Type: application/sdp
    Content-Disposition: session;handling=required
    Content-Length: 314

    v=0
    o=CiscoSystemsSIP-GW-UserAgent 8631 870 IN IP4 192.168.100.200
    s=SIP Call
    c=IN IP4 192.168.100.200
    t=0 0
    m=audio 17076 RTP/AVP 0 8 18 101
    c=IN IP4 192.168.100.200
    a=rtpmap:0 PCMU/8000
    a=rtpmap:8 PCMA/8000
    a=rtpmap:18 G729/8000
    a=fmtp:18 annexb=no
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16

    *Feb 28 20:23:08.895: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Received:
    SIP/2.0 403 Forbidden
    Via: SIP/2.0/UDP 192.168.100.200:5060;branch=z9hG4bK74D8F;received=192.168.100.200
    From: <sip:1001@192.168.100.205>;tag=1A5CDC-2B5
    To: <sip:7777@192.168.100.205>;tag=as030f4c80
    Call-ID: EB69A5BC-23DD11DF-808DE5CE-7FEEA234@192.168.100.200
    CSeq: 102 INVITE
    User-Agent: Asterisk PBX
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Supported: replaces
    Content-Length: 0


    *Feb 28 20:23:08.903: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    ACK sip:7777@192.168.100.205:5060 SIP/2.0
    Via: SIP/2.0/UDP 192.168.100.200:5060;branch=z9hG4bK74D8F
    From: <sip:1001@192.168.100.205>;tag=1A5CDC-2B5
    To: <sip:7777@192.168.100.205>;tag=as030f4c80
    Date: Sun, 28 Feb 2010 20:23:08 GMT
    Call-ID: EB69A5BC-23DD11DF-808DE5CE-7FEEA234@192.168.100.200
    Max-Forwards: 70
    CSeq: 102 ACK
    Allow-Events: telephone-event
    Content-Length: 0

    Config:
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    !
    no aaa new-model
    dot11 syslog
    ip source-route
    !
    ip dhcp excluded-address 192.168.100.1 192.168.100.100
    ip dhcp excluded-address 192.168.100.150 192.168.100.254
    !
    ip dhcp pool data
    network 192.168.100.0 255.255.255.0
    default-router 192.168.100.254
    dns-server 208.67.222.222
    option 150 ip 192.168.100.200
    !
    ip cef
    no ip domain lookup
    no ipv6 cef
    multilink bundle-name authenticated
    !
    voice rtp send-recv
    !
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    no supplementary-service sip moved-temporarily //i try with yes
    no supplementary-service sip refer //i try with yes
    fax protocol pass-through g711ulaw
    h323
    sip
    bind control source-interface FastEthernet0/0
    bind media source-interface FastEthernet0/0
    registrar server expires max 3600 min 3600
    !
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g711alaw
    codec preference 3 g729r8
    !
    voice-card 0
    !
    archive
    log config
    hidekeys
    !
    interface FastEthernet0/0
    ip address 192.168.100.200 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.168.100.254
    !
    ip http server
    no ip http secure-server
    ip http path flash:
    !
    control-plane
    !
    dial-peer voice 10 voip
    destination-pattern 7777
    progress_ind setup enable 3
    progress_ind progress enable 8
    voice-class codec 1
    session protocol sipv2
    session target ipv4:192.168.100.205
    session transport udp
    incoming called-number 1...
    dtmf-relay rtp-nte
    no vad
    !
    dial-peer voice 11 voip
    destination-pattern 105.
    session protocol sipv2
    session target ipv4:192.168.100.205
    session transport udp
    dtmf-relay rtp-nte
    codec g711ulaw
    !
    sip-ua
    credentials username 1200 password 7 135445415F realm asterisk
    authentication username 1200 password 7 06575D7218
    no remote-party-id
    retry invite 4
    retry response 3
    retry bye 2
    retry cancel 2
    retry register 5
    timers register 250
    registrar ipv4:192.168.100.205 expires 3600
    sip-server ipv4:192.168.100.205
    !
    telephony-service
    em logout 0:0 0:0 0:0
    max-ephones 5
    max-dn 5
    ip source-address 192.168.100.200 port 2000
    auto assign 1 to 5
    network-locale IT
    network-locale 1 IT
    network-locale 2 IT
    network-locale 3 IT
    network-locale 4 IT
    max-conferences 4 gain -6
    dn-webedit
    time-webedit
    transfer-system full-consult
    create cnf-files version-stamp Jan 01 2002 00:00:00
    !
    ephone-dn 1 dual-line
    number 1001
    !
    ephone 1
    no phone-ui speeddial-fastdial
    no phone-ui snr
    no multicast-moh
    mac-address 001E.BE90.xxxx
    type 7970
    button 1:1
    !
    line con 0
    login local
    line aux 0
    line vty 0 4
    login local
    !
    scheduler allocate 20000 1000
    end

    Router#
     

Share This Page