Can't registry SIP phone

Discussion in 'General' started by pnaves, Sep 12, 2009.

  1. pnaves

    Joined:
    May 27, 2009
    Messages:
    66
    Likes Received:
    0
    Hi Folks,

    I just configured a SIP-FRIEND to the card 0709935046 of my test customer. But I tried to registry my SIP phone using:

    Authorization User Name: 0709935046 (card number)
    Secret: 940632 as (secret field of SIP friend)
    Host: 192.168.0.100

    But I got this erro message in my SIP phone Registratios error: 404


    Do I have to extra configure something to use a2billing with elastix?

    Help me please":woohoo: I lost my day trying to fix it but I couldn't.:silly:
     
  2. abanuz

    Joined:
    Feb 25, 2008
    Messages:
    20
    Likes Received:
    0
    it looks,there is no user in elastix site.Please check user on sip.conf under /etc/asterisk
     
  3. pnaves

    Joined:
    May 27, 2009
    Messages:
    66
    Likes Received:
    0
    The file sip.conf seems to be managed by freepbx. The a2billing create the file additional_a2billing_sip.conf where a2billing custumer are configured. There aren't references of this file in sip.conf. Should I include this file into sip.conf using directive #include.

    My sip.conf:

    [general]

    ; These files will all be included in the [general] context
    ;
    #include sip_general_additional.conf

    ;sip_general_custom.conf is the proper file location for placing any sip general
    ;options that you might need set. For example: enable and force the sip jitterbuffer.
    ;If these settings are desired they should be set the sip_general_custom.conf file.
    ;
    ; jbenable=yes
    ; jbforce=yes
    ;
    ;It is also the proper place to add the lines needed for sip nat'ing when going
    ;through a firewall. For nat'ing you'd need to add the following lines:
    ; nat=yes , externip= , localhost= , and optionally fromdomain= .
    ;
    #include sip_general_custom.conf

    ;sip_nat.conf is here for legacy support reasons and for those that upgrade
    ;from previous versions. If you have this file with lines in it please make
    ;sure they are not duplicated in sip_general_custom.conf, if so remove them
    ;from sip_nat.conf as sip_general_custom.conf will have precedence.
    #include sip_nat.conf

    ;sip_registrations_custom.conf is for any customizations you might need to do to
    ;the automatically generated registrations that FreePBX makes.
    ;
    #include sip_registrations_custom.conf
    #include sip_registrations.conf

    ; These files should all be expected to come after the [general] context
    ;
    #include sip_custom.conf
    #include sip_additional.conf

    ;sip_custom_post.conf If you have extra parameters that are needed for a
    ;extension to work to for example, those go here. So you have extension
    ;1000 defined in your system you start by creating a line [1000](+) in this
    ;file. Then on the next line add the extra parameter that is needed.
    ;When the sip.conf is loaded it will append your additions to the end of
    ;that extension.
    ;
    #include sip_custom_post.conf
     
  4. josko

    Joined:
    Dec 5, 2008
    Messages:
    1
    Likes Received:
    0
    of course you must add this line in to sip.conf (for use sip registration):
    #include additional_a2billing_sip.conf

    for iax registration the same in to iax.conf
    #include additional_a2billing_iax.conf
     
  5. pnaves

    Joined:
    May 27, 2009
    Messages:
    66
    Likes Received:
    0
    Ok! Thank you!;)
     
  6. alben

    Joined:
    Jan 20, 2010
    Messages:
    28
    Likes Received:
    0
    hi, i created a a2billing client an all other setup
    added line in sip.conf:
    #include additional_a2billing_sip.conf

    additional sip has the client settings:
    [4775407827]
    type=friend
    username=4775407827
    accountcode=4775407827
    regexten=4775407827
    callerid=757416273042484
    amaflags=billing
    secret=0287432266
    nat=yes
    dtmfmode=RFC2833
    qualify=yes
    canreinvite=yes
    disallow=all
    allow=ulaw
    allow= alaw
    allow= gsm
    allow= g729
    host=dynamic
    context=a2billing
    regseconds=0
    cancallforward=yes

    but cant login to a softphone with that client
    please can help how to create a sip client in elastic a2billing?
    thanks a lot
     
  7. alben

    Joined:
    Jan 20, 2010
    Messages:
    28
    Likes Received:
    0
    sorry
    i tried again and now it registers ok
     
  8. alben

    Joined:
    Jan 20, 2010
    Messages:
    28
    Likes Received:
    0
    problem was when i copy and paste from the 2billing customer screen dont work but when i copy and paste (account-secret) from the conf file it works fine
     
  9. alben

    Joined:
    Jan 20, 2010
    Messages:
    28
    Likes Received:
    0
    now can't dial out

    hi, i got my a2billing customer to log in fine (i use portsip softphone)
    now my problem is, i need to do some additional setup so i can dial out?.
    i'm getting "called failed request timeout 408"
    i see the a2billing extension logged in my CLI> screen sip show peers but i dont get any procces when i dial out.
    When i dial out with my freepbx extension configured with my voip provider it dials ok.

    thanks a lot
     
  10. juliantitto

    Joined:
    Aug 3, 2010
    Messages:
    11
    Likes Received:
    0
    hello everybody, im having the same problem that you had and i add the line #include additional_a2billing_sip.conf but the sip customer continues without registrar

    [general]

    ; These files will all be included in the [general] context
    ;
    #include sip_general_additional.conf

    ;sip_general_custom.conf is the proper file location for placing any sip general
    ;options that you might need set. For example: enable and force the sip jitterbuffer.
    ;If these settings are desired they should be set the sip_general_custom.conf file.
    ;
    ; jbenable=yes
    ; jbforce=yes
    ;
    ;It is also the proper place to add the lines needed for sip nat'ing when going

    through a firewall. For nat'ing you'd need to add the following lines:
    ; nat=yes , externip= , localhost= , and optionally fromdomain= .
    ;
    #include sip_general_custom.conf

    ;sip_nat.conf is here for legacy support reasons and for those that upgrade
    ;from previous versions. If you have this file with lines in it please make
    ;sure they are not duplicated in sip_general_custom.conf, if so remove them
    ;from sip_nat.conf as sip_general_custom.conf will have precedence.
    #include sip_nat.conf


    ;sip_registrations_custom.conf is for any customizations you might need to do to
    ;the automatically generated registrations that FreePBX makes.
    ;
    #include sip_registrations_custom.conf
    #include sip_registrations.conf

    ; These files should all be expected to come after the [general] context
    ;
    #include sip_custom.conf
    #include sip_additional.conf

    ;sip_custom_post.conf If you have extra parameters that are needed for a
    ;extension to work to for example, those go here. So you have extension
    ;1000 defined in your system you start by creating a line [1000](+) in this
    ;file. Then on the next line add the extra parameter that is needed.
    ;When the sip.conf is loaded it will append your additions to the end of
    ;that extension.

    #include additional_a2billing_sip.conf // HERE IS THE INCLUDE
    ;
    #include sip_custom_post.conf

    i appreciate your help..thanks
     
  11. juliantitto

    Joined:
    Aug 3, 2010
    Messages:
    11
    Likes Received:
    0
    Friends ... my accout logged in ... after the include the line #include addtional_a2billing_sip.conf its necessary to restart your system.

    Thanks a lot everybody.

    Regards
     

Share This Page