Can't get incoming or outgoing to work

Discussion in 'General' started by newboy, Mar 12, 2009.

  1. newboy

    Joined:
    Mar 11, 2009
    Messages:
    60
    Likes Received:
    0
    I am new to IP-PBX and VoIP. I have installed Elastix 1.3 and configured a trunk for VoIP account with Oztell and Pennytel. I have 2 incoming numbers with Oztell.

    When i try to connect using "BOL SipPhone" directly to Oztell I can connect without any problem and receive incoming and calls and make outgoing calls. But, when I try to use the PBX, i cannot make or receive any calls. I have spoken to Oztell; they can see that Elastix is connected to their system.

    I have 2 extensions configured on PBX and connected using "BOL SipPhone" and they normally work fine if i call internally.

    I have opened the UDP ports 5060 and 10000 to 20000 for the PBX but still can't receive any incoming calls.

    When i check the FREE PBX, even that shows 2 trunks online and 2 registrations plus 2 IP phones.
    IP Phones Online 2
    IP Trunks Online 2
    IP Trunk Registrations 2

    Server status for everything is OK.
    Asterisk OK
    Op Panel OK
    MySQL OK
    Web Server OK
    SSH Server OK


    But when i go to the DASHBOARD in ELASTIX, it says that I haven't extension. But, it does show the extensions and the trunks in green under "FLASH OPERATOR PANEL".

    I tried to configure a ring group and added both extensions and a mobile number in it. But when i try to use that Ring Group in the "Incoming Route", ELASTIX doesn't say anything but in FRE PBX it comes up with an error "There are 1 bad destinations"

    When I try to dial out, I get a message "ALL CIRCUITS ARE BUSY, PLEASE TRY AGAIN LATER"

    Please advice on what should or can I do to fix this problem. Any help will be much appreciated.
     
  2. bucasia

    Joined:
    Feb 15, 2009
    Messages:
    36
    Likes Received:
    0
    Outbound calls are definitely easier to get working than inbound so I'd concentrate on that first :)

    You don't say about creating an 'Outbound Route'. Have you created that as well as the trunk/s?

    Matt
     
  3. newboy

    Joined:
    Mar 11, 2009
    Messages:
    60
    Likes Received:
    0
    Hello Matt,

    Thanks for your reply. I have created the Trunk and Outbound Rule for Ozetel. Here are the settings i have used.


    TRUNK (Oztell, i have created 1 for Pennytel as well)
    Outgoind Dial Rules
    899060X.
    60ZXX.
    06612+NXXXXXXX
    0661+NXXXXXXXX
    61+1300XXXXXX
    61+13ZXXX
    61+1800XXXXXX

    Outgoing Settings
    allow=ulaw&alaw
    canredirect=no
    disallow=all
    dtmfmode=rfc2833
    fromuser=899060xxxxx
    host= sip.syd.net2max.com
    insecure=very
    secret=Password
    type=peer
    username=899060XXXXX

    Incoming Settings
    User Context: 899060XXXXX(User ID)

    canreinvite=no
    context=from-trunk
    fromuser=899060XXXXX
    insecure=very
    qualify=no
    secret=Password
    type=user
    username=899060XXXXX

    Registration String: 899060XXXXX:password@sip.syd.net2max.com/899060XXXXX



    OUTGOING RULE

    Dial patterns
    0011|601XX.
    0|[378]NXXXXXXX
    1[38]XX.
    NXXXXXXX

    Trunk Sequence
    0 Oztell

    Can you please suggest if i am doing something wrong here? I checked with Oztell and Elastix is registering with them properly. All protocols are enabled through Oztell's website. Even the Flash Operator panel shows that i am registered with both Pennytel and Oztell and have 2 extensions configured.
     
  4. bucasia

    Joined:
    Feb 15, 2009
    Messages:
    36
    Likes Received:
    0
    I'm pretty sure on recent versions of Asterisk you need the allow after the disallow

    So it would be worth changing -

    to

     
  5. newboy

    Joined:
    Mar 11, 2009
    Messages:
    60
    Likes Received:
    0
    Thanks Matt,

    I'll try that out now. Do i need to make any changes to the sip_custom.conf? here is how my sip_custom.conf file looks like at the moment:

    language=au
    videosupport=yes
    allow=g729
    allow=g723
    allow=h261
    allow=h263
    allow=h263p

    defaultexpirey=600
    maxexpirey=3600
    rtptimeout=60
    rtpholdtimeout=120

    useragent = Elastix
     
  6. bucasia

    Joined:
    Feb 15, 2009
    Messages:
    36
    Likes Received:
    0
    I don't think you should have to if they are the defaults (although I'm surprised ulaw isn't in the allow list).

    Anyway, I'm pretty sure those will be overwritten by the settings specified on the trunk.
     
  7. newboy

    Joined:
    Mar 11, 2009
    Messages:
    60
    Likes Received:
    0
    Hey Matt,

    Changing the settings as recommended by you fixed the problem. i can now make and recieve calls.

    Thanks a lot for your help.

    I have got 1 more problem when i try to use Ring Group. I have set the incoming number to land on the ring group in which i have 2 extensions and then the mobile number. After this it is set to terminate the call if no answer.

    If i set follow me on "ringall" or "ringall-prim", it rings all the extensions at the same time but if i change it to "Hunt" or "Hunt-prim", it rings the extensions one by one for the Ringtime specified but when the call is transferred to the mobile, it just rings once and then terminates the call.

    Any suggestions on how i can fix this?
     
  8. newboy

    Joined:
    Mar 11, 2009
    Messages:
    60
    Likes Received:
    0
    Also, hen i set the calls to land on the ring group in the incoming rule, i get an error message in FREE PBX that there are 1 bad destinations.
     
  9. bucasia

    Joined:
    Feb 15, 2009
    Messages:
    36
    Likes Received:
    0
    I'm glad you can make calls now :)

    Are you putting a hash # on the end of the mobile number to tell FreePBX that it's an external number?

    Also, can you ring the number as you have it listed in the ring group dialog box, say from an extension?

    Matt
     

Share This Page