Can't connect from external network

Joined
Feb 27, 2009
Messages
9
Points
0
Hi,

We have a dedicated server with a Xen virtual machine where elastix is running.

We have forwarded the ports 5060 and 4569 and they are working fine. Also we have forwarded one port to 443 so we are able to see the control panel from outside.

The problem we have is that we can not connect a softphone from outside the local network.

we have configured iax_custom.conf in the following way:

externip = 174.36.xxx.xx
localnet = 192.168.122.111/255.255.255.0

language=en
delayreject = yes
jitterbuffer = yes
mailboxdetail = yes
allow=g729
allow=ilbc allow=g723

Also we have configured sip_nat.conf :

nat=yes
externip=174.36.xxx.xx
localnet=192.168.122.111/255.255.255.0

We have tried to connect to an IAX extension and to SIP one and none of them are connection.

we would appreciate you help.

Many thanks
 
Joined
Oct 24, 2008
Messages
4,099
Points
0
localnet = 192.168.122.111/255.255.255.0
should be
localnet=192.168.122.0/255.255.255.0

192.168.122.111
is a host
 
Joined
Feb 27, 2009
Messages
9
Points
0
Thanks dicko

I have done those changes and restarted the VM but unlucky I can't connect through IAX nor SIP.

cheers
 
Joined
Sep 23, 2008
Messages
488
Points
0
Its probably related to port-forwarding. Are you forwarding 10000-20000 UDP to the Xen box? If you're forwarding the IAX2 port, then you should be able to make a call using something like ZoIPer which supports IAX extensions.

IAX2 only requires the 1 port, unlike SIP / RTP which requires multiple :)
 

Members online

No members online now.

Forum statistics

Threads
30,992
Messages
131,106
Members
17,716
Latest member
Orbit114
Top