Can't access web GUI after inital install

jcardinal

Joined
Jul 13, 2009
Messages
35
Likes
0
Points
6
#1
I installed elastix 1.5.2 from ISO onto a Shuttle SG31G2. The onboard ethernet adapter was not recognized, so I had to install a driver for it. Once that was done and the machine was online, I still couldn't access the web GUI. I tried completely disabling selinux, but still couldn't get connected. The error message in Firefox (and IE) suggests that I'm not getting connected at all. I've confirmed that apache is running. I also installed trixbox 2.8.0.1 and was able to access the web GUI immediately after the install with no other steps required.

Is it possible that the installer didn't complete since it didn't find an ethernet adapter? Any suggestions on what I can do to get up and running?
 

jcardinal

Joined
Jul 13, 2009
Messages
35
Likes
0
Points
6
#2
To follow up on this...it seems that the elastix installer does indeed fail if it can't find a working ethernet adapter. After this install, I got the ethernet adapter working but still had no ability to connect via the web interface.

I attempted the entire install again with a USB ethernet adapter connected, and everything came up correctly. I then got the unrecognized onboard ethernet adapter working, removed the USB one, and everything is working great.
 

gamba47

Joined
May 28, 2009
Messages
595
Likes
0
Points
0
#3
Looks like a bug!

gamba47
 

javapaul

Joined
Jul 1, 2009
Messages
99
Likes
0
Points
0
#4
i had the same problem, i use ifconfig to look up the Ethernet info, and it didn't have an ip address so i assigned one and then ping it from a different location, also all my security options on FF an IE were real high so i lowered them and it worked
 

jcardinal

Joined
Jul 13, 2009
Messages
35
Likes
0
Points
6
#5
I'm pretty sure you're having a different issue then. Your Firefox/IE security problems suggest they weren't allowing you to visit the web GUI because of the suspicious/self-signed SSL certificates that elastix uses by default. My issue had to do with a failed install. I didn't make any changes to the client machine or browser settings between the time things weren't working and the time they were. This was purely a server problem.

I can't remember for certain, but I almost feel like there weren't even the proper (any?) files in /var/www/html/ after the first/unsuccessful install. I should have documented things better, but at the time, I was just in a hurry to get things working.
 

javapaul

Joined
Jul 1, 2009
Messages
99
Likes
0
Points
0
#6
did u run ifconfig in the linux box? are you getting a proper ip? is the NIC been detected?
 

jcardinal

Joined
Jul 13, 2009
Messages
35
Likes
0
Points
6
#7
Yes. When I was having this problem, I ran ifconfig, found that the NIC was not detected, installed the necessary driver, configured the NIC and brought the elastix server online. After that, I could ping to and from the elastix server, as well as use ssh and other tools to confirm it was connected and accessible on the network. With all of those things working and apache confirmed to be up and running, I could not connect to the elastix box from a web browser.

Like I said, I was able to repeat the elastix installation from scratch with a USB NIC connected and everything came up as expected. I'm suggesting that the first install attempt had a critical failure because it did not detect a working NIC.
 

Blueeye

Joined
Sep 7, 2009
Messages
1
Likes
0
Points
0
#8
Hi jcardinal

i have the same problem with my shuttle :(

were did u get the driver and how do i install it

Cheers

Rod
 

jcardinal

Joined
Jul 13, 2009
Messages
35
Likes
0
Points
6
#9
Check out post #4 at this link:
Hmm. The sky2 driver.

This is what I would like you to try. From a system with working Internet access -- the one which you use to post here, perhaps? -- go to the ElRepo repository and download the kABI tracking kmod-sk98lin driver. The version you will require for your 64-bit system is kmod-sk98lin-10.70.1.3-1.el5.elrepo.x86_64.rpm, which will be found here.

Transfer it to the target system by use of some form of removable medium and then install it --

Code:
rpm -ivh --nosignature kmod-sk98lin-10.70.1.3-1.el5.elrepo.x86_64.rpm

You'll need to use the --nosignature flag to the rpm command, unless you've already imported the ElRepo public key by a similar sneakernet method.

Now change the alias line in your /etc/modprobe.conf file to refer to the sk98lin module, not the sky2 one and restart your network --

Code:
service network restart
To reiterate though, I had to do the initial installation of elastix with a separate NIC card installed. Then, after everything is installed, you install the driver for the onboard NIC, remove the separate NIC you used for installation, and reconfigure your network settings.

I hope that helps!
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#10

a_villacis

Joined
Jun 2, 2008
Messages
36
Likes
0
Points
0
#11
Is this still an issue with the Elastix ISO for 1.6.0 beta 2?
 

a_villacis

Joined
Jun 2, 2008
Messages
36
Likes
0
Points
0
#12
Unable to reproduce the issue in a virtual machine. Our system has a DHCP server in the LAN for our phones.

I did the following:
- configure virtual machine (VM) without any network card
- install Elastix-2.0 alpha on it. As expected, no network connectivity.
- Power down virtual machine
- Modify VM configuration to add supported network card emulation\
- Restart VM
- System successfully gets an IP address via DHCP.
- Web server responds normally.
 

newdem

Joined
Oct 14, 2009
Messages
7
Likes
0
Points
0
#13
hi
same pb, did you make hard install from usb key?
you can try :

iptables -F


bye
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top