Cannot install via setup-sangoma on 2.0.3 [SOLVED]

Adamant

Joined
Jul 27, 2010
Messages
11
Likes
0
Points
0
#1
Hi All,

I have a system here which I have previously been running Trixbox on, and now decided to look at Elastix but having an issue installing my Sangoma Hardware.

This machine has an A500, A101D and an A200 installed in it.

I run setup-sangoma and it asks me questions about the hardware, when I tell it to restart asterisk then I get the following:

Unloading Dahdi modules...
FATAL: Module dahdi is in use.
Error executing command:
modprobe -r dahdi

Rebooting the machine doesn't help and the cards aren't working.

I have tried just a "yum update" but to no avail - still the same error occurs.

Anyone any ideas of where I need to look / what I can do? This hardware was known good on Trixbox so it must just be the install that I'm doing wrong / has an issue!
 

josiegross

Joined
Jan 23, 2011
Messages
5
Likes
0
Points
0
#2
Re:Cannot install via setup-sangoma on 2.0.3

Try to configure the Sangoma's with /usr/sbin/wancfg_dahdi instead of setup-sangoma

Worked for me on a A200
 

Adamant

Joined
Jul 27, 2010
Messages
11
Likes
0
Points
0
#3
Re:Cannot install via setup-sangoma on 2.0.3

Hi,

Thanks for the reply - I just tried this but it seems the wancfg_dahdi doesn't support the A500 card! :(

I'm just downloading 1.6 now and seeing if either setup-sangoma works on that or if wancfg_dahdi supports the A500 on there.

Regards,
Adam

Edit: Just re-tried the wancfg_dahdi and it doesn't see the A500 but also fails at the same point of "FATAL: Module dahdi is in use" as the setup-sangoma does.
 

josiegross

Joined
Jan 23, 2011
Messages
5
Likes
0
Points
0
#4
Re:Cannot install via setup-sangoma on 2.0.3

Then you should probably reach out to Sangoma for help :)
 

Adamant

Joined
Jul 27, 2010
Messages
11
Likes
0
Points
0
#5
Re:Cannot install via setup-sangoma on 2.0.3

[q]Then you should probably reach out to Sangoma for help[/q]

This is exactly where I went! Sangoma are being *really* helpful, we have the drivers installed now - was simply a case of executing a service dahdi stop before running the setup-sangoma command.

Now have trunks showing in the Hardware Detector screen but they are red and underneath say "Not detected by Asterisk". A catch-all inbound to one extensions is set up and incoming calls are just getting the engaged tone.

Putting Asterisk into verbose mode and calling in shows nothing.

Now lasing with Sangoma on how to sort this out, they asked for some log files which I've sent over.
 

Adamant

Joined
Jul 27, 2010
Messages
11
Likes
0
Points
0
#6
Just in case anyone else has this issue.

The issue *only* seems to occur when you have BRI cards (A500) in the machine.

Wancfg_dahdi does not have drivers for the A500 BRI card as this doesn't present via DAHDI but via the WOOMERA interface.

The setup scripts included with Elastix 2.0.3 that do support the BRI is the setup-sangoma script but this generates borked chan_dahdi conf files (/etc/asterisk/chan_dahdi.conf).

To fix this, after running setup-sangoma, I needed to add the following at the top of the auto-generated chan_dahdi.conf

Code:
[trunkgroups]

[channels]
context=default
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
relaxdtmf=yes
rxgain=0.0
txgain=0.0
group=1
callgroup=1
pickupgroup=1
immediate=no

I don't know enough about Asterisk and Dahdi to know if the last thing I did made any difference but the comments were shown as # in the config generated by setup-sangoma so I changed them to ;

All now detected and working! :)
 

srf21c

Joined
Jan 12, 2010
Messages
5
Likes
0
Points
0
#7
Fix for Sangoma A400 bundled w/ELX025

Solved a similar issue with Sangoma A400 card undetected after default install of Elastix 2.x

Environment:
ELX025 appliance
Sangoma A400 card
Elastix-2.0.3-i386-bin-15Nov2010 (fresh install)

Steps:
service dahdi stop
setup-sangoma
vi /etc/asterisk/chan_dahdi.conf (paste in settings from previous post)
service asterisk restart
 

james.zhu

Joined
Feb 13, 2008
Messages
99
Likes
0
Points
6
#8
Re: Fix for Sangoma A400 bundled w/ELX025

good news. thank you for sharing.
 

dynamiq

Joined
Jun 22, 2012
Messages
2
Likes
0
Points
0
#9
Re:Cannot install via setup-sangoma on 2.0.3

I fought with this for days on a new dynamic (or fractional) T1. I tried 3 different versions of Asterisk (FreePBX, PIAF, Elastix) and none of them would work until I found your thread with the answer! Thank you so much for posting!

BTW, the version I am using now is Elastix 2.4 with a dahdi update (using "yum update dahdi" at the CLI) with a Sangoma A101 T1 card. It would NOT work until I added your lines to the chan_dahdi.conf.

Thank you, Thank you, Thank you!!!
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,898
Messages
130,879
Members
17,560
Latest member
manuelc
Top