Can register Sip Trunk but no voice??

lawsu

Joined
Aug 28, 2009
Messages
9
Likes
0
Points
0
#1
Hi,

I am having real difficulty to get this working.

My provider force me a 2Wire device for Sip call. I manage to get away and have success with Linksys PAP2T and softphone like X-lite. I just cannot get Asterisk to work.

I manage to register the trunk.

I can make outgoing call but there is no voice on both ends.

I check log status and it return with
"rtp.c: RTP Transmission error of packet to 0.0.0.0:0: Invalid argument"
I am using a public IP address. I end up puting "nat and externip" to get rid of the error.

Having getting rid of the error, I still have no voice when connected. I tried alot of combination of command still dun work.

username=6xxxxxx
type=peer
secret=xxxxxxx
qualify=yes
nat=yes
localhost=127.0.0.1
insecure=very
host=voip.xxxx.com
fromdomain=voip.xxxx.com
externip=6x.x.x.x
dtmfmode=rfc2283
disallow=all
context=default
auth=md5
allow=ulaw&alaw
relaxdtmf=yes

Log files....

[Aug 29 00:19:46] VERBOSE[2817] logger.c: -- Called MIO/9xxxxxxx
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- Call on SIP/MIO-0950de50 placed on hold
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- Started music on hold, class 'default', on SIP/100-09573268
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- SIP/MIO-0950de50 is making progress passing it to SIP/100-09573268
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- SIP/MIO-0950de50 is ringing
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- Call on SIP/MIO-0950de50 placed on hold
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- Stopped music on hold on SIP/100-09573268
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- Started music on hold, class 'default', on SIP/100-09573268
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- SIP/MIO-0950de50 is making progress passing it to SIP/100-09573268
[Aug 29 00:19:53] VERBOSE[2817] logger.c: -- Call on SIP/MIO-0950de50 placed on hold
[Aug 29 00:19:53] VERBOSE[2817] logger.c: -- Stopped music on hold on SIP/100-09573268
[Aug 29 00:19:53] VERBOSE[2817] logger.c: -- Started music on hold, class 'default', on SIP/100-09573268
[Aug 29 00:19:53] VERBOSE[2817] logger.c: -- SIP/MIO-0950de50 answered SIP/100-09573268
[Aug 29 00:19:53] VERBOSE[2817] logger.c: -- Executing [s@macro-setmusic:1] NoOp("SIP/MIO-0950de50", "Setting Outbound Route MoH To: none") in new stack
[Aug 29 00:19:53] DEBUG[2817] app_macro.c: Executed application: NoOp
[Aug 29 00:19:53] VERBOSE[2817] logger.c: -- Executing [s@macro-setmusic:2] SetMusicOnHold("SIP/MIO-0950de50", "none") in new stack
[Aug 29 00:19:53] DEBUG[2817] app_macro.c: Executed application: SetMusicOnHold
[Aug 29 00:19:53] DEBUG[2817] app_dial.c: Macro exited with status 0
[Aug 29 00:19:53] VERBOSE[2817] logger.c: -- Stopped music on hold on SIP/100-09573268
[Aug 29 00:19:53] VERBOSE[2817] logger.c: -- Packet2Packet bridging SIP/100-09573268 and SIP/MIO-0950de50
I appreciate if any guru here can advice me further to next stage. thank you.
 

Megabyte

Joined
Mar 28, 2009
Messages
327
Likes
0
Points
0
#2
Why do you have auth=md5 in your string?

try like this maybe it could help you



register => bootcamp3:bootcamp@172.16.79.63



[to_sipprovider]
type=peer
username=bootcamp3
fromuser=bootcamp3
fromdomain=example.com
secret=bootcamp
canreinvite=no
insecure=invite,port
host=172.16.79.63
deny=0.0.0.0/0
permit=172.16.79.63/255.255.255.255
disallow=all
allow=gsm
allow=ulaw
allow=alaw
qualify=yes
nat=no


And remember the register string
 

lawsu

Joined
Aug 28, 2009
Messages
9
Likes
0
Points
0
#3
With "nat=no", give me this error again....
"rtp.c: RTP Transmission error of packet to 0.0.0.0:0: Invalid argument"
Not too sure why it is pointing to 0.0.0.0 ?????........ I turn on nat, the error is gone.

I tried your setting, same thing, can register and connect, still no voice.....
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#4
I don't believe you are clear about your network here,

You say you have a public IP address,

but you don't state your firewall/router configuration .

If a public "network" (not an IP address, but a real internet network <ip network address>/<net mask> ) than all your devices must be within that network, , the interface must be configured correctly as to gateway/address/netmask and DNS server and there is no need for NAT, if you have a "private network" behind your router than , then yes you need

externip=
localnet=

etc. in your sip*.conf file.

It looks to me like you have a NAT solution behind a ISP provided NAT box

further the attempts to connect rtp to 0.0.0.0 shows that it incorrectly configured. 0.0.0.0 is a network, and a very large one at that. rtp needs a host, which is atomic by nature.


I suggests you start at the first page of "Elastix Without Tears" and continue until you understand now to set up Linux/Asterisk?Elastix behind a router.

It has worked for most folks here. Unfortunately there is no substitute for comprehension :)
 

lawsu

Joined
Aug 28, 2009
Messages
9
Likes
0
Points
0
#5
hi dicko......

I am rather sure I have configured the network portion correctly.

I tried configure another trunk with provider "voipuser.org" with nat=off in the same asterisk server and it did not give me problems nor any error as mention above. Strange right?

By the way, I have updated my Elastix to 1.5.2-2.3.... still no go.....
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#6
I'm sure you are sure, but just for shits and grins, please feel free to document your network from the ISP, the interface on your elastix box and any router/NAT settings between these two

( please obfuscate any public ip's)
 

lawsu

Joined
Aug 28, 2009
Messages
9
Likes
0
Points
0
#7
No problem.

ISP Router (Public IP)
IP : X.X.X.161
Sub : 255.255.255.224

NAT Router ( I am not going thru NAT router )
Wan : X.X.X.162 Sub : 255.255.255.224
Lan : 192.168.1.1 Sub : 255.255.255.0


Asterisk (Direct connection to Main ISP Router)
IP : X.X.X.167
Sub : 255.255.255.224
Gateway : X.X.X.161
DNS : ISP Provided. (No problem as I register sip as hostname and I manage to do yum update as well :) )

I am actually OK with network setup but comes to Asterisk troubleshooting, I am bit lost.

Thank you.......
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#8
You've lost me here

What is the

Lan : 192.168.1.1 Sub : 255.255.255.0

about, surely the router is acting either as a bridge to the identical local network or a NAT,

If a bridge

Then no NAT
all your clients must be within the /255.255.255.224 network

if NATting into 192.168.1.1, and your clients are there then the Elastix ifconfig doesn't compute if it is in the same physical network, if it's not then I suggest your are doin it the hard way.
 

lawsu

Joined
Aug 28, 2009
Messages
9
Likes
0
Points
0
#9
Hi, please refer picture for my setup.

My asterisk + client are not in NAT (192.168.1.X).

I purposely put the Asterisk + Test Client on Public to eliminate any NAT related issues.
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#10
Then from your original post


assuming no NAT in sip*.conf (because it shopuldn't be there)

username=6xxxxxx
type=peer
secret=xxxxxxx
qualify=yes
nat=yes ; WHY DO YOU HAVE THAT
localhost=127.0.0.1 ; WHY DO YOU HAVE THAT
insecure=very
host=voip.xxxx.com
fromdomain=voip.xxxx.com
externip=6x.x.x.x ; SHOULD NOT BE NECESSARY
dtmfmode=rfc2283
disallow=all
context=default ; ARE YOU SURE ABOUT THAT
auth=md5 ; ARE YOU SURE ABOUT THAT
allow=ulaw&alaw
relaxdtmf=yes ; ARE YOU SURE ABOUT THAT


I suggest a leisurely visit to http://voip-info.org will elucidate Asterisk for you

I further suggest a hardware phone/ata for testing preferably two, then you can at least talk to yourself(less than 30 bucks each on e-bay) especially if your host machine with xlite is in any way compromised (i.e. by OS?)
 

lawsu

Joined
Aug 28, 2009
Messages
9
Likes
0
Points
0
#11
actually, when I first started off, it was like few key statements.

To be frank, I am not sure. I done some reading on working setup includiing Elastix Without Tears few months ago and other asterisk website. Trying to play around with lots of different combination.

dicko, do you think you can test on my problem if I send you sip details?? No obligations tho.... :)
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#12
To be quite honest, I suggest you just try "Elastix Without Tears" one more time, this time with feeling, it has been brought up to 1.5 date and it has worked for the vast majority of others here. I don't feel there is any point doing it over another way.
 

lawsu

Joined
Aug 28, 2009
Messages
9
Likes
0
Points
0
#13
I just read the Trunk portion 8.4.

I remove my existing trunk and create again.

username=xxxxXXXX
type=peer
secret= Password
insecure=very
host=voip.provider.com
dtmfmode=rfc2833
disallow=all
allow=alaw
canreinvite=no

When I use "ulaw" it throws me "rtp.c: RTP Transmission error of packet to 0.0.0.0:0: Invalid argument"

There is no error when I use "alaw".

With both tries, there was no nat entry in trunk setting. (therefore, its off)

However, both attempts still can connect but no voice.
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#14
Then I would investigate how x.x.x.161 handles rtp connections (the audio payload)

ulaw and alaw are not arbitrary, you MUST use codecs that are compatible with your VSP or definityely will have no audio.

You state:
With both tries, there was no nat entry in trunk setting. (therefore, its off)

this is not necessarily so, the trunk will inherit any settings in the /etc/asterisk/sip*.conf family of files.

http://voip-info.org will help you understand this inheritance behavior in Asterisk

Maybe it's now time for the network section of EWT ?
 

lawsu

Joined
Aug 28, 2009
Messages
9
Likes
0
Points
0
#15
I tried ulaw and alaw using x-lite to connect to my sip provider. It works without any problem. Which should mean that both codecs should be supported.

I have verify that there is no NAT entry in sip*.conf as well.

Sorry.. what is EWT and where can I find it??

Do you happen to know of anyone who can solve my problem?? I do not mind for a small token if required as this problem been dragging me for quite sometime.
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#16
EWT="Elastix Without Tears"

Palosanto our, benevolent sponsors,provide paid support, the link is available on the home page.

Good Luck
 

lawsu

Joined
Aug 28, 2009
Messages
9
Likes
0
Points
0
#17
I tried to drop them an email, till now no response.

I read the EWT but still going nowhere.

Any1??? Else will have to shelve this idea and at mercy of my ISP. Haiz.....
 

e90

Joined
Sep 14, 2009
Messages
2
Likes
0
Points
0
#18
Lawsu,

I have the same problem with this voip provider (looking at your error log). It seems to be related to how they are handling the RTP stream. I've opened UDP 10000-35000 and adjusted rtp.conf with no luck. Registration is fine, but no audio on outbound calls. Inbound calls are crystal clear though.

Seems the combination of Asterisk, 2Wire NAT, and MIO voip is problematic. If anyone has gotten this to work, please share. My guess is that this provider is intentionally banning Asterisk calls.

So for now, this trunk serves as my DISA until I can get outbound calls working.
 

e90

Joined
Sep 14, 2009
Messages
2
Likes
0
Points
0
#19
Lawsu's log shows MOH being triggered for outbound calls. Anyone know how to prevent this from happening? Could be what's causing no audio on outbound calls.

[Aug 29 00:19:46] VERBOSE[2817] logger.c: -- Called MIO/9xxxxxxx
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- Call on SIP/MIO-0950de50 placed on hold
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- Started music on hold, class 'default', on SIP/100-09573268
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- SIP/MIO-0950de50 is making progress passing it to SIP/100-09573268
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- SIP/MIO-0950de50 is ringing
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- Call on SIP/MIO-0950de50 placed on hold
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- Stopped music on hold on SIP/100-09573268
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- Started music on hold, class 'default', on SIP/100-09573268
[Aug 29 00:19:49] VERBOSE[2817] logger.c: -- SIP/MIO-0950de50 is making progress passing it to SIP/100-09573268
[Aug 29 00:19:53] VERBOSE[2817] logger.c: -- Call on SIP/MIO-0950de50 placed on hold
 

numantis

Joined
Apr 14, 2011
Messages
6
Likes
0
Points
0
#20
here is the answer to this aged question:

Go into unembedded freepbx > tools > sip settings
and configure the subnet for your network, then all is well.
 

Staff online

Members online

Latest posts

Forum statistics

Threads
30,913
Messages
130,917
Members
17,589
Latest member
cristian.saiz
Top