can not ssh??????????????

Discussion in 'General' started by ziexpert, May 25, 2009.

  1. ziexpert

    Joined:
    May 25, 2009
    Messages:
    8
    Likes Received:
    0
    Hi,

    I have just installed Elastix 1.5.2-2
    I am having problems with ssh
    I can not log in
    although I can log in from the gui but not from ssh nor the server own terminal (monitor)
    I have tried my own password with both admin and root
    I have tried palosanto with both root and admin but no luck,, why is that?
    How could I login from the gui but not from the server own terminal?

    Plz advice
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Welcome to Elastix:

    There is no system user "admin" by default in Elastix (but it is a very good idea to add a non-privileged user)
    the root account will have the password you set up while installing (it is case sensitive)
    If you forgot your password for root then append single to the kernel arguments in grub (press escape while you are booting and read the screens)
    You will boot into single user level and get a root login without a password, type passwd and follow the prompts.
    then
    init 3
    should get you into runlevel 3 (standard) and try again with the new password.
     
  3. ziexpert

    Joined:
    May 25, 2009
    Messages:
    8
    Likes Received:
    0
    Hi Dicko

    Appreciate your help, but the question is, how the hell did the password change?
    I did not change as I was able to login couple of days before i posted here. Why did it change how did it change is a question that I can not figure out.

    I did not forget the password, I could not. We made it very simple 123456.... how could it be changed?

    Regards.
     
  4. gamba47

    Joined:
    May 28, 2009
    Messages:
    595
    Likes Received:
    0
    maybe some friend making you a joke ? 123456 it´s a really weak password.

    gamba47
     
  5. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Just as gamba47 says, but more likely not a friend at all:

    check your /var/log/secure file, I think you will be quite surprised.
     
  6. ziexpert

    Joined:
    May 25, 2009
    Messages:
    8
    Likes Received:
    0
    Hi,

    OK I am a bit lost here.
    When I press escape I get the following options:

    Elastix
    Elastix base

    e to edit command line
    a to modify the kernal
    c for command line

    Apparently it is not the first two

    When I press "c"
    Passwd is not a recognized command
    Password is but it asks me to enter password which I do not have.


    What should I do?

    Appreciate your help
     
  7. gamba47

    Joined:
    May 28, 2009
    Messages:
    595
    Likes Received:
    0
  8. raj

    raj

    Joined:
    Apr 19, 2009
    Messages:
    149
    Likes Received:
    0

    As Dicko Sir said you need to modify kernal so press a and then follow what he said or as gamba47 posted the link follow that properly.
     
  9. ziexpert

    Joined:
    May 25, 2009
    Messages:
    8
    Likes Received:
    0
    Appreciate your help guys,,

    I managed to change the password and things are working better now.

    Dicko
    I checked /var/log/secure and yup I was surprised.
    I lost count of ppl trying to hack my system.......

    Another interesting issue now is that when I log in to asterisk

    I get the following message:
    **[WOOMERA]** Receive Message: {default} [localhost/42420]

    Do you guys have any idea what that is and how to get rid of it?

    The PBX is working fine, all functions are working but the message keeps coming up...

    Appreciate your help
     
  10. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    It's the sangoma driver

    unload chan_woomera.so from asterisk cli

    and add
    noload => chan_woomera.so

    to
    /etc/asterisk/modules.conf
    if you don't have a sangoma BRI card
     

Share This Page