can not make outgoing call if have more than 4 FXO

Discussion in 'General' started by toasterisk, Mar 18, 2009.

  1. toasterisk

    Joined:
    Mar 12, 2009
    Messages:
    5
    Likes Received:
    0
    hello,
    i have a wired problem. when i put more than 4 FXOs using openvox a1200 or two a400ps.
    if i use my 5,6,7,8 for outgoing trunk with g0. all failed.
    it reports that the call is answered, but never come out. it calls in elastix like this:
    dial(zap/g0/XXXXXXX).
    if i dial like this: dial(zap/5 or 6), then i can make outgoing calls.
    i do not know why? asterisk does not detect my live channel, just call channel 1 or 2.
    i think it is a bug for freepbx or elastix dialplan script.
    anyone has an idea for that?
    thanks!
    to*
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    You should check both

    /etc/zaptel.conf
    /etc/asterisk/zapata.conf
    that your channels and groups are set up correctly.

    zttool from bash can help identify what channels are which.
    the load order of the zaptel modules can change the channel numbers of the hardware.
     
  3. toasterisk

    Joined:
    Mar 12, 2009
    Messages:
    5
    Likes Received:
    0
    thank you for your input. i think my setting files are ok. but the problem is that:
    when plugin the pstn to fxo 5,6,7,8. if i run dial(zap/g0/XXXXXX), the call can not be made. if i change to dial(zap/5 or 6), my call is ok. it means that g0 can not jump to 5,6,7,8. actually, those channels are under group0. i believe the channel status function has something wrong.
    thanks!
    to*
     
  4. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    I'm sorry if I don't understand correctly, but do you have dialtone on all eight fxo interfaces?

    if Group 0 = 1-8
    then if you dial:

    dial(zap/g0/XXXXXX)

    you will allways use zap/1 unless it's busy, then it will use zap/2, etc.

    if there is no dialtone on zap/1 then the call will fail, the standard zap driver will not skip a trunk if there is no dialtone, only if the channel is in use.

    To debug and if you only have 4 trunks try

    dial(zap/G0/XXXXXX), which will use the same group but decrementing, i.e. 8 then 7 then six etc.
     

Share This Page