Calls not going to voicemail or IVR.

Joshoua

Joined
Jul 14, 2009
Messages
15
Likes
0
Points
0
#1
Hello everyone.
Elastix is working great except one thing.
Calls do not go to voicemail.
When someone calls an extension and the call is not answered,he or she is not diverted to the extension's voicemail. The call is dropped with no feedback. It stops ringing and the line is left blank.
The same happens when the IVR is enabled and someone calls the company.
It's like, elastix is trying to play the message, but something happens and it cannot.
Now, here's the weird thing.
When I restart the server, everything works OK for a few days and then I get the same problem.
I have tried to troubleshoot Asterisk through the CLI.
This is what I got when calling my extension and hanging up on it:
Code:
* ANSWER:
P[ 1]  --> empty cad using dad
P[ 1] I SEND:CONNECT oad:XXXXXXXX dad:4099 pid:3158
P[ 1]  --> channel:1 mode:TE cause:16 ocause:16 rad: cad:4099
P[ 1]  --> info_dad: onumplan:2 dnumplan:0 rnumplan:  cpnnumplan:0
P[ 1]  --> * IND :      -1! (stop indication) pid:3158
    -- <mISDN/1-u8846> Playing 'vm-theperson' (language 'en')
P[ 1] I IND :CONNECT_ACKNOWLEDGE  oad:XXXXXXX dad:4099 pid:3158 state:CONNECTED
P[ 1]  --> channel:1 mode:TE cause:16 ocause:16 rad: cad:4099
P[ 1]  --> info_dad: onumplan:2 dnumplan:0 rnumplan:  cpnnumplan:0
P[ 1] I IND :DISCONNECT oad:XXXXXXX dad:4099 pid:3158 state:CONNECTED
P[ 1]  --> channel:1 mode:TE cause:16 ocause:16 rad: cad:4099
P[ 1]  --> info_dad: onumplan:2 dnumplan:0 rnumplan:  cpnnumplan:0
P[ 1]  --> queue_hangup
P[ 1] I SEND:RELEASE oad:XXXXXXX dad:4099 pid:3158
P[ 1]  --> channel:1 mode:TE cause:16 ocause:-1 rad: cad:4099
P[ 1]  --> info_dad: onumplan:2 dnumplan:0 rnumplan:  cpnnumplan:0
  == Spawn extension (macro-vm, s-NOANSWER, 2) exited non-zero on 'mISDN/1-u8846' in macro 'vm'
  == Spawn extension (ext-local, vmu099, 1) exited non-zero on 'mISDN/1-u8846'
P[ 1] * IND : HANGUP    pid:3158 ctx:ext-local dad:vmu099 oad:XXXXXXX State:CONNECTED
P[ 1]  --> out_cause:16
P[ 1]  --> state:CONNECTED
P[ 1] I IND :RELEASE_COMPLETE oad:XXXXXXX dad:4099 pid:3158 state:CLEANING
P[ 1]  --> channel:1 mode:TE cause:16 ocause:16 rad: cad:4099
P[ 1]  --> info_dad: onumplan:2 dnumplan:0 rnumplan:  cpnnumplan:0
P[ 1]  --> No need to queue hangup
P[ 1] Cannot hangup chan, no ast
P[ 1] $$$ Cleaning up bc with stid :10010100 pid:3158
P[ 1]

I don't like the "Cannot hangup chan, no ast" at the end...
Anyone had a similar problem or has any idea on how to troubleshoot?
Thanks in advance.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,900
Messages
130,884
Members
17,561
Latest member
marouen
Top