Caller ID Name not sent on Sip to PRI Gateway

Discussion in 'General' started by 6string, Dec 28, 2010.

  1. 6string

    Joined:
    Mar 20, 2009
    Messages:
    44
    Likes Received:
    0
    I am setting up Elastix 1.6 as a SIP to PRI gateway to a Legacy PBX
    Everything is working with the exception of Caller ID Name
    Here are some of my settings:

    group=0,11
    context=from-pstn ( I have also tried from-trunk and from-internal )
    switchtype = national
    signalling = pri_net
    channel => 1-23
    context = default
    group = 63




    ; Auto-generated by /usr/sbin/hardware_detector
    [trunkgroups]

    [channels]
    context=from-pstn
    signalling=fxs_ks
    rxwink=300 ; Atlas seems to use long (250ms) winks
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    canpark=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=no
    faxdetect=incoming
    echotraining=800
    rxgain=0.0
    txgain=0.0
    callgroup=1
    pickupgroup=1

    ;Uncomment these lines if you have problems with the disconection of your analog lines
    ;busydetect=yes
    ;busycount=3


    immediate=no

    #include dahdi-channels.conf
    #include chan_dahdi_additional.conf


    My Legacy PBX is setup for National and pri_cpe and currently does receive name from the Telco

    Thanks for the Help
     
  2. 6string

    Joined:
    Mar 20, 2009
    Messages:
    44
    Likes Received:
    0
    Bueller Bueller Anyone ! B)
     

Share This Page