Caller ID authentication issue

Discussion in 'General' started by Fresh Connexions, Jun 26, 2009.

  1. Fresh Connexions

    Joined:
    Jun 26, 2009
    Messages:
    1
    Likes Received:
    0
    I have a small problem with caller ID authentication i would like some help with please.

    Running Elastix 1.52-2.3 and a2billing 1.3.0

    I have succesfully set up rates,trunks etc in a2billing, added the following to the extension_custom.conf file:

    exten => 225,1,Answer
    exten => 225,2,Wait,2
    exten => 225,3,DeadAGI,a2billing.php
    exten => 225,4,Wait,2
    exten => 225,5,Hangup

    I have edited a2billing.conf as follows:

    use_dnid=YES
    cid_enable=YES

    After doing all of the above i can dial 225 and get voice prompt with account balance and minutes left etc followed by request to enter the number i want to call. If i enter the number and dial all works fine and a2billing picks up the call and generates invoice etc.

    I would like to bypass having to dial 225 to access a2billing and have a2billing pick up calls automatically.

    I have tried to follow the instructions in this post:
    http://forum.asterisk2billing.org/viewtopic.php?t=2127

    but my extensions.conf file does not contain the line:
    exten => s,n(skipoutnum),Dial(${pre_num:4}${the_num}${post_num},300,${DIAL_TRUNK_OPTIONS})
    which those instructions say i must modify.

    The macro dial out trunk section of my extensions.conf file is as follows:
    [macro-dialout-default]
    exten => s,1,Macro(user-callerid,SKIPTTL)
    exten => s,2,Macro(record-enable,${CALLERID(number)},OUT)
    exten => s,3,Macro(outbound-callerid,${ARG1})
    exten => s,4,Dial(${OUT}/${ARG1})
    exten => s,5,Playtones(congestion)
    exten => s,6,Congestion(5)
    exten => s,105,Macro(outisbusy)


    I think the instructions i have been using may relate to an earlier version of elastix/a2billing and would be gratefull of any advice of how to get this working


    Many Thanks
     

Share This Page