Call Tranfer Problem

Discussion in 'General' started by giorgoslouk, Feb 6, 2011.

  1. giorgoslouk

    Joined:
    Jan 10, 2011
    Messages:
    9
    Likes Received:
    0
    Hello everybody,
    I'm having this strange problem with Call Tranfer.
    When i want to transfer a call to another extension with ## (e.g.##102) i get the message from the operator that the extension is not available.I increased featuredigittimeout to 5000 but the problem persists.I have three extensions on two ATA devices.
    Please help.
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Ensure that the dial-string settings on your ATA allow such dialstring, and that any Asterisk feature codes including ## are not over-ridden by it.
     
  3. giorgoslouk

    Joined:
    Jan 10, 2011
    Messages:
    9
    Likes Received:
    0
    Can you explain this?
     
  4. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    I believe you will find both subjects are well explained in your ATA's documentation, a dial-string is usually a regex (regular expression) whereby some, and only some dialed numbers are recognized and allowed out of your box, and often some might be re-written , this will include phone number recognition and feature code recognition, anything matching will be delivered to the server, the feature codes are available in FreePBX, and these codes must NOT collide with any feature codes that your ATA has defined. Most ATA's have their own codes for doing blind and supervised transfers, these need to be disabled for best effect. It is usually best to disable all ATA's feature codes and let Asterisk handle the calls.
     
  5. giorgoslouk

    Joined:
    Jan 10, 2011
    Messages:
    9
    Likes Received:
    0
    I do not think this is an ATA problem since i'm having the same trouble with X-Lite too.
    I have two ATA's: a Grandstream HT286 and LINKSYS pap2t.
    I have disabled the feature codes on both of them but the problem persists.
     
  6. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Make sure you have not enbled T or t in your general settings Asterik dial command(s), (that will suborn ## and only expect #) otherwise it generally works as advertised.

    To further debug, enable DTMF logging in logger.conf (other posts here as to how) and post the log for an unsuccessful transfer

    You can of course not use ##, enable Tt as appropriate and use that instead.
     
  7. giorgoslouk

    Joined:
    Jan 10, 2011
    Messages:
    9
    Likes Received:
    0
    I have tr.
    What should i enable?
    OK i will enable Tt.
    The rest tomorrow,it's midnight here now.
    Thank you for your help dicko!!!
     
  8. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    That would be up to you to choose, that's why they are options, no? , all ATA's are not built equally, and some will intercept it and use it to it's own purpose if enabled, as said already refer to your ATA's documentation I suggest you use the Asterisk codes and disable them all as Asterisk cannot necessarily discriminate whether the # was dialed on the RX or TX path of the 2/4 wire hybrid that the ATA presents as a sip call. YMMV of course.
     

Share This Page