Call recording and playback

Discussion in 'General' started by dereky, Oct 20, 2008.

  1. dereky

    Joined:
    Oct 7, 2008
    Messages:
    7
    Likes Received:
    0
    Hi all - my call recording and playback quality is poor. The calls sound like they have been recorded in fast forward. The music-on-hold plays perfectly. I am using Elastix 1.3. Any help will be much appreciated.
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    this happens when you record a call from an extension or from a a queue?

    what are the characteristics of your cpu processor?
    how many ram do you have?
    what is the average load of ram consumption?
     
  3. dereky

    Joined:
    Oct 7, 2008
    Messages:
    7
    Likes Received:
    0
    Hi, thanks for the reply.

    The call recording is set to "always" for inbound and outbound under the extension setting.

    CPU:-GenuineIntel Intel(R) Pentium(R) Dual CPU E2200 @ 2.20GHz

    RAM:- 32.61% used of 1,000.84 Mb
     
  4. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    is there a way that you may upload one of your recordings?
     
  5. dereky

    Joined:
    Oct 7, 2008
    Messages:
    7
    Likes Received:
    0
  6. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    I got the recording...
    I heard the recording quality, it is very poor... :S

    By the way, you aren't using vmware for your elastix? isn't you?
     
  7. dereky

    Joined:
    Oct 7, 2008
    Messages:
    7
    Likes Received:
    0
    Hi, thanks for the patience. Elastix is installed on a stand-alone PC. It sounds to me like the call recording is being compressed. But I don't know where to look. :unsure:
     
  8. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Hi.

    Ok. have you modify the voice mail gain

    Into Freepbx, general parameters:

    Use gain when recording the voicemail message (optional):

    Use the specified amount of gain when recording the voicemail message.
    The units are whole-number decibels ( dB ).



    Information:

    If you set 0, you set 0db (no change). But if you set 1, you increase of 1 db the level, and if you set -1 you reduce of 1db the level.

    Maybe it's because the level it's too down what you don't have the best quality!?
     
  9. dereky

    Joined:
    Oct 7, 2008
    Messages:
    7
    Likes Received:
    0
    Hi, after extensive testing, I have established that the gain setting only affects the quality of the voicemail recordings. It does not change the call recording quality, which is what I am having problems with. If I configure call recording via the queue, the quality is perfect. The voicemail quality is also perfect. It is only when I configure the call recording paramters via the extension that there is a problem.
     
  10. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Hmmmm....I don't know why.
    Sorry.
     
  11. dereky

    Joined:
    Oct 7, 2008
    Messages:
    7
    Likes Received:
    0
    Hi

    The problem seems to be caused by the MixMonitor application that is designed to record 1 audio and mix them natively as the call is in progress to avoid the need to spawn external processes which lead to harmful cpu usage spikes. As a workaround I substituted the following command in the extensions.conf file with the Monitor command. See below:

    ;exten => s,999,MixMonitor(${CALLFILENAME}.wav)
    exten => s,999,Monitor(wav49,${CALLFILENAME}.wav,m)

    The wav49 format plays back perfectly, while the wav format is garbled. This seems to be an error experienced on Asterisk under Ubuntu as well.
     
  12. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    ha.. ok.
    Maybe a bug!
     
  13. alexandrosm77

    Joined:
    Feb 13, 2008
    Messages:
    3
    Likes Received:
    0
    put the following in extensions_override_freepbx.conf reload asterisk and the problem will dissapear


    [macro-record-enable]
    exten => s,1,GotoIf($[${LEN(${BLINDTRANSFER})} > 0]?2:4)
    exten => s,2,ResetCDR(w)
    exten => s,3,StopMonitor()
    exten => s,4,AGI(recordingcheck,${STRFTIME(${EPOCH},,%Y%m%d-%H%M%S)},${UNIQUEID})
    exten => s,5,Noop(No recording needed)
    exten => s,999,Monitor(wav,${CALLFILENAME},m)

    ;exten => s,3,BackGround(for-quality-purposes)
    ;exten => s,4,BackGround(this-call-may-be)
    ;exten => s,5,BackGround(recorded)
     
  14. lewis

    Joined:
    Jan 14, 2009
    Messages:
    15
    Likes Received:
    0
    hello all,

    i just installed Elastix 1.3-2 (the latest one).
    i used alexandros's patch, and my recordings were ok...
    after this i upgraded my system (yum update + freepbx updates) and when i use this patch, nothing is recorded..
    when i remove everything from extensions_override_freepbx.conf calls are recorded but they are gargled..

    any new update to this issue ?

    rgds,
    George
     

Share This Page