Call Pickup Headache

okle100

Joined
Jul 2, 2008
Messages
10
Likes
0
Points
0
#1
I have been trying to get Call Pickup working all day today with little success.

I have setup all the extensions through FreePBX.
For the zaptel channels (FXS ports) i can not see an optin through freePBX to setup the callgroup and pickupgroup values, but in /etc/asterisk/zapata.conf theese values are set to "1".

For the SIP extensions theese Values are set to "1".

In the Features panel of freepbx the callpickup value is set to default = **.

While reading some other forums i found theese advices that I need to setup these values:

Code:
/etc/asterisk/extensions_additional.conf

[app-pickup]
include => app-pickup-custom

exten => _**.,1,Noop(Attempt to Pickup ${EXTEN:2} by ${CALLERID(num)})

exten => _**.,n,Pickup(${EXTEN:2}@grom-did-direct)

exten => _**.,n,Pickup(${EXTEN:2})
and

Code:
/etc/asterisk/features_general_custom.conf

pickupexten => *8
I have tryied with different feature code (*0) and (*9) but the results are always the same:


On a Zap connected phone, i can not pickup an call (from extension and from outside line)

On a SIP connected phone i can only pickup an call using *8 witch would pickup the first incoming call, and does not allow to choose withch call to pickup.
On a SIP connected phone i can not pickup an call using ** (*9, *0) in any case.



Here is an outpoot from asterisk -vvvvr (cores set verbose 50):

Code:
elastix*CLI> core set verbose 50
Verbosity was 60 and is now 50
    -- Starting simple switch on 'Zap/7-1'

    -- Executing [104@AllowNational:1] Goto("Zap/7-1", "AllowNational_rulematch|104|1") in new stack

    -- Goto (AllowNational_rulematch,104,1)
   
 -- Executing [104@AllowNational_rulematch:1] Macro("Zap/7-1", "exten-vm|novm|104") in new stack
    -- Executing [s@macro-exten-vm:1] Macro("Zap/7-1", "user-callerid") in new stack
    -- Executing [s@macro-user-callerid:1] NoOp("Zap/7-1", "user-callerid: device 106") in new stack
    -- Executing [s@macro-user-callerid:2] Set("Zap/7-1", "AMPUSER=106") in new stack
    -- Executing [s@macro-user-callerid:3] GotoIf("Zap/7-1", "0?report") in new stack
    -- Executing [s@macro-user-callerid:4] ExecIf("Zap/7-1", "1|Set|REALCALLERIDNUM=106") in new stack
    -- Executing [s@macro-user-callerid:5] NoOp("Zap/7-1", "REALCALLERIDNUM is 106") in new stack
    -- Executing [s@macro-user-callerid:6] Set("Zap/7-1", "AMPUSER=106") in new stack
    -- Executing [s@macro-user-callerid:7] Set("Zap/7-1", "AMPUSERCIDNAME=ZAP7(darko)") in new stack
    -- Executing [s@macro-user-callerid:8] GotoIf("Zap/7-1", "0?report") in new stack
    -- Executing [s@macro-user-callerid:9] Set("Zap/7-1", "AMPUSERCID=106") in new stack
    -- Executing [s@macro-user-callerid:10] Set("Zap/7-1", "CALLERID(all)="ZAP7(darko)" <106>") in new stack
    -- Executing [s@macro-user-callerid:11] Set("Zap/7-1", "REALCALLERIDNUM=106") in new stack
    -- Executing [s@macro-user-callerid:12] ExecIf("Zap/7-1", "0|Set|CHANNEL(language)=") in new stack
    -- Executing [s@macro-user-callerid:13] NoOp("Zap/7-1", "TTL:  ARG1: novm") in new stack
    -- Executing [s@macro-user-callerid:14] GotoIf("Zap/7-1", "0?continue") in new stack
    -- Executing [s@macro-user-callerid:15] Set("Zap/7-1", "__TTL=64") in new stack
    -- Executing [s@macro-user-callerid:16] GotoIf("Zap/7-1", "1?continue") in new stack
    -- Goto (macro-user-callerid,s,23)
    -- Executing [s@macro-user-callerid:23] NoOp("Zap/7-1", "Using CallerID "ZAP7(darko)" <106>") in new stack
    -- Executing [s@macro-exten-vm:2] Set("Zap/7-1", "FROMCONTEXT=exten-vm") in new stack
    -- Executing [s@macro-exten-vm:3] Set("Zap/7-1", "VMBOX=novm") in new stack
    -- Executing [s@macro-exten-vm:4] Set("Zap/7-1", "EXTTOCALL=104") in new stack
    -- Executing [s@macro-exten-vm:5] Set("Zap/7-1", "CFUEXT=") in new stack
    -- Executing [s@macro-exten-vm:6] Set("Zap/7-1", "CFBEXT=") in new stack
    -- Executing [s@macro-exten-vm:7] Set("Zap/7-1", "RT=""") in new stack
    -- Executing [s@macro-exten-vm:8] Macro("Zap/7-1", "record-enable|104|IN") in new stack
    -- Executing [s@macro-record-enable:1] GotoIf("Zap/7-1", "0?2:4") in new stack
    -- Goto (macro-record-enable,s,4)
    -- Executing [s@macro-record-enable:4] AGI("Zap/7-1", "recordingcheck|20080809-190936|asterisk-1218301769.55") in new stack
    -- Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
  recordingcheck|20080809-190936|asterisk-1218301769.55: Inbound recording not enabled
    -- AGI Script recordingcheck completed, returning 0
    -- Executing [s@macro-record-enable:5] NoOp("Zap/7-1", "No recording needed") in new stack
    -- Executing [s@macro-exten-vm:9] Macro("Zap/7-1", "dial||tTrwW|104") in new stack
    -- Executing [s@macro-dial:1] GotoIf("Zap/7-1", "1?dial") in new stack
    -- Goto (macro-dial,s,3)
    -- Executing [s@macro-dial:3] AGI("Zap/7-1", "dialparties.agi") in new stack
    -- Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
  dialparties.agi: Starting New Dialparties.agi
  == Parsing '/etc/asterisk/manager.conf': Found
  == Parsing '/etc/asterisk/manager_additional.conf': Found
  == Parsing '/etc/asterisk/manager_custom.conf': Found
  == Manager 'admin' logged on from 127.0.0.1
  dialparties.agi: Caller ID name is 'ZAP7(darko)' number is '106'
  dialparties.agi: USE_CONFIRMATION:  'FALSE'
  dialparties.agi: RINGGROUP_INDEX:   ''
  dialparties.agi: Methodology of ring is  'none'
    --  dialparties.agi: Added extension 104 to extension map
    --  dialparties.agi: Extension 104 cf is disabled
    --  dialparties.agi: Extension 104 do not disturb is disabled
       >  dialparties.agi: extnum 104 has:  cw: 1; hascfb: 0 [] hascfu: 0 []
       >  dialparties.agi: ExtensionState: 0
    --  dialparties.agi: dbset CALLTRACE/104 to 106
    --  dialparties.agi: Filtered ARG3: 104
  == Manager 'admin' logged off from 127.0.0.1
    -- AGI Script dialparties.agi completed, returning 0
    -- Executing [s@macro-dial:7] Dial("Zap/7-1", "ZAP/5||tTrwW") in new stack
    -- Called 5
    -- Zap/5-1 is ringing
    -- Executing [**104@AllowNational:1] Goto("SIP/506-b7847818", "app-blackhole|hangup|1") in new stack
    -- Goto (app-blackhole,hangup,1)
    -- Executing [hangup@app-blackhole:1] NoOp("SIP/506-b7847818", "Blackhole Dest: Hangup") in new stack
    -- Executing [hangup@app-blackhole:2] Hangup("SIP/506-b7847818", "") in new stack
  == Spawn extension (app-blackhole, hangup, 2) exited non-zero on 'SIP/506-b7847818'
    -- Zap/5-1 is ringing
    -- Hungup 'Zap/5-1'
  == Spawn extension (macro-dial, s, 7) exited non-zero on 'Zap/7-1' in macro 'dial'
  == Spawn extension (macro-dial, s, 7) exited non-zero on 'Zap/7-1' in macro 'exten-vm'
  == Spawn extension (macro-dial, s, 7) exited non-zero on 'Zap/7-1'
    -- Executing [h@macro-dial:1] Macro("Zap/7-1", "hangupcall") in new stack
    -- Executing [s@macro-hangupcall:1] ResetCDR("Zap/7-1", "w") in new stack
    -- Executing [s@macro-hangupcall:2] NoCDR("Zap/7-1", "") in new stack
    -- Executing [s@macro-hangupcall:3] GotoIf("Zap/7-1", "1?skiprg") in new stack
    -- Goto (macro-hangupcall,s,6)
    -- Executing [s@macro-hangupcall:6] GotoIf("Zap/7-1", "1?skipblkvm") in new stack
    -- Goto (macro-hangupcall,s,9)
    -- Executing [s@macro-hangupcall:9] GotoIf("Zap/7-1", "1?theend") in new stack
    -- Goto (macro-hangupcall,s,11)
    -- Executing [s@macro-hangupcall:11] Hangup("Zap/7-1", "") in new stack
  == Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'Zap/7-1' in macro 'hangupcall'
  == Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'Zap/7-1'
    -- Hungup 'Zap/7-1'
elastix*CLI>
 

telecomtechnician

Joined
Jan 8, 2008
Messages
422
Likes
0
Points
16
#2
Hi there

I am having the same problem, I cannot pickup calls. I have not seen an option in freepbx where you can create a pickup group, only a ring group.

I am working with sip extensions and the phones are connected through ATA.

Waiting for your comment

David Medina
 

jgutierrez

Joined
Feb 28, 2008
Messages
5,737
Likes
0
Points
0
#3
okle100 have you tried to edit your ZAP extension and leave in blank the option that says "echotraining"?

if in your zapata configuration file you have set callgroup and callpickup to 1, also check that your sip extension has set up with callgroup and pickupgroup to 1
 

jgutierrez

Joined
Feb 28, 2008
Messages
5,737
Likes
0
Points
0
#4
telecomtechnician make sure that the sip extensions that you are using are on the same callgroup and pickupgroup, you may check that if you edit your extension on the web interface, also make sure that there isn't a feature code on your ATA for *8
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top