call disconnect after 20 second

abbass@

Joined
Feb 28, 2010
Messages
15
Likes
0
Points
0
#1
Hi There,

Is there anybody can help me please,

diagnostic info,

1. elastix server is fresh installed, sip_nat, sip_general_config files seems ok.
2. nat settings is ok on router.
3. all local and remote sip extensions registered to elastix without problem.
4. local calls perfect.
5. i use eyebeam for sip clients.
6. g.711u is a selected codec for all sip extensions.

here is problem,

when remote sip extensions call each other, they start talking without problem but after 20-30 second call disconnect unexpectedly. Same problem happening for local to remote or remote to local call as well.

Thanks
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#2

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#3
Hi abbas.

Like Dicko said. Maybe a router problem.

Hi Dicko... How are you? :)

I had the same problem when I had modified the range RTP port from 10000/20000 to 10000/10050.
I had only changed into Asterisk but not into my router.
Remember that you must redirect every port (SIP & RTP) to the Elastix server.
So 5060 and 10000/20000 (UDP) basically.
And today, it's seems that it works fine.
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#4
Franck, I am well, tu aussi?, how is the little shed, I built one with my son a couple of weeks ago to store his crap (he went to Chile, he's in love, zut alors!!)?

for abbass@ :
when it comes to rtp all points must agree as to what is acceptable, the server, the various routers and the extension, by convention Asterisk has always used 10000-20000, it sounds big but it unlikely that there will be any problem as most extensions understand that they will often be talking to an Asterisk box, if you decide to reduce that range then please do that symmetrically throughout your infrastructure

regards to all
dicko
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#5
dicko said:
Franck, I am well, tu aussi?, how is the little shed, I built one with my son a couple of weeks ago to store his crap (he went to Chile, he's in love, zut alors!!)?
Yes, I'm well.
There's few day, a little twister came in my village. :S
Arrrghhh, I didn't like that.
No damage. Excepted the operator cable. 10 hours without telephone and internet.
 

abbass@

Joined
Feb 28, 2010
Messages
15
Likes
0
Points
0
#6
I am still exploring the problem over your suggestions, here i captured packets during the call established and ended, this capture can gives you more idea about the problem, it seems elastix say bye to local extension after while.

http://img246.imageshack.us/img246/7756/byeh.jpg


192.168.1.85 ---elastix ip
86.186...... ---remote extension ip (phone number: 102)
192.168.1.35 ---local extension ip (phone number: 100)

Thanks
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#7
Attach your config files into your next post.
by example : sip_nat.conf & sip_general_custom.conf & sip_additionnal.conf (only the 100 and the 102) & a sample router config -> config.zip

Like that whe could see your config.

In France, it's the night, so at tomorrow. :side:

Maybe Dicko could retake the next, why not...!?

Regards
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#8
try

qualify=15

in the extension
 

abbass@

Joined
Feb 28, 2010
Messages
15
Likes
0
Points
0
#9
Hi,

Thank you very much your replies, i am trying to get info as much as i can.

http://rapidshare.com/files/358620647/e ... s.txt.html

I attached elastix confs. but there is no way to get editable config file from the router, manufacture use specific config format, therefore i am gona write here what i have done on router.

router is zywall70, it was netgear before but i got some nat problem with netgear than i replaced it with zywall. there is very simple configuration on zywall router as below;

firewall: disabled
sip alg:disabled
forwarded ports(tcp/udp): 5060,10001-20000 to elastix

I suspect there is some mistake on the elastix settings or softphone settings, because if i check the captured file i can see that first elastix send BYE packet(every time 20 second) to local extension during the call flow, elastix and local extension are in the same subnet, that means there is no nat, even remote extension cannot terminate the call at the same time because it doesnt know call terminated in local by the elastix, at that moment why elastix doesnt generate any packet for remote extension to inform the call end. http://img246.imageshack.us/img246/7756/byeh.jpg

One more thing, elastix is handeling all udp flow over itself, it is not working like sip proxy, therefore there sould be something implementing by elastix, if it take off itself from the middle after call established between two peer than this issue could happen which is we are trying the sort out, so i can say router unable to carry on calls.
http://img708.imageshack.us/img708/2425/topology.jpg

Actually i am not very good on understanding these things, just i am running on my logic, maybe i am wrong. i am gona perfor your advices.

thanks Danardf i ll wait your reply about configs
thanks Dicko i ll try with chage qualify value

I appreciated
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#10

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#11
Questions:
Why put nat=yes everywhere?

##############sip_nat.conf##############

externhost = my.dyndnsname.org
localnet = 192.168.1.0/255.255.255.0
externrefresh = 10 if you put this , you can put srvlookup=yes into sip_general_custom.conf
############sip_general_custom.conf######################

bindport=5060
bindaddr=0.0.0.0
nat=no
qualify=yes
defaultexpirey=3600
context=from-internal <--- Why .. delete it!!!
useragent=Elastix
disallow=all
allow=alaw <--- G711a, only France and a Part of Europe.
allow=ulaw <--- G711µ, many used in the world
allow=g729 <--- only if this codec is installed.
allow=gsm
allow=ilbc
allow=g723 <--- only if this codec is installed.
.

##############sip_additional.conf###############

[100]
deny=0.0.0.0/0.0.0.0
type=friend
secret=*****
qualify=yes
port=5060
pickupgroup=
permit=0.0.0.0/0.0.0.0
nat=no <--- if your extension is into your LAN
nat=yes <--- if your extension is out off your LAN (WAN / Remote)
mailbox=100@device
host=dynamic
dtmfmode=rfc2833
dial=SIP/100
context=from-internal
canreinvite=no
callgroup=
callerid=device <100>
accountcode=
call-limit=50
You talk about RTP site your router. 10001 - 20000
You didn't listen to me.

Look at the rtp.conf file, your range must be exactly the same that config router!!!!
If no, do it.

Try this, and let we know. ;)
 

abbass@

Joined
Feb 28, 2010
Messages
15
Likes
0
Points
0
#12
Hi,

Thanks for your helps, i tried all these but result is same,

OH SORY DANARDF I HAVE'NT SEEN YOUR PREVIOUS POST, I JUST TRIED OTHER ADVICES,
SORY I LL TRY YOUR SUGGESTION NOW THAN LET YOU KNOW.


when i change the qualify value, call cannot connect between the peers.
when i enabled the SIP ALG everything stop working.
When i disabled sip alg and forwarded all port to elastix than i see problem same as before i reported.

if you attach configuration files here i can try to replace them with mines, elastix just fresh installed and i have set only network setting, config files and put 4-5 extensions. I touched only two config file, these are sip_nat.conf and sip_general_custom.conf

##############sip_nat.conf##############

nat = yes
externhost = my.dyndnsname.org
localnet=192.168.1.0/255.255.255.0
externrefresh = 10

############sip_general_custom.conf######################

bindport=5060
bindaddr=0.0.0.0
nat=yes
qualify=yes
context=from-internal
defaultexpirey=3600
rtptimeout=60
rtpholdtimeout=120
useragent=Elastix
disallow=all
allow=alaw
allow=ulaw
allow=g729
allow=gsm
allow=ilbc
allow=g723



##############sip_additional.conf###############

[100]
deny=0.0.0.0/0.0.0.0
type=friend
secret=100100
qualify=yes
port=5060
pickupgroup=
permit=0.0.0.0/0.0.0.0
nat=yes
mailbox=100@device
host=dynamic
dtmfmode=rfc2833
dial=SIP/100
context=from-internal
canreinvite=no
callgroup=
callerid=device <100>
accountcode=
call-limit=50


[102]
deny=0.0.0.0/0.0.0.0
type=friend
secret=102102
qualify=yes
port=5060
pickupgroup=
permit=0.0.0.0/0.0.0.0
nat=yes
mailbox=102@device
host=dynamic
dtmfmode=rfc2833
dial=SIP/102
context=from-internal
canreinvite=no
callgroup=
callerid=device <102>
accountcode=
call-limit=50
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#13

abbass@

Joined
Feb 28, 2010
Messages
15
Likes
0
Points
0
#14
:( unfortunately i could not make it work properly, i have changed all related config files as you described, i checked nat settings 50 times, no way to fix it. Now progres is

-local to remote calls doesnt disconnect (before it was disconnecting, i am happy for this)
-but remote to local calls still disconnect after 20 second, i cant beliave that, this is really annoying, it is not 50 second or 10 second, it is 20 second like written somewhere.

Thanks
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#15
Then your problem lies either with the xlite configuration or more likely your router/firewall check both (all) of them.

sip set debug ip <remote ip>

will show you what is not being answered.
 

abbass@

Joined
Feb 28, 2010
Messages
15
Likes
0
Points
0
#16
:laugh: :laugh: yeah Dicko i really need to read all RTFMs, i start thinking to get static ip to escape NAT, but i scare that if i could meet the same problem even with static ip, anyway i ll do diagnostic with debug commands. I got some manuels about debugging on asterisk, i hope this time i ll be able to show exact problem to you.

thank you for your guidance
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#17
Then good for you, knowledge and understanding is more permanent than stumbling in the dark, be aware that normally an ALG will bypass the routers NAT'ing so if you set up the ALG and also NAT rules simultaneously you might confuse both yourself and the router :)

regards

dicko
 

Members online

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,564
Latest member
Mai Tuyen
Top