Bug Report - Virtual Fax GUI

Discussion in 'General' started by Bob, May 24, 2008.

  1. Bob


    Nov 4, 2007
    Likes Received:
    Elastix : Version 1.0 (1.0-17)
    Hardware: N/A
    Tested : On three separate systems
    Critical: Medium to low
    Location: Virtual Fax
    Sub Area: GUI PHP Code

    If you create a couple (meaning more than one) of virtual faxes, delete both of them, recreate them, edit them, you will find that the newly added area code, changes to the same as the country code, change it back, and save it, and it appear to correct itself. However, in /etc/iaxmodem, it modifies the iaxmodem-cfg.ttyIAX1 and subsequent files, with the actual port number changed to the Area/Country code.

    Further info:
    The reason why the person deleted & recreated the virtual faxes, was that he was trying to correct the areacode which was set wrong, even though he had it right when he first set the faxes up. So this is an error that will occur again.

    After all the editing, it finally stopped the IAX registrations occurring, and hence no faxes. I have not been able to reproduce this part as yet.

    Temporary Fix:
    On the system that originally had this issue.
    1) Manually edited the /etc/iaxmodem/iaxmodem-cfg.ttyIAX? and provided port numbers starting at 40000 upwards.
    2) Manually deleted the iaxmodem.ttyIAX (note no number), that was created in the mess. This was probably the real reason for the IAX registration failure of all lines.

    Closing Notes:
    At no time (before the error occurred) was any manual changes made on the Elastix system. e.g. all changes were made through the GUI, no quick hacks

Share This Page