Broadvoice trunks not registering

Discussion in 'General' started by danzitting, Oct 15, 2009.

  1. danzitting

    Joined:
    Oct 15, 2009
    Messages:
    7
    Likes Received:
    0
    Hello all,
    I must be missing something but does anyone have Elastix actually working with their Broadvoice account? I have gone all over the internet trying different trunk configurationsand can't seem to make it work. I finally got to the configuration below which, according to Broadvoice support, my lines are registering but then immediately losing their registration. The result is when I call my number, I get the generic Broadvoice voicemail message (e.g. the Elastix box never picks up the call). Any help telling me what I missing in this configuration will be MUCH appreciated as I have searched and searched with no luck. Thanks!

    Trunk Name: Main Line

    PEER Details
    username=<MY BV NUMBER>
    user=phone
    type=peer
    secret=<BV SECRET PASSWORD FOR THIS LINE>
    Qualify=yes
    insecure=very
    host=sip.broadvoice.com
    fromuser=<MY BV NUMBER>
    fromdomain=sip.broadvoice.com
    dtmfmode=inband
    dtmf=inband
    context=from-pstn
    canreinvite=no
    authname=<MY BV NUMBER>

    USER Context:

    USER Details
    username=<MY BV NUMBER>
    user=<MY BV NUMBER>
    type=user
    secret=<BV SECRET PASSWORD FOR THIS LINE>
    insecure=very
    host=sip.broadvoice.com
    fromdomain=sip.broadvoice.com
    dtmfmode=inband
    dtmf=inband
    context=from-pstn

    Register String
    <MY BV NUMBER>@sip.broadvoice.com: <BV SECRET PASSWORD FOR THIS LINE>: <MY BV NUMBER>@sip.broadvoice.com
     
  2. soulofmischief87

    Joined:
    Apr 30, 2008
    Messages:
    42
    Likes Received:
    0
    Your subject says their not registering but I understand otherwise from the content on your post, but can you paste what you get from asterisk cli? and what do you get one do a sip show registry? does your server resolve the dns sip.broadvoice.com? if not check your dns settings and and gateway check if you can resolve any other dns. Also double check your username and password. Im eager to see what your answers are.
     
  3. danzitting

    Joined:
    Oct 15, 2009
    Messages:
    7
    Likes Received:
    0
    Maybe I used the wrong terms. Broadvoice support told me that my lines are registering and then immediately losing their registration because of a problem on my end but didn't know what the problem is. To answer your questions, below are some results from Asterisk CLI, sip.broadvoice.com does resolve fine, and the username/passwords are correct. ANy other ideas wht the problem might be? Thanks!

    elastix*CLI> sip show registry
    Host Username Refresh State Reg.Time
    sip.broadvoice.com:5060 <MY BV NUMEBR>@s 120 Request Sent

    elastix*CLI> sip show peers
    Name/username Host Dyn Nat ACL Port Status
    Broadvoice/<MY BV NUMEBR> 206.15.136.221 5060 UNREACHABLE
    1 sip peers [Monitored: 0 online, 1 offline Unmonitored: 0 online, 0 offline]
     
  4. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    I suggest you check your NAT/PAT settings on your firewall/router/asterisk box.


    (sip debug ip <the problem one>, from asterisk CLI will also be diagnostic)
     

Share This Page