Broadvoice-outgoing fine, no incoming calls

Discussion in 'General' started by daytonbrown, Feb 16, 2011.

  1. daytonbrown

    Joined:
    Feb 16, 2011
    Messages:
    1
    Likes Received:
    0
    Hi all,

    I'm having a problem with my new elastix install. When I direct connect my X-Lite to my Broad Voice account, bot in bound and out bound work great.

    On my elastix server, not so much. Outbound works great, but inbound I get nothing except an almost immediate bounce to the broadvoice voicemail. Here is my trunk setup.

    type=peer
    user=phone
    host=sip.broadvoice.com
    fromdomain=sip.broadvoice.com
    fromuser=2482460221
    secret=XXXXXXXXXXX
    username=2482460221
    insecure=very
    context=from-BroadVoice
    authname=2482460221
    dtmfmode=inband
    dtmf=inband
    canreinvite=no
    progressinband=yes

    Incoming settings / user are blank.

    I have an inbound route that directs everything to my softphone.

    On the sip debug I only get 2 lines whenever I call in.

    == Using SIP RTP TOS bits 184
    == Using SIP RTP CoS mark 5

    Thanks,
     
  2. schleid

    Joined:
    Feb 17, 2011
    Messages:
    19
    Likes Received:
    0
    Try this configuration except for the registration line as I don't know if elastix use it.
    I had the same problem but this config solved it

    [outgoing settings]
    PEER DETAILS

    authname=[Your BV number]
    canreinvite=no
    context=from-broadvoice
    dtmf=inband
    dtmfmode=inband
    fromdomain=sip.broadvoice.com
    fromuser=[Your BV number]
    host=sip.broadvoice.com
    insecure=very
    nat=yes
    secret=[I remove it]
    type=peer
    user=phone
    username=[Your BV number]

    [USER CONTEXT] = SIP.BROADVOICE.COM

    [USER DETAILS]
    context=from-pstn
    dtmf=rfc2833
    dtmfmode=rfc2833
    fromdomain=sip.broadvoice.com
    host=sip.broadvoice.com
    insecure=very
    nat=yes
    secret=[I remove it]
    type=friend
    user=[Your BV number]
    username=[Your BV number]

    registration = [Your BV number]@sip.broadvoice.com:[UR Sip Password]:[Your BV number]@sip.broadvoice.com/[Your BV number]
     

Share This Page