bloquer les appels sortant d'une extension

Discussion in 'Elastix 2.x' started by shakir33, Nov 26, 2009.

  1. shakir33

    Joined:
    Nov 16, 2009
    Messages:
    90
    Likes Received:
    0
    bonjour,

    je vais faire en sorte qu'une extension soit interdit d'effectuer des appels sortant, j'ai utilisé user comme type d'extension mais ça marche pas

    est ce que vous avez des idées ?

    merci
     
  2. newnet82

    Joined:
    Apr 25, 2009
    Messages:
    57
    Likes Received:
    0
  3. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Tout juste Auguste.:laugh:
    Ou avec les permit et deny.
     
  4. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    newnet82 Bonne année.

    Un petit truc qui me chagrine.
    avec le module custom contexts de Freepbx. une fois que tu as concocté ton context, tu l'appliques bien sur ton extension?
    Si tu veux par exemple interdire l'accès à une certaine route sortante, tu fait juste un deny dessus?

    J'ai une version Freepbx 2.6 sur un Elastix 1.6.13 et ça ne fonctionne pas dans une logique normale.

    Dans mon cas, l'accès à la route sortante est toujours valide. par contre, elle ne l'ait plus sur je "deny" tout. (Normal jusque là).
    J'ai un doute sur la fonctionnalité avec les versions?

    tu peux me confirmer que mon exemple est bon?
     
  5. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
    attention dans ton custom context aux options en rouge. Si tu les mets sur allow, toutes les options incluses dans le groupe ne sont pas prise en compte.

    Il faut mettre ALL OUTBOUND ROUTE sur deny, puis sur chaque outbound route mettre allow/deny en fonction de ce que tu veux.
     
  6. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Salut Patrick. :)
     
  7. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    une solution très rapide peût être configurer le context de l'extension, et placer ext-local au lieu de from-internal. Bien sûr, tu devrais èditer l'extension qui a déjà été créé dans l'interfaz de l'Elastix
     
  8. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    La solution paraît bonne.
    A garder sous le coude :p
     

Share This Page