blf problem yealink t28

Discussion in 'IP Phones' started by revlin, Dec 4, 2009.

  1. revlin

    Joined:
    Dec 4, 2009
    Messages:
    3
    Likes Received:
    0
    blf buttons do not work correctly in yealink t28+elastix
    in trixbox it's works. please help.
     
  2. Yealink

    Joined:
    Dec 6, 2009
    Messages:
    3
    Likes Received:
    0
    May I know your T28 firmware version & Elastix firmware version?

    For Yealink T28, please download the lastest firmware below, upgrade and then test again.

    http://www.yealink.com/en/download.asp?BigClassName=IP Phone

    We tested here, but the BLF all worked well.

    Any question, feel free to reach me! :cheer:
     
  3. revlin

    Joined:
    Dec 4, 2009
    Messages:
    3
    Likes Received:
    0
    yealink ver.2.41.0.60,2.3.....all+elastix=1.6.5
    not work



    in elasix 1.5.2...=all work
     
  4. Yealink

    Joined:
    Dec 6, 2009
    Messages:
    3
    Likes Received:
    0
    it seems not because of Yealink phones...

    We'll check with Elastix and test.

    Thanks!
     
  5. lek

    lek Guest

    We have tested against Elastix 1.6 and everything seems to work fine. Could you post details of your test?
     
  6. Xexexe

    Joined:
    Mar 2, 2010
    Messages:
    12
    Likes Received:
    0
    Hi
    Elastix 1.6 and .43 firmware BLF is not working correctly
    after a couple of hours pass..
    So, initially it seems ok but the show hints command now
    shows 0 watchers on the lines.
     
  7. TheFuzz

    Joined:
    Jan 28, 2011
    Messages:
    2
    Likes Received:
    0
    I'm hoping that you can help.

    I'm prototyping an Elastix system running 2.0.3 with four Yealink T28P's with 2.60 firmware. I only have four extensions setup, 2651, 2602 2603 and 2649. I'm not having any luck making the BLF functions work on any of the phones. I've tried various configurations on the phone and within Asterisk.

    I've modified the /etc/asterisk/extensions_custom.conf file with this:

    [blf]
    exten => 2651,hint,SIP/2651
    exten => 2602,hint,SIP/2602
    exten => 2603,hint,SIP/2603
    exten => 2649,hint,SIP/2649

    and also I added into /etc/asterisk/sip_custom.conf

    [general]
    allowsubscribe=yes
    subscribecontext=blf
    notifyringing=yes
    notifyhold=yes
    limitonpeers=yes
    call-limit=99

    With no luck.

    Any help would be greatly appreciated! Thanks!
     
  8. TheFuzz

    Joined:
    Jan 28, 2011
    Messages:
    2
    Likes Received:
    0
    Just in case someone else looks at this thread, I solved the problem. I removed the configuration settings listed above. I did modify /etc/asterisk/sip_general_custom.conf with the following:

    allowsubscribe=yes
    notifyringing=yes
    notifyhold=yes
    limitonpeers=yes

    I'm not sure if this is actually needed or not.

    My problem with the Yealink T28P is that I was attempting to setup the BLF using the Line Keys and not the Memory Keys.

    So, to make it work I programmed the *Memory Keys* for BLF and set the extension in both the value and extension fields and it works.

    It seemed to make sense to me to use the line keys for lines and not the memory keys. The good folks over at 888 Voip Store had a video that led me to the solution.
     

Share This Page