Billing Error

Discussion in 'General' started by aldedi, Apr 18, 2007.

  1. aldedi

    Joined:
    Apr 18, 2007
    Messages:
    1
    Likes Received:
    0
    does anyone here was sucessfully setup the billing system until display the cost of call usage?
    bcause in my server, the billing didn't display anything.

    i was set the rate and also thick the trunk (Zap/g1) but it still didn't display anything even in the CDR Report was display the call usage, duration, source, destination etc.

    is ther anyone know how to setup the billing system correctly.
    i was try to search in google, but i can't found any clue to help me.
     
  2. lek

    lek Guest

    What version of Elastix are you using?
     
  3. saleh

    Joined:
    Apr 18, 2007
    Messages:
    249
    Likes Received:
    0
    i have the same problem
    i using Elastix 0.7.3

    Thanks,
    Saleh
     
  4. bwg

    bwg

    Joined:
    Aug 14, 2008
    Messages:
    62
    Likes Received:
    0
    I'm the similar problem

    I can configure rates for is zap/g0, when I look at the CDR report, I see that I have calls going from zap/1-1. zap/2-1 zap/3-1 ......
    I can not see any of my calls in the billing report, can anyone help me with this.
     
  5. fcastro

    Joined:
    Nov 13, 2008
    Messages:
    8
    Likes Received:
    0
    Hi everybody,
    I have 1.2 version installed and I solved this problem modifying this file:
    /var/www/html/modules/billing_report/index.php line 219

    replacing:
    $troncales = $oTrunk->getExtendedTrunksBill($grupos, $arrConfig['ASTETCDIR']['valor'].'/zapata.conf');//ej array("ZAP/1","ZAP/2");

    by:
    $troncales = $oTrunk->getExtendedTrunksBill($grupos, $arrConfig['ASTETCDIR']['valor'].'/zapata-channels.conf');//ej array("ZAP/1","ZAP/2");

    because zap channels definition is not in zapata.conf, it is in zapata-channels.conf

    I hope this help
    Bye!
     

Share This Page