Biling rate problem !

hetii

Joined
Jun 7, 2007
Messages
32
Likes
0
Points
0
#1
Hi try to run billing rate system for ZAP/g0 trunk but there is something wrong:

i find this file:
/var/www/html/modules/billing_report/index.php
and in inside i find there this array
$troncales[]=$trunkBill

but for Zap chanells this array is empty().

When i set this array to $troncales[]='ZAP/'
then i see my calls in website.

....
fresh info:
in this file i find this expresion:
if (ereg("^(group|channel)=([[:space:]]*.*)",$linea,$regs)){
and this expresion rekognized only group(in ma case) because in my zapata.conf file i have this strings

group=0
....
channel => 1-15
channel => 17-31

group=1

so he cannot find channel.
then i set this
$grupos[0]['channel']='1-15';
$grupos[1]['channel']='17-31'; <- ofcourse this is not tru becouse both channels range is in the same group

and then i check this array:
show($troncales,troncales,1);

and here are reult
ZAP/1
ZAP/2
ZAP/3
ZAP/4
ZAP/5
ZAP/7

so i don`t understad this :( why only 6 position ?

Can somebody developer write me for what is this array ?

i can write there $troncales[]="ZAP/"
and system show me all zap trunks in rate system so for what is this $troncales[]="ZAP/$canal"; ?<br><br>Post edited by: hetii, at: 2007/08/10 12:08
 

adminad

Joined
Apr 29, 2010
Messages
150
Likes
0
Points
0
#2
Dear Hetii,

I think finally we have discover what's happening and it's a bug related with the array called $groupos not being filled properly. I'll fix this issue and release a patch here tomorrow.
 

hetii

Joined
Jun 7, 2007
Messages
32
Likes
0
Points
0
#3
hi edgar :)

do you have this patch ?

(now i use latest elastix but there is still problem with ZAP/g0 trunks and billing rates)

regards :)
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top