Big Delay on Call Center Module

Discussion in 'General' started by mcamerar, Sep 27, 2010.

  1. mcamerar

    Joined:
    Nov 25, 2009
    Messages:
    25
    Likes Received:
    0
    Hi all,

    When I was using the old version of Elastix with the 1.5 call center module everything was working perfectly....
    In August I decided to uninstall it and to install the new version of Elastix 2(actually I have 2.0.0-38 with call center module 2.0 update 9), since then I was unable to use the call center module anymore 'cause of the enormous delay that generates from the moment that the call go through an operator and when he sees the name and data appearing on the screen.
    I tried to change some parameters in the queue and in the call center settings, but nothing changed. Sometimes the data come with 1 sec or 2 sec of delay, but most of the time they are late of 10-15 secs. Anyone has this kind of problem?
    Anyone can help me please?
    Thank you
     
  2. saugortgarcia

    Joined:
    Sep 11, 2009
    Messages:
    9
    Likes Received:
    0
    Hi,

    I have experienced the same problem with call center module. With elastix 1.5 I did not have this problem.

    In my lab just login in agent login delay minutes. Also, Elastix GUI in general seen to be more slow. But the delay is most notorious in call center module. Why?

    Could you give us some advice to resolve this issue?



     
  3. saugortgarcia

    Joined:
    Sep 11, 2009
    Messages:
    9
    Likes Received:
    0
    Hi,

    I have just updated my elastix install to 2.0.0.40, and the issue was corrected.

    I suggest to add somewhere a change list to know what fix,add, correct each version.

    Thanks
     
  4. Disaster

    Joined:
    May 28, 2009
    Messages:
    59
    Likes Received:
    0
    Hi,

    Thank you for the feedback as I had the issue previously with Elastix 1.6, are you also using the latest call center Module?
     
  5. mcamerar

    Joined:
    Nov 25, 2009
    Messages:
    25
    Likes Received:
    0
    Re:Big Delay on Call Center Module & Programming C

    I confirm...in these days Elastix has been updated till version 2.0.42 and finally everything seems to works fine again.

    Still don't know about the "Programming call"...Anyone knows if it works and how?
     
  6. mcamerar

    Joined:
    Nov 25, 2009
    Messages:
    25
    Likes Received:
    0
    Re:Big Delay on Call Center Module & Programming C

    After many tests I found out that there are problems again with 2.0.42.(updated on Sunday) On the contrary friday I updated to 2.0.41 and everything was fine with the call center Module.
    This new version is showing the data again with delay as it was before...
    Anyone has noticed this?
     
  7. saugortgarcia

    Joined:
    Sep 11, 2009
    Messages:
    9
    Likes Received:
    0
    Hi,

    It leads to an interesting question: If we upgrade elastix through yum tool, how we make a downgrade or regression to the previous working version?


    In my case I still on elastix 2.0.40 and call center module 2.0.9 and works fine. Another question: what changes in elastix that affect/strike the callcenter module performance?
     
  8. mcamerar

    Joined:
    Nov 25, 2009
    Messages:
    25
    Likes Received:
    0
    Exactly. Would be really useful to pubblish a list of all the changments that sree applied with every new update. Besides, a function that allows to uninstall every update...
    Hope someone can help.
     
  9. scenarist

    Joined:
    Apr 18, 2011
    Messages:
    92
    Likes Received:
    0
    I am using
    elastix-2.0.0-62 and
    elastix-callcenter-2.0.0-14


    and I also have a BIG problem with delay between two calls in outgoing campaign.

    Does anyone solved this problem or problem still exists?
    What does means "Answering delay"(set to 5 sec) and
    "Enable overcommit of outgoing calls" (unchecked)

    if I setup two queues with 6 agents instead of one queue with 12 agents, on that way maybe I will get a quick dialer?
    Please help me , because with this big delay my call center doesn't make sense.!
     
  10. ezevoip

    Joined:
    Aug 13, 2009
    Messages:
    25
    Likes Received:
    0
    Re: Re:Big Delay on Call Center Module

    i'm using elastix 2.0.0-57 with elastix-callcenter-2.0.0-15, 15 agents working just fine.

    have you checke you procesor and memory use when you activate the module?add info
     
  11. scenarist

    Joined:
    Apr 18, 2011
    Messages:
    92
    Likes Received:
    0
    I have call center with 12 agents which makes only outgoing calls.
    Configuration of elastix server is:
    8 core 3GHz Intel processor
    8GB RAM
    SATA HDD 2x1TB , RAID 1 mode
    Internet connection download 2Mbps/2Mbps.

    I configured two queues with 6 agents per queues.

    Just now, I am thinking that maybe my router make a problem, because some agents sometimes waiting 5 minutes or 3 or 10 minutes to receive call, and some agents receives calls every 10 seconds.

    Please tell me my friend how much time your agents waiting between two calls (approximately).
    You are using one queue with 15 agents or otherwise?
    Do you setup some special functions on your router (port forwarding or similar)??
    Which softphone client you use ?
    Maybe does not make sense for my problem but which antivirus you use ?

    if I do not solve the problem for a few days, I will try with Elastix 1.6 and call center 1.5
     
  12. scenarist

    Joined:
    Apr 18, 2011
    Messages:
    92
    Likes Received:
    0
    Ok. Problem is about my voip provider which I am using. I sent an email to their support and this is their response>

    Code:
    According to our AGB we have to inform you, that the company sipgate doesnt support 
    or tolerate the usage of autodialing programs.
    
    I need some voip provider which allows autodialer?
     

Share This Page