Beta 3.0 User Registration

Joined
Dec 12, 2010
Messages
20
Points
0
What would the proper username be for an extension in 3.0?

I created a user with an extension of 101. I tried every combination of user and domain that I could think of, but I can't get my phone to register. I imagine that there is some magical combination of user and domain that I must use because of the multiple organizations. I just can't figure it out.
 
Joined
Feb 15, 2014
Messages
2
Points
0
I have the same problem here ! No user/password combination can authenticate to the extension.
 
Joined
Feb 15, 2014
Messages
2
Points
0
After install Elastix 3.0.0 beta1, I created 2 extensions for test ( 122 and 123 ), but my SIP clients ( Zoiper or X-Lite ) cannot connect to the service:

/var/log/asterisk/full message:
chan_sip.c: Registration from '"username"<sip:122@192.168.0.199>' failed for '192.168.0.105:25684' - Wrong password

Zoiper returns with SIP 403 - Forbidden

User and Password are OK.

Server and clients are inside the same network.

I don´t have problems wirh Elastix 2.4. I need to upgrade to vtiger 5.4, and only Elastix 3.0 have the php version needed.
 
Joined
Jan 29, 2014
Messages
3
Points
0
I have the same problem.
Zoiper not working to connect to elastix 3.0 beta 1
What other VoIP client can we use?
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Points
36
Doing some testing over the next few hours.

I believe I have an answer for Zoiper (came across similar answer on Friday whilst testing another SIP phone). Zoiper helped me solve the issue with the other phone, but never went back to Zoiper to test it working as well.

Anyhow, will post after i have had a chance to test.

Regards
 
Joined
Dec 12, 2010
Messages
20
Points
0
I managed to get mine working. I don't know if this is the same problem anyone else had.

Even though I had set the mysql and admin passwords on firstboot, for some reason the mysql password (in mysql itself) did not get updated.

I'm guessing the web interface was maybe using the root account and still able to create the extensions? However, asterisk was not able to read the database to let extensions register because asteriskuser had the wrong password compared to what was in /etc/asterisk/res_odbc.conf.

Try running the elastix-admin-passwords again to set them. Or you could also try changing the password in mysql using webmin or any other way you know how, to match what's in the file.

I hope this helps someone else that might have the same problem.
 
Joined
Mar 18, 2014
Messages
2
Points
0
I have tried everything in this thread and I still can't register my phones to this server. Are there any fields that would have changed from 2.4 that need to be set differently on the phones?
 

Members online

No members online now.

Forum statistics

Threads
30,992
Messages
131,106
Members
17,716
Latest member
Orbit114
Top