Been there, done... not quite that!!

sergiogm2000

Joined
Jan 30, 2008
Messages
16
Likes
0
Points
0
#1
This is the response to:
Version 1.0 FreePBX module error - 2008/02/12 19:50
B)
Hi that same thing happened to me when I did that, I guess we are two of the few who are evaluating this such great distro, hehe, anyways, this is what I've done.

download the tar.gz, untar it and manually install it.

you can use the src directory if you want but you can do that on any directory at all.

wget http://mirror.freepbx.org/freepbx-2.4.0.tar.gz
tar zxvf freepbx-2.4.0.tar.gz
cd freepbx-2.4.0

"this lines confused me a little bit but in your case you don't need to start the service 'cause Elastix comes to start the service automatically."

./start_asterisk start # for upgrades use: ./amportal start

"just run this command inside the freepbx-2.4.0 directory and it will work without a problem.

./install_amp

after doing that you can return to the online check for updates in the freepbx portal and you're way to go, now you're going to be able to upgrade ALL the packages painless.
I hope this could help you and any other with this issue.
By the way here's the link where I found how to solve this:
http://www.freepbx.org/support/document ... our-system

I also upgraded openfire to the lastest version and installed webmin and it's not that hard, just google your questions and you'll find the way to solve that and as someone said you can use much of trixbox docs and is pretty much the same but be carefull to first use the elastix proved solution before trying other's distro documentation.

I will try to write all of my issues into one single file to post it, but don't rely on that soon hehehe<br><br>Post edited by: sergiogm2000, at: 2008/02/14 09:54
 

sergiogm2000

Joined
Jan 30, 2008
Messages
16
Likes
0
Points
0
#2
This post is a response to:
Version 1.0 FreePBX module error - 2008/02/12 19:50 Installation went well but when I went to FreePBX to update the modules I got this error

Downloading framework 2401706 of 2401706 (100%)
Untarring..Done.
error copying framework files:
'cp -rf' from src: '/var/www/html/admin/modules/frame­ work/htdocs/*' to dst: '/var/www/html'...details follow
cp: cannot create directory `/var/www/html/_asterisk': Permission denied
cp: cannot create directory `/var/www/html/recordings': Permission denied
Checking for upgrades..No upgrades found
framework installed successfully Looks like Freepbx is still showing 2.3 and not 2.4
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,940
Messages
130,961
Members
17,632
Latest member
moaulool
Top