Bad echo on 2nd TDM400

Discussion in 'General' started by r1200gs, Aug 4, 2009.

  1. r1200gs

    Joined:
    Jul 3, 2009
    Messages:
    15
    Likes Received:
    0
    I have 2 TDM400 cards and 5 POTS lines
    the 1st card has 2 lines and the other has 2
    the 2 lines on the 2nd card have bad echo and the lines on the first card are fine.
    I have switched the cards and lines around to see if it made a difference but it has not.
    I have also edited the file /etc/asterisk/dahdi-channels.conf /etc/asterisk/chan_dahdi.conf to add in the echocancel and echotraining=500
    rxgain=0.0
    txgain=0.0

    It seems like the configuration is only talking care of the first card.

    Some docs talk about a ztmonitor program, do I need that?
     
  2. Megabyte

    Joined:
    Mar 28, 2009
    Messages:
    327
    Likes Received:
    0
    Did you try echocanceller=oslec,1-5 for example, it looks like you dont have echocanceller setup in your system.conf

    Another thing is stop asterisk just the asterisk server and run fxotune -s that will help. but im sure you forget to add echocanceller=oslec,1-5
     
  3. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Megabyte:

    I always thought you had to build the /etc/fxotune.conf file first with fxotune -i (and the parameters pertinent to YOUR particular FXO s. for fxotune -s to have any effect). B)
     
  4. Megabyte

    Joined:
    Mar 28, 2009
    Messages:
    327
    Likes Received:
    0
    Dicko gracias por la aclaracion pero creo que hubiese sido mas productiva si hubieses hecho otro post debajo y le indicas a la persona que necesita una respuesta como debe de hacerlo haciendole las correcciones de lugar a mi post.
     
  5. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Mis disculpas por la percepción del delito, no se pretendía
     
  6. r1200gs

    Joined:
    Jul 3, 2009
    Messages:
    15
    Likes Received:
    0
    I did stop asterisk and ran fxotune -i and started asterisk and the problem is gone!!!
    Thanks very much!!
     
  7. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    As Megabyte says,

    fxotune will improve your echo cancellation if you set it up.

    you can find the documentation at voipinfo.org or (I believe) by running

    fxotune

    basically you need to stop asterisk so fxotune can access the zap/dahdi devices,

    have all your FXO lines connected,
    set up any localisation's necessary when setting up zap/dahdi as to your local line impedences and signaling tones etc. if you don't live in NANP land (these are also on voipinfo.org)

    find a digit that will break dialtone,
    discover how long it takes for the telco to return a "re-order" tone

    and plug those parameters into the

    fxotune -i <needed parameters>

    and wait a few minutes (run it with -vv if you want to see what's going on.) this will seed /etc/fxotune.conf.

    then fxotune -s will be effective.

    [edit]
    Well, either there is a clock skew around here or, I guess my post was as productive as I intended it to be :) :)
    and
    r1200gs:
    Your welcome.
     

Share This Page