AVANTFAX is a MUST!!!!

leiw3248

Joined
Apr 21, 2008
Messages
476
Likes
0
Points
0
Hello ramoncio

Could you help me?

Thanks
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
Sorry leiw3248, I've been out for some time.

What's your status?

Try with this:

Code:
chown -R asterisk.uucp /var/www/html/avantfax/faxes /var/www/html/avantfax/tmp
chmod -R 0777 /var/www/html/avantfax/faxes /var/www/html/avantfax/tmp
 

leiw3248

Joined
Apr 21, 2008
Messages
476
Likes
0
Points
0
Hi ramoncio !

Now fax can delivery to avanfax, but the three "please wait" still here, how to fix it ?

Thanks !
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
Hi leiw3248,

I don't know why you have the "Please, wait", if faxes are working.
Do they work ingoing_/outgoing now?

Have a look at /var/log/iaxmodem/* maybe you can see some errors there..
 

leiw3248

Joined
Apr 21, 2008
Messages
476
Likes
0
Points
0
Hi ramoncio

I saw iaxmodem-cfg.ttyIAX1, iaxmodem-cfg.ttyIAX2 and iaxmodem-cfg.ttyIAX3 in /var/log/iaxmodem directory.

vi iaxmodem-cfg.ttyIAX1:

[2010-06-14 08:23:01] Registration completed successfully.
[2010-06-14 08:23:56] Registration completed successfully.
[2010-06-14 08:24:51] Registration completed successfully.
[2010-06-14 08:25:46] Registration completed successfully.
[2010-06-14 08:26:41] Registration completed successfully.
[2010-06-14 08:27:36] Registration completed successfully.
[2010-06-14 08:28:31] Registration completed successfully.

vi iaxmodem-cfg.ttyIAX2:

[2009-12-24 16:58:31] Registration completed successfully.
[2009-12-24 16:59:26] Registration completed successfully.
[2009-12-24 17:00:21] Registration completed successfully.
[2009-12-24 17:01:16] Registration completed successfully.
[2010-01-01 19:46:17] Terminating...
[2010-05-24 11:37:55] Terminating...
[2010-05-24 12:07:58] Terminating...

vi iaxmodem-cfg.ttyIAX3:

[2010-05-24 12:03:35] Registration completed successfully.
[2010-05-24 12:04:30] Registration completed successfully.
[2010-05-24 12:05:25] Registration completed successfully.
[2010-05-24 12:06:20] Registration completed successfully.
[2010-05-24 12:07:16] Registration completed successfully.
[2010-05-24 12:07:58] Terminating...

Are iaxmodem-cfg.ttyIAX2 and iaxmodem-cfg.ttyIAX3 holding on Terminating... ?
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
It looks as if only ttyIAX1 is working. ttyIAX2 and ttyIAX3 have problems.

See if the iax peers are correctly configured and registered using the console.
Check the iaxmodem config files at /etc/iaxmodem/* and /var/spool/hylafax/etc/config*, and /etc/inittab
And also increase asterisk verbose and debug levels and check asterisk log files for iaxmodem stuff.
 

Usuarioforum

Joined
Nov 15, 2007
Messages
93
Likes
0
Points
0
Hi all:

I have installe a lot avantfax in 1.6 version without problem. Now I have installed 3.2.2 rpm from Ramoncio in a old 1.5.2 elastix version. Can send fax, but can receive. The faxes are received in /var/spool/hylafax/recvq in tiff format, but can't see in avantfax imbox and are not sended. All the logs I see looks right. Where can I see more information about where is the mistake?

Cheers.
 

Terry

Joined
May 25, 2007
Messages
174
Likes
0
Points
0
Dear Sir,
I am using Elastix 1.6.12
with www.lolacolay.com/ramon/elastix-avantfa ... noarch.rpm

Fax function is working great
After some days , i am increase some iax modem and IAX extension ,
I can see Virtual Fax List :Running and idle on ttyIAX1-6
But on the AvantFax web i can see only ttyIAX 1-3
ttyIAX1 [idle] ttyIAX2 [idle] ttyIAX3 [idle]
Why i can not see another new config iax modem 4-6 ??///
Another checking : i connect YajHFC Fax client
ican see all the Fax modem is running
Modem ttyIAX1 (): Running and idle
Modem ttyIAX2 (): Running and idle
Modem ttyIAX6 (): Running and idle
Modem ttyIAX3 (): Running and idle
Modem ttyIAX5 (): Running and idle
Modem ttyIAX4 (): Running and idle

Very starnge ?????//
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
Hi Terry,
You need to manually add the modems to Avantfax.
When you install the rpm, it installs and configures your existing modems at the moment of installation.
If you add iaxmodems after that, you need to go to:

https://yourserverip/avantfax/admin/

And then go to 'Configure modems' and add the new iaxmodems there.
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
This is the part of the script that adds the modems to Avantfax database and changes some config files:

Code:
# CONFIGURE MODEMS TO USE AVANTFAX
for i in `ls /var/spool/hylafax/etc/config.*`; do
  if [ ! -L $i ]; then
cat >> $i << EOF
#
## AvantFAX
#
FaxRcvdCmd:     bin/faxrcvd.php
DynamicConfig:  bin/dynconf.php
UseJobTSI:      true

EOF
fi
done

cat >>  /var/spool/hylafax/etc/config << EOF
#
## AvantFAX
#
NotifyCmd:      bin/notify.php

EOF

# ADD MODEMS
for i in `ls /var/spool/hylafax/etc/config.*`; do
  if [ -f $i ]; then
    modem=`echo $i | awk -F'/' '{print $6}' | awk -F'.' '{print $2}'`

  # ADD MODEMS TO AVANTFAX DATABASE
mysql --user=avantfax --password=$AVANTFAXPASS -e "INSERT INTO Modems SET device='$modem', alias ='$modem'" avantfax
echo "Configuring $modem for AvantFAX"
fi
done
What this does is:

1.- At the end of each /var/spool/hylafax/etc/config.* file (one per modem)
it adds this lines:

#
## AvantFAX
#
FaxRcvdCmd: bin/faxrcvd.php
DynamicConfig: bin/dynconf.php
UseJobTSI: true

2.- At the end of /var/spool/hylafax/etc/config it adds:

#
## AvantFAX
#
NotifyCmd: bin/notify.php

3.- It adds each modem into the Avantfax mysql database, into the table 'Modems'.
 

Terry

Joined
May 25, 2007
Messages
174
Likes
0
Points
0
1 I cannot find available iaxmodem on ip/avantfax/admin
2 i used your script and made a sh file
chmod 777 filename
./filename
IT show error message
'/avantfax.sh: line 2: syntax error near unexpected token `do
'/avantfax.sh: line 2: `for i in `ls /var/spool/hylafax/etc/config.*`; do


how to do now ???/
Thanks all your help .......
 

Terry

Joined
May 25, 2007
Messages
174
Likes
0
Points
0
finilly, i reinstall the avantfax again .......

a problems , How can I remove all the Fax Visor on the web ?
I cannot remove from web ,where can I delete from system ?
 

originaltba

Joined
Aug 17, 2010
Messages
93
Likes
0
Points
0
Hello Ramoncio,

I have avantfax installed on elastix 1.6-12 an all seems to be working great. I only have one problem: after several days of searching with google I can't seem to find any info on how to get email to fax working

fax to email works like a charm I just need help with this final component.

I would also like to say thanks to you because i could not have done it without reading all the helpful info you have provided

keep up the great work and let me know if you can help

thanks
 

johnme

Joined
Nov 28, 2008
Messages
148
Likes
0
Points
0
Hi

Its time to use elastix 2

I have installed elastix 2.0.2 with elastix-avantfax-3.1.6-beta2.noarch.rpm
But it didnt work the wright way.

Does anyone tried avantfax with elastix 2.0.2 with success?

Now i have a elastix 2.0.2 default instalation ready to make tests.

Please let me know if you have some informations for successful installation.
I already downloaded all the scripts i found on this threat, but i am not sure witch of
them is te best for use with elastix 2.

Any suggestions?
John
 

johnme

Joined
Nov 28, 2008
Messages
148
Likes
0
Points
0
Hi

I made a second try with Ramoncio script now (avantfax-3.1.6.sh).
I have change the password of mysql in the script and everything wend ok!

1.In elastix qui in fax tab now there is avantfax.
2.No faxes apear in avantfax only in fax viewer of eastix.
3.I can send faxes from avantfax qui
4.even if i send the fax from avantfax the mail format is from elastix and is wronk
(elastix doesnt handle mails)

Please give me some directions where to look for

1.All faxes should appear in avantfax
2.Avant fax should handle mails and not elastix (avant fax do it better in notifications).

Maybe Ramoncio could give the best help here...

Thanks
John
 

dwaine18

Joined
Dec 28, 2010
Messages
1
Likes
0
Points
0
Re:AVANTFAX is a MUST!!!! Not working for me

Hello,

Thanks for the great job. I am trying to run this command in my Ubuntu Linux cl but it always tells me the following after I try to run th rpm

yum -y localinstall --nogpgcheck elastix-avantfax-3.2.2-beta1.noarch.rpm



********************************************************************************************
Fetched 5,966kB in 3s (1,677kB/s)
Preconfiguring packages ...
Selecting previously deselected package liblua5.1-0.
(Reading database ... 123404 files and directories currently installed.)
Unpacking liblua5.1-0 (from .../liblua5.1-0_5.1.4-5_amd64.deb) ...
Selecting previously deselected package librpmio0.
Unpacking librpmio0 (from .../librpmio0_4.7.2-1lbuild1_amd64.deb) ...
Selecting previously deselected package rpm-common.
Unpacking rpm-common (from .../rpm-common_4.7.2-1lbuild1_all.deb) ...
Selecting previously deselected package librpm0.
Unpacking librpm0 (from .../librpm0_4.7.2-1lbuild1_amd64.deb) ...
Selecting previously deselected package librpmbuild0.
Unpacking librpmbuild0 (from .../librpmbuild0_4.7.2-1lbuild1_amd64.deb) ...
Selecting previously deselected package python-sqlite.
Unpacking python-sqlite (from .../python-sqlite_1.0.1-7ubuntu1_amd64.deb) ...
Selecting previously deselected package python-urlgrabber.
Unpacking python-urlgrabber (from .../python-urlgrabber_3.1.0-5ubuntu1_all.deb) ...
Selecting previously deselected package rpm2cpio.
Unpacking rpm2cpio (from .../rpm2cpio_4.7.2-1lbuild1_amd64.deb) ...
Selecting previously deselected package rpm.
Unpacking rpm (from .../rpm_4.7.2-1lbuild1_amd64.deb) ...
Selecting previously deselected package python-rpm.
Unpacking python-rpm (from .../python-rpm_4.7.2-1lbuild1_amd64.deb) ...
Selecting previously deselected package python-sqlitecachec.
Unpacking python-sqlitecachec (from .../python-sqlitecachec_1.1.2-1ubuntu1_amd64.deb) ...
Selecting previously deselected package yum.
Unpacking yum (from .../yum_3.2.25-1ubuntu2_all.deb) ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Setting up liblua5.1-0 (5.1.4-5) ...

Setting up librpmio0 (4.7.2-1lbuild1) ...

Setting up rpm-common (4.7.2-1lbuild1) ...
Setting up librpm0 (4.7.2-1lbuild1) ...

Setting up librpmbuild0 (4.7.2-1lbuild1) ...

Setting up python-sqlite (1.0.1-7ubuntu1) ...

Setting up python-urlgrabber (3.1.0-5ubuntu1) ...

Setting up rpm2cpio (4.7.2-1lbuild1) ...
Setting up rpm (4.7.2-1lbuild1) ...
Trying rpm init...

Setting up python-rpm (4.7.2-1lbuild1) ...

Setting up python-sqlitecachec (1.1.2-1ubuntu1) ...

Processing triggers for python-central ...
Setting up yum (3.2.25-1ubuntu2) ...

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for python-support ...
linux@ubuntu:~$ yum -y localinstall --nogpgcheck elastix-avantfax-3.2.2-beta1.noarch.rpm
error: cannot open Name index using db3 - No such file or directory (2)
error: cannot open Providename index using db3 - No such file or directory (2)
You need to be root to perform this command.
linux@ubuntu:~$ sudo yum -y localinstall --nogpgcheck elastix-avantfax-3.2.2-beta1.noarch.rpm
Setting up Local Package Process
Examining elastix-avantfax-3.2.2-beta1.noarch.rpm: elastix-avantfax-3.2.2-beta1.noarch
Marking elastix-avantfax-3.2.2-beta1.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package elastix-avantfax.noarch 0:3.2.2-beta1 set to be updated
--> Processing Dependency: /bin/sh for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: /bin/sh for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: /bin/sh for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: /bin/sh for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: /usr/bin/php for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: ImageMagick for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: expect for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: ghostscript for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: ghostscript-fonts for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: httpd for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: libpng for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: libtiff for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: libtiff-devel for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: libungif for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: mysql-server for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: netpbm-progs for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: php for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: php-mbstring for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: php-mysql for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: php-pear for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: php-pear-MDB2-Driver-mysql for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: php-pear-Mail for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: php-pear-Mail-Mime for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: php-pear-Net-SMTP for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: php-pecl-Fileinfo for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: rsync for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: sudo for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: vixie-cron for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: /usr/bin/php for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: /bin/sh for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: /bin/sh for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: /bin/sh for package: elastix-avantfax-3.2.2-beta1.noarch
--> Processing Dependency: /bin/sh for package: elastix-avantfax-3.2.2-beta1.noarch
--> Finished Dependency Resolution
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: rsync is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: php-pear-Mail is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: mysql-server is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: php-pear-Net-SMTP is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: /bin/sh is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: httpd is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: php-pecl-Fileinfo is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: php-pear-Mail-Mime is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: php-mbstring is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: libtiff is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: ghostscript-fonts is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: expect is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: sudo is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: /usr/bin/php is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: php-mysql is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: libtiff-devel is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: netpbm-progs is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: vixie-cron is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: ImageMagick is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: php is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: php-pear is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: ghostscript is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: php-pear-MDB2-Driver-mysql is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: libpng is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
elastix-avantfax-3.2.2-beta1.noarch from /elastix-avantfax-3.2.2-beta1.noarch has depsolving problems
--> Missing Dependency: libungif is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: libpng is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: php-pear-Mail is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: ghostscript-fonts is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: php-pear-Net-SMTP is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: ghostscript is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: sudo is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: ImageMagick is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: libtiff-devel is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: rsync is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: /usr/bin/php is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: expect is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: netpbm-progs is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: php-mysql is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: libtiff is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: php-pecl-Fileinfo is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: /bin/sh is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: php-mbstring is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: php-pear-Mail-Mime is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: php is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: vixie-cron is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: php-pear-MDB2-Driver-mysql is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: php-pear is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: httpd is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: mysql-server is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
Error: Missing Dependency: libungif is needed by package elastix-avantfax-3.2.2-beta1.noarch (/elastix-avantfax-3.2.2-beta1.noarch)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest


**************************************************************************************************

Please can someone let me know exactly what Im doing wrong as I am sure that Im not suppose to install each of these missing dependencies one by one.

Thanks a million,
Dwayne
 

johnme

Joined
Nov 28, 2008
Messages
148
Likes
0
Points
0
Hi

This rpm is for centos (red hat) and you are using ubuntu as you said... this is debian.
I dont beleive it will work.

Bye
John
 

mehrshid

Joined
Jun 15, 2009
Messages
4
Likes
0
Points
0
Hello dwaine18
You can skip this error :

yum -y localinstall --nogpgcheck elastix-avantfax-3.2.2-beta1.noarch.rpm --skip-broken

Regards
Mehran
 

maumar

Joined
Sep 12, 2008
Messages
80
Likes
0
Points
0
i am installing:
Code:
elastix-avantfax-3.3.2-beta1.noarch.rpm
into last stable elastix, last at the date i am writing:

Code:
Elastix-2.0.3-x86_64-bin-15nov2010.iso
yes, skipping broken packages does work, but then you end up with:
Code:
### DB Settings: avantfax d58fe49 avantfax eLaStIx.2oo7
### Testing root access for MySQL
### Creating AvantFAX MySQL database
### Creating avantfax account with password d58fe49 for DB avantfax
  Installing     : elastix-avantfax                                                                                                                                                                                       53/53 
####### Creating AvantFAX menu in Elastix #######
Menu AvantFAX already exists...
setsebool:  SELinux is disabled.
Stopping MySQL:  [  OK  ]
Starting MySQL:  [  OK  ]
Stopping httpd: [  OK  ]
Starting httpd: [  OK  ]
ls: /var/spool/hylafax/etc/config.*: No such file or directory
###############################################################################
Log into the AvantFAX Administrative interface at: http://192.168.111.191/admin/
Username: admin
Password: password
###############################################################################
Done

Installed:
  elastix-avantfax.noarch 0:3.3.2-beta1                                                                                                                                                                                         

Dependency Installed:
  GConf2.x86_64 0:2.14.0-9.el5                          ImageMagick.x86_64 0:6.4.0.10-2                        ORBit2.x86_64 0:2.14.3-5.el5                      atk.x86_64 0:1.12.2-1.fc6                                     
  avahi.x86_64 0:0.6.16-10.el5_6                        avahi-glib.x86_64 0:0.6.16-10.el5_6                    bitstream-vera-fonts.noarch 0:1.10-7              expect.x86_64 0:5.43.0-5.1                                    
  gamin.x86_64 0:0.1.7-8.el5                            giflib.x86_64 0:4.1.3-7.3.3.el5                        gnome-keyring.x86_64 0:0.6.0-1.fc6                gnome-mime-data.x86_64 0:2.4.2-3.1                            
  gnome-mount.x86_64 0:0.5-3.el5                        gnome-vfs2.x86_64 0:2.16.2-6.el5_5.1                   gtk2.x86_64 0:2.10.4-21.el5_5.6                   hicolor-icon-theme.noarch 0:0.9-2.1                           
  jasper-libs.x86_64 0:1.900.1-13.el5                   lcms.x86_64 0:1.18-0.1.beta1.el5_3.2                   libXcursor.x86_64 0:1.1.7-1.1                     libXfixes.x86_64 0:4.0.1-2.1                                  
  libXft.x86_64 0:2.1.10-1.1                            libXi.x86_64 0:1.0.1-4.el5_4                           libXinerama.x86_64 0:1.0.1-2.1                    libXrandr.x86_64 0:1.1.1-3.3                                  
  libXres.x86_64 0:1.0.1-3.1                            libbonobo.x86_64 0:2.16.0-1.1.el5_5.1                  libbonoboui.x86_64 0:2.16.0-1.fc6                 libcroco.x86_64 0:0.6.1-2.1                                   
  libglade2.x86_64 0:2.6.0-2                            libgnome.x86_64 0:2.16.0-6.el5                         libgnomecanvas.x86_64 0:2.14.0-4.1                libgnomeui.x86_64 0:2.16.0-5.el5                              
  libgsf.x86_64 0:1.14.1-6.1                            libnotify.x86_64 0:0.4.2-6.el5                         librsvg2.x86_64 0:2.16.1-1.el5                    libwmf.x86_64 0:0.2.8.4-10.2                                  
  libwnck.x86_64 0:2.16.0-4.fc6                         netpbm.x86_64 0:10.35.58-8.el5                         netpbm-progs.x86_64 0:10.35.58-8.el5              notification-daemon.x86_64 0:0.3.5-9.el5                      
  pango.x86_64 0:1.14.9-8.el5.centos.2                  php-pear-Auth-SASL.noarch 0:1.0.4-1.el5                php-pear-MDB2.noarch 0:2.4.1-2.el5.centos         php-pear-MDB2-Driver-mysql.noarch 0:1.4.1-3.el5.centos        
  php-pear-Mail.noarch 0:1.1.14-5.el5.1                 php-pear-Mail-Mime.noarch 0:1.4.0-1.el5.centos         php-pear-Net-SMTP.noarch 0:1.4.4-1.el5            php-pear-Net-Socket.noarch 0:1.0.10-1.el5                     
  php-pecl-Fileinfo.x86_64 0:1.0.4-3.el5.centos         rsync.x86_64 0:2.6.8-3.1                               shared-mime-info.x86_64 0:0.19-5.el5              startup-notification.x86_64 0:0.8-4.1                         

Skipped (dependency problems):
  php53-common.x86_64 0:5.3.3-1.el5                                                                            php53-common.x86_64 0:5.3.3-1.el5_6.1    
  
  
  Complete!
i dunno if now php is a consistent status ;( http://forum.elastix.org/old_files/elastix_avantfax_3.txt
 

maumar

Joined
Sep 12, 2008
Messages
80
Likes
0
Points
0
my doubt is: having php 5.3 into elastix 2.0.2, born to live with php 5.2, could create some issue?
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,967
Messages
131,028
Members
17,677
Latest member
John-V
Top