Australian Daylight Saving time Problem

Discussion in 'General' started by Newcopia, Oct 8, 2008.

  1. Newcopia

    Joined:
    Apr 3, 2008
    Messages:
    14
    Likes Received:
    0
    There is a problem with the time in elastix not displaying and applying the operating system time.
    The Centos operating system has had the time zone updated and correctly shows the correct daylight saving time. But the Elastix (free-pbx) panel and more importantly timed conditions is not correctly updated.
    Neither are the phones displaying the correct time.

    There has been some discussion about it here
    http://forums.whirlpool.net.au/forum-re ... ?t=1065204
    Does anyone know where elastix or free-pbx is getting its time from?

    Can anyone help in fixing this problem as time conditions are being affected?
     
  2. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    Newcopia,

    After a lot more investigation, it appears that PHP keeps its own database of Timezones (or at least till recently). The Elastix GUI being written in PHP is using the PHP timezone database.

    Thankfully I have a 1.3-2 system from a fresh build and it appears that it has the latest release of PHP (PHP 5.1.6 (cli) (built: Jul 16 2008 19:53:00)). It is showing the correct time in the GUI.

    The 1.1 Stable system is using a previous version of PHP (PHP 5.1.6 (cli) (built: Sep 20 2007 10:16:10)). On these couple of systems that I have access to, the GUI time is wrong.

    From what I can gather via Bug reports/Change logs, as per the 2008 version, they started using TZdata to allow PHP to match the changes in the O/S (makes sense).

    So the real fix from what I can see is perform the YUM updates to bring your system up to Elastix 1.3-2, and your problem will be solved.

    Now back to getting YUM working after getting stuck on WANPIPE.

    If you are also stuck getting the YUM updates to work in total, I suspect that you could do a YUM update of the PHP files (by themselves) to get the GUI issue fixed.

    One other alternative, if you are after a quick fix is to set your Timezone to Brisbane as they historically changed 2-3 weeks before Sydney. Not good, but it gives you a bit of breathing space to get issues resolved.

    Regards
    Bob
     
  3. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    P.S

    If you want to check what version you are running using php --version

    # php --version
    PHP 5.1.6 (cli) (built: Sep 20 2007 10:16:10)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

    The one above is from a 1.1 System (e.g. GUI not working)

    # php --version
    PHP 5.1.6 (cli) (built: Jul 16 2008 19:53:00)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

    The one above is from a 1.3-2 System (e.g. GUI working)


    Regards

    Bob
     
  4. Newcopia

    Joined:
    Apr 3, 2008
    Messages:
    14
    Likes Received:
    0
    Thanks Bob
    I am running Elastix 1.2.1-4 so that could well be the issue I have changed the time zone to pacific / Noumea it is plus 11 hours (I can't get this to show the plus sign -|- )as is our daylight saving time.

    Brisbane don't have DST so if I was to use their time zone it would be 2 hours out.

    I will consider doing a yum update over the weekend.

    Cheers Newcopia
     
  5. Newcopia

    Joined:
    Apr 3, 2008
    Messages:
    14
    Likes Received:
    0
    my version
    [root@PBX ~]# php --version
    PHP 5.1.6 (cli) (built: Sep 20 2007 10:16:10)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
     
  6. Filipe

    Joined:
    Sep 28, 2009
    Messages:
    2
    Likes Received:
    0
    Hello BOB and newcopia

    I tried almost everything but still i can't match the server time whit the web gui in elastix.

    It's always 1 hour off. (In my case 1 hour ahead)

    My php version is:

    PHP 5.1.6 (cli) (built: Apr 7 2009 08:00:04)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

    My elastix version is :

    Elaxtix 1.5.2-2.3

    i've done all the yum updates and messed around whit TZDATA and UTP.

    My BIOS clock is correct and i basically run out of options.

    Can sameone tell me where the php gets the time from? Or wich file to correct and command to execute?

    Regards
     
  7. MrWolf

    Joined:
    Feb 15, 2010
    Messages:
    1
    Likes Received:
    0
    Hello gentlemen
    I regret to say that I have the same problem.

    The only difference is that regardless of the BIOS time elastix (V1.4 no YUM / and PHP Jul 16 2008)
    I can never never get the BIOS time and the Elastix time to match.
    I have checked and I have set the correct time zone in general settings as well as in the Time-Date sections of the GUI.


    1) however when I change the time in the GUI it changes the BIOS time and makes it about 23 hours ahead. Then later the the NTP updates the Time it makes the brisbane time an hour fast. I dont really care about the BIOS time if only the Elastix time would remain correct.

    2) Another thing that might us find the cause is that BOB said that brisbane time change kicks in several weeks earlier than Sydney however the fact is that Brisbane / QLD does not have a daylight savings time slot at all. Our time does not change..

    Can someone please help. Its driving me nuts LOL..
    Is there some way of disabling daylight savings all together
     

Share This Page