astribank Xorcom USB

heronleal

Joined
Jan 25, 2008
Messages
33
Likes
0
Points
0
#1
I have installed a Channel bank of Xorcom. 2 FXO and 6FXS.

I did install with hardware detection at elastix
I did edit manually zapata.conf and include to zapata_additional.conf;

My screen is here attached

I don't know why appears 12 FXO and 2 FXS?

sip phones to zap phones works, but zap to zap does not work.

I know that when a call is dialed of one sip to a zap, asterisk do this. But when a zap to zap asterisk does not do it, and channel bank must do that.

at console of SSH there's an error like this:

ERR-xpp_usb: xusb_xframe_send: failed submit_urb: -90
ERR-xpp_usb: failed re-submitting read urb, error -90
Zaptap registered 'sample' char driver on major 33
Registered Tormenta2 PCI
Unregistered Tormenta2
Specify address with base=0xNNNNN
Wildcard USB FXS Interface driver registered
NOTICE-xpp: XBUS-00: Using default packet allocators
ERR-xpp_usb: Failed to initializa xpp usb bus: -19



My lspci is here:
[root@elastix asterisk]# lspci
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller IDE (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller (rev 01)
02:02.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 24)



my interrupts here:
[root@elastix asterisk]# cat /proc/interrupts
CPU0 CPU1
0: 60232235 0 IO-APIC-edge timer
1: 1421 0 IO-APIC-edge i8042
8: 3 0 IO-APIC-edge rtc
9: 0 0 IO-APIC-level acpi
12: 138 0 IO-APIC-edge i8042
14: 539941 0 IO-APIC-edge ide0
169: 63121 0 IO-APIC-level eth0
193: 0 0 IO-APIC-level uhci_hcd:usb3
201: 181628344 0 IO-APIC-level uhci_hcd:usb1, ehci_hcd:usb5
209: 84619 0 IO-APIC-level uhci_hcd:usb2, libata
217: 0 0 IO-APIC-level uhci_hcd:usb4
225: 184 0 IO-APIC-level HDA Intel
NMI: 0 0
LOC: 58419881 58419904
ERR: 0
MIS: 0


Anyone can helP?????

tks

Post edited by: heronleal, at: 2008/01/31 23:16

Post edited by: heronleal, at: 2008/01/31 23:18<br><br>Post edited by: heronleal, at: 2008/01/31 23:26
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#2
This is normal.
I have an astribank 2/6 too and I think those 6 channels are for the case that you use the rj45 connectors in the front of the unit INSTEAD of using the rj11 connectors. I don't think you will be able to use all of them at the same time (but maybe as failover??).
I use
1-6 extensions fxs
13-14 lines fxo

Please post your /etc/zapata.conf and /etc/zaptel*
A very common problem is that Elastix by default creates zap extensions with echotraining activated. You must disable echotraining.
 

heronleal

Joined
Jan 25, 2008
Messages
33
Likes
0
Points
0
#3
HAHAHAHA,

Thanks a lot my friend.

U are completely right.

Echotraining is the problem.

Thanks a lot.

Anyway, there it is.

etc/zaptel*
# Span 1: XBUS-00/XPD-00 "Xorcom XPD #00/00: FXS"
fxoks=1
fxoks=2
fxoks=3
fxoks=4
fxoks=5
fxoks=6
# astbanktype: output
fxoks=7
# astbanktype: output
fxoks=8
# astbanktype: input
fxoks=9
# astbanktype: input
fxoks=10
# astbanktype: input
fxoks=11
# astbanktype: input
fxoks=12

# Span 2: XBUS-00/XPD-10 "Xorcom XPD #00/10: FXO"
fxsks=13
fxsks=14

# Global data
loadzone = us
defaultzone = us

/etc/zapata_additionals.conf

;;;;;;[401]
signalling=fxo_ks
record_out=Adhoc
record_in=Adhoc
mailbox=401
immediate=no
group=5
echotraining=no
echocancelwhenbridged=no
echocancel=yes
context=from-internal
callprogress=no
callerid=ZAP channel 1 <401>
busydetect=no
busycount=7
channel=>1

;;;;;;[402]
signalling=fxo_ks
record_out=Adhoc
record_in=Adhoc
mailbox=402
immediate=no
group=5
echotraining=no
echocancelwhenbridged=no
echocancel=yes
context=from-internal
callprogress=no
callerid=ZAP channel 2 <402>
busydetect=no
busycount=7
channel=>2

Note: it goes till 4012

/etc/zapata-channels.conf
; Span 1: XBUS-00/XPD-00 "Xorcom XPD #00/00: FXS"
;;; line="1 XPP_FXS/00/00/0 FXOKS (In use)"
signalling=fxo_ks
callerid="Channel 1" <6001>
mailbox=6001
group=5
context=from-internal
channel => 1
callerid=
mailbox=
group=
context=default

;;; line="2 XPP_FXS/00/00/1 FXOKS (In use)"
signalling=fxo_ks
callerid="Channel 2" <6002>
mailbox=6002
group=5
context=from-internal
channel => 2
callerid=
mailbox=
group=
context=default

Note: it goes till 6012

than it comes:

; Span 2: XBUS-00/XPD-10 "Xorcom XPD #00/10: FXO"
;;; line="13 XPP_FXO/00/10/0 FXSKS (In use)"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-pstn
channel => 13
context=default

;;; line="14 XPP_FXO/00/10/1 FXSKS (In use)"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-pstn
channel => 14
context=default

I don't know why this happens. Or maybe I am wrong, but why 4001 and channel 1 is 6001?<br><br>Post edited by: heronleal, at: 2008/02/06 20:48
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#4
You need:

Your /etc/asterisk/zapata.conf should have this lines at the bottom:
...
....
.....
#include zapata-channels.conf;
#include zapata_additional.conf;


In /etc/asterisk/zapata-channels.conf you should have your fxo ports: lines 13 and 14 (remember fxsks signalling).

You shouldn't touch /etc/asterisk/zapata_additional.conf
It is generated everytime you create zap extensions in freepbx. This file lists your zap fxs extensions: lines 1-6 (with fxoks signalling). You don't need to create lines 7-12.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top