[asterisk-users] Manager.conf '127.0.0.1 unable to

Discussion in 'General' started by smsadmin, Oct 31, 2008.

  1. smsadmin

    Joined:
    Oct 27, 2008
    Messages:
    33
    Likes Received:
    0
    Installed webmin thirdlane pbx gui module and asterisk crached with the error in the subject line

    Do someone know how i can correct the bug?
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    mmm...

    Try to paste the complete error message....
     
  3. smsadmin

    Joined:
    Oct 27, 2008
    Messages:
    33
    Likes Received:
    0
    Now i get no message at all, and if i try : #restart now, asterisk log me out
    like that:

    [root@elastix ~]# asterisk -r
    Asterisk 1.4.22-rc5, Copyright (C) 1999 - 2008 Digium, Inc. and others.
    Created by Mark Spencer <markster@digium.com>
    Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for detail s.
    This is free software, with components licensed under the GNU General Public
    License version 2 and other licenses; you are welcome to redistribute it under
    certain conditions. Type 'core show license' for details.
    =========================================================================
    Connected to Asterisk 1.4.22-rc5 currently running on elastix (pid = 3754)
    elastix*CLI> restart now
    elastix*CLI>
    Disconnected from Asterisk server
    [root@elastix ~]#
     
  4. smsadmin

    Joined:
    Oct 27, 2008
    Messages:
    33
    Likes Received:
    0
    here what i get now:
    Failed to connect to the Asterisk manager through port: 5038
    Added 6 minutes ago
    (retrieve_conf.FATAL)
     
  5. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Usually you get that error message when the user and/or password from /etc/amportal.conf and from /etc/asterisk/manager.conf doesn't match.

    I'll recommend you to check if you have a manager.conf.old on the same directory, back up managaner.conf and rename manager.conf.old to manager.conf, and reboot your server.

    If that doesn't work, paste your amportal.conf and manager.conf files
     

Share This Page