Asterisk not load after Elastix1_3's installation

Discussion in 'General' started by seaq, Oct 22, 2008.

  1. seaq

    Joined:
    Sep 17, 2008
    Messages:
    41
    Likes Received:
    0
    I installed the last version of Elastix (1.3) and after of this, the Asterisk don't load.

    When introduce:

    astersik -vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvc

    This message appear:

    Asterisk 1.4.22-rc5, Copyright (C) 1999 - 2008 Digium, Inc. and others.
    Created by Mark Spencer <markster@digium.com>
    Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
    This is free software, with components licensed under the GNU General Public
    License version 2 and other licenses; you are welcome to redistribute it under
    certain conditions. Type 'core show license' for details.
    =========================================================================
    == Parsing '/etc/asterisk/asterisk.conf': Found
    == Parsing '/etc/asterisk/extconfig.conf': Found
    == Parsing '/etc/asterisk/logger.conf': Found
    Asterisk Event Logger Started /var/log/asterisk/event_log
    [root@elastix asterisk]# more /var/log/asterisk/event_log


    The system gives me the following message in /var/log/asterisk/full:

    [Oct 21 18:20:44] VERBOSE[4012] logger.c: Asterisk Event Logger Started /var/log/asterisk/event_log
    [Oct 21 18:20:44] ERROR[4012] asterisk.c: Asterisk has detected a problem with your Zaptel configuration and will shutdown for your protection. You have options:
    1. You only have to compile Zaptel support into Asterisk if you need it. One option is to recompile without Zaptel support.
    2. You only have to load Zaptel drivers if you want to take advantage of Zaptel services. One option is to unload zaptel modules if you don't need them.
    3. If you need Zaptel services, you must correctly configure Zaptel.


    ¿What happen?

    The machine in that i'm installing the Elastix is an:

    HP Proliant DL385G2

    Thanks in advance for your help.
     
  2. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Hi!

    Why you use asterisk in console mode?
    You must use asterisk in remote mode!

    >asterisk -rvvvvv and not
    >asterisk -cvvvvvvv

    • -c Provide console CLI
      -r Connect to Asterisk on this machine
      -v Increase verbosity (multiple v's = more verbose)


    If asterisk work, you must use asterisk -rvvvv.
    If asterisk don't work, you can use asterisk -cvvvvv
     
  3. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Excuse me, i didn't see the "Why" - zaptel! :blush:

    So... you have installed a specific board like TDM or other?
    Have you make an yum update? Maybe there is a valid update to zaptel!?
     
  4. seaq

    Joined:
    Sep 17, 2008
    Messages:
    41
    Likes Received:
    0
    Hi!

    I'm not using a TDM board; i'm working with the TZDUMMY that comes in the standard installation.

    But i've installed the Elastix 1.3 in a Virtual Machine and other PC, and no appears said problem.

    Thanks in advance for your help.
     
  5. itjumper

    Joined:
    Jul 22, 2008
    Messages:
    81
    Likes Received:
    0
    I have the same problem using the following hardware:

    ASUS RS100-X5/PI2 Intel 1U Server with Intel Duo Core CPU with 2 onboard Marvel 8056 GbE LAN controllers

    The same install worked fine on other machine.
     
  6. itjumper

    Joined:
    Jul 22, 2008
    Messages:
    81
    Likes Received:
    0
    I noticed that if you restart zaptel manually, then asterisk will start (manually) ok. But sometimes, asterisk will keep auto restarting if it failed to restart
     
  7. seaq

    Joined:
    Sep 17, 2008
    Messages:
    41
    Likes Received:
    0
    Hi;

    I've solved the issue like this:

    vi /etc/asterisk/modules.conf

    add the line...

    noload => chan_zap.so

    ... afther that it works

    The problem is caused by not having Zaptel hardware in the machine.
     
  8. seaq

    Joined:
    Sep 17, 2008
    Messages:
    41
    Likes Received:
    0
  9. itjumper

    Joined:
    Jul 22, 2008
    Messages:
    81
    Likes Received:
    0
    Asterisk starts successfully every time if zaptel service is disable at startup. I used webmin to disable it
     
  10. seaq

    Joined:
    Sep 17, 2008
    Messages:
    41
    Likes Received:
    0
    Hi Itjumper;

    Do you have any card (for zaptel drivers) installed in your system?
     
  11. itjumper

    Joined:
    Jul 22, 2008
    Messages:
    81
    Likes Received:
    0
  12. gregec

    Joined:
    Jul 24, 2008
    Messages:
    15
    Likes Received:
    0
    I have same problem after upgrading...

    If I unload zaptel genzaptelconf -su
    then Asteerisk load, but I do not know if it is ok to work without zaptel?

    Any suggestions?
     
  13. itjumper

    Joined:
    Jul 22, 2008
    Messages:
    81
    Likes Received:
    0
    zaptel is only required if you need to interface with PSTN, via either an analog or a digital card.

    I have one machine that had this problem when no card was installed. Then the problem went away afrer I installed a Rhino T1 card.

    I think you must have no card installed.
     
  14. gregec

    Joined:
    Jul 24, 2008
    Messages:
    15
    Likes Received:
    0
    Thank you for answer.

    I do not have any card installed, that's why it is strange how come that after upgrade it report this error. I even tried to rescan for zaptel card and it does not find anything, change zaptel.conf but error is same. I can not start aterisk unless I unload zaptel...

    I do not know how to reinstall dummy drivers. I think this is problem that after upgrade dummy zaptel is gone.

    I read somewhere that even if asterisk does not have zaptel cards it has to has loaded zaptel module because of timing?

    I can report now that I have problems with installation now when i unload zaptel module. Exstensions are registered but can not make internal calls beetwen exstension... I will do reinstall :-(((
     

Share This Page