Asterisk manager Connection Failure

capizell

Joined
Feb 8, 2010
Messages
6
Likes
0
Points
0
#1
Hi. I have some problems with Elastix program. When I connect to unembedded freePBX, I found a error:

Asterisk Manager Connection Failure
Failed to connect to the Asterisk manager through port: 5038
Added 13 weeks, 4 days, 2 hours, 32 minutes ago
(retrieve_conf.FATAL)

I've read in some pages the problem could be that in manager.conf and amporta.conf I have different password, but I look it and they're the same:

In amportal.conf:
# AMPMGRUSER: the user to access the Asterisk manager interface
AMPMGRUSER=admin

# AMPMGRPASS: the password for AMPMGRUSER
# AMPMGRPASS=amp111
AMPMGRPASS=amp111


In manager.conf:
[general]
enabled = yes
port = 5038
bindaddr = 0.0.0.0

[admin]
secret = amp111
deny=0.0.0.0/0.0.0.0
permit=127.0.0.1/255.255.255.0
read = system,call,log,verbose,command,agent,user
write = system,call,log,verbose,command,agent,user

#include manager_additional. conf
#include manager_custom.conf


If anyone have the same problem or knows how I can resolve it I was very gratefully. Thanks.
 

wasi.syed

Joined
Jan 7, 2011
Messages
94
Likes
0
Points
0
#2
hello,

even me too facing same kind of error message.

exit: 1

Checking for PEAR DB..OK
Checking for PEAR Console::Getopt..OK
Checking for /etc/amportal.conf ..OK
Bootstrapping /etc/amportal.conf ..OK
Parsing /etc/amportal.conf ..OK
Parsing /etc/asterisk/asterisk.conf ..OK
Connecting to database..OK
Connecting to Asterisk manager interface..Wed, 23 Mar 2011 14:31:10 +0530 - Failed to login.
FAILED
[FATAL] Asterisk Manager Connection Failure Failed to connect to the Asterisk manager through port: 5038
1 error(s) occurred, you should view the notification log on the dashboard or main screen to check for more details.

if any body found solution ...pls do let us know..

regds
wasi
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#3
Re: Re:Asterisk manager Connection Failure

asterisk is running?????
try ps -a -e | grep asterisk
 

wasi.syed

Joined
Jan 7, 2011
Messages
94
Likes
0
Points
0
#4
hello,

given response on provided command.

[root@elastix /]# ps -a -e |grep asterisk
3820 ? 00:00:00 safe_asterisk
3828 ? 00:02:40 asterisk
[root@elastix /]#
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#5
can you telnet to port 5038?? in localhost
 

wasi.syed

Joined
Jan 7, 2011
Messages
94
Likes
0
Points
0
#6
telnet result...it does not work


wasisyed@wasisyed:~$ telnet 192.168.10.5 5038
Trying 192.168.10.5...
telnet: Unable to connect to remote host: Connection refused


whereas shell is working ..

asisyed@wasisyed:~$ sudo ssh root@192.168.10.5
[sudo] password for wasisyed:
root@192.168.10.5's password:
Last login: Thu Mar 24 11:34:34 2011 from 192.168.10.51

Welcome to Elastix
----------------------------------------------------

To access your Elastix System, using a separate workstation (PC/MAC/Linux)

Open the Internet Browser using the following URL:
http://192.168.10.5

[root@elastix ~]#


advise further...
REgsd
Wasi
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#7
Re: Re:Asterisk manager Connection Failure

then there is your problem.....u dont have acces to the asterisk manager interface...try search about manger.conf files and how to configure permissions
 

wasi.syed

Joined
Jan 7, 2011
Messages
94
Likes
0
Points
0
#8
hello,
telnet 127.0.0.1 5038 able to connected

even check cli mode found something errror message on cli mode whenever disconnect calls
but does not understand meaning and solution ..

==connect attempt from '127.0.0.1' able to authenticate
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#9
Re: Re:Asterisk manager Connection Failure

then your problem is an auth problem between your program and managertry searching in manager.conf permits and ip validations
 

wasi.syed

Joined
Jan 7, 2011
Messages
94
Likes
0
Points
0
#10
hello,

this is my manager.conf file

AMI - Asterisk Manager interface
;
; FreePBX needs this to be enabled. Note that if you enable it on a different IP, you need
; to assure that this can't be reached from un-authorized hosts with the ACL settings (permit/deny).
; Also, remember to configure non-default port or IP-addresses in amportal.conf.
;
; The AMI connection is used both by the portal and the operator's panel in FreePBX.
;
; FreePBX assumes an AMI connection to localhost:5038 by default.
;
#include manager_additional.conf
#include manager_custom.conf

[general]
enabled = yes
port = 5038
bindaddr = 127.0.0.1

[AMPMGRUSER]
secret = amp1234
deny=0.0.0.0/0.0.0.0
permit=127.0.0.1/255.255.255.0
read = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate
write = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate

can u pls chk and advise further troubleshoot.

regds
wasi
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top