asterisk doesn't answer calls

Discussion in 'General' started by bono056, Feb 22, 2010.

  1. bono056

    Joined:
    Jan 19, 2010
    Messages:
    70
    Likes Received:
    0
    i've done some changes in my pbx, but after that asterisk doesn't answer calls. i see something like this in cli:
    Code:
        -- Starting simple switch on 'DAHDI/3-1'
        -- Executing [s@from-pstn:1] Set("DAHDI/3-1", "__FROM_DID=s") in new stack
        -- Executing [s@from-pstn:2] Gosub("DAHDI/3-1", "app-blacklist-check|s|1") in new stack
        -- Executing [s@app-blacklist-check:1] LookupBlacklist("DAHDI/3-1", "") in new stack
        -- Executing [s@app-blacklist-check:2] GotoIf("DAHDI/3-1", "0?blacklisted") in new stack
        -- Executing [s@app-blacklist-check:3] Return("DAHDI/3-1", "") in new stack
        -- Executing [s@from-pstn:3] ExecIf("DAHDI/3-1", "1 |Set|CALLERID(name)=") in new stack
        -- Executing [s@from-pstn:4] Set("DAHDI/3-1", "__CALLINGPRES_SV=allowed_not_screened") in new stack
        -- Executing [s@from-pstn:5] SetCallerPres("DAHDI/3-1", "allowed_not_screened") in new stack
        -- Executing [s@from-pstn:6] Goto("DAHDI/3-1", "app-blackhole|hangup|1") in new stack
        -- Goto (app-blackhole,hangup,1)
        -- Executing [hangup@app-blackhole:1] NoOp("DAHDI/3-1", "Blackhole Dest: Hangup") in new stack
        -- Executing [hangup@app-blackhole:2] Hangup("DAHDI/3-1", "") in new stack
      == Spawn extension (app-blackhole, hangup, 2) exited non-zero on 'DAHDI/3-1'
        -- Hungup 'DAHDI/3-1'
        -- Remote UNIX connection
        -- Remote UNIX connection disconnected
    
    
    any idea about whats the problem cam be?
     
  2. bono056

    Joined:
    Jan 19, 2010
    Messages:
    70
    Likes Received:
    0
    apparently problem started when i click System>Hardware Detection>detect new hardwares.
    it overwrite 2 conf files (dahdi-channels.conf & chan_dahdi.conf.elastixsave).
    now dahdi-channels.conf is something like this:
    Code:
    signalling=fxs_ks
    callerid=asreceived
    group=0
    context=from-pstn
    channel => 1
    callerid=
    group=
    context=default
    
    i changed context to from-zaptel, but it dosnt work again.
     
  3. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    wll with that info nobody will answer ever...try to explain the scenrios...card, version etc your configs
     

Share This Page