Asterisk Call Manager/1.0

Discussion in 'General' started by pnaves, Aug 20, 2009.

  1. pnaves

    Joined:
    May 27, 2009
    Messages:
    66
    Likes Received:
    0
    Hello Folks,

    Why I can't login into Asterisk Call Mangager with this commands.

    Action: login
    Username:admin
    Secret:elastix456

    Response: Error
    Message: Authentication failed
    Asterisk Call Manager/1.0

    Note: My Elastix server using all defaults password.

    Tks,
    ;)
     
  2. pawels

    Joined:
    May 19, 2008
    Messages:
    51
    Likes Received:
    0
    Hello,
    Check your security settings in /etc/asterisk/manager.conf
    By default only local connection is allowed.

    Pawel
     
  3. pnaves

    Joined:
    May 27, 2009
    Messages:
    66
    Likes Received:
    0
    Hi,
    Firstly Tks for response!
    I commented the permit line command just as you see below, but I had the same error. What I have to do?

    Regards,
    Pedro


    ;
    ; Asterisk Call Management support
    ;
    [general]
    enabled = yes
    port = 5038
    bindaddr = 0.0.0.0

    [admin]
    secret = elastix456
    deny=0.0.0.0/0.0.0.0
    ;permit=127.0.0.1/255.255.255.0
    read = all,system,call,log,verbose,command,agent,user
    write = all,system,call,log,verbose,command,agent,user

    #include manager_additional.conf
    #include manager_custom.conf
     
  4. pawels

    Joined:
    May 19, 2008
    Messages:
    51
    Likes Received:
    0
    Hi,

    From your config I see that you have blocked all coonections!
    ...
    deny=0.0.0.0/0.0.0.0
    ...

    To allow connection from local host you should uncommented line
    permit=127.0.0.1/255.255.255.0

    To allow connection from paricular host with IP 192.168.10.15 you should add line:.
    permit=192.168.10.15/255.255.255.0

    example of manager.conf

    [general]
    enabled = yes
    port = 5038
    bindaddr = 0.0.0.0

    [admin]
    secret = elastix456
    deny=0.0.0.0/0.0.0.0
    permit=127.0.0.1/255.255.255.0
    permit=192.168.10.15/255.255.255.0
    permit=172.20.2.121/255.255.255.0
    read = all,system,call,log,verbose,command,agent,user
    write = all,system,call,log,verbose,command,agent,user

    #include manager_additional.conf
    #include manager_custom.conf

    Of course you can add any account in file manager_custom.conf - it is recommended way.

    example of manager_custom.conf

    [user]
    secret = password
    deny=0.0.0.0/0.0.0.0
    permit=192.168.10.15/255.255.255.0
    read = all,system,call,log,verbose,command,agent,user

    Regards,
    Pawel
     
  5. pnaves

    Joined:
    May 27, 2009
    Messages:
    66
    Likes Received:
    0
    Solve my problem :p

    Tks very much
     

Share This Page