asterisk 1.6.2 whispering

Discussion in 'General' started by saidmsl, Jan 1, 2010.

  1. saidmsl

    Joined:
    Nov 20, 2008
    Messages:
    65
    Likes Received:
    0
    Hi,

    just install elastix alpha 3 with asterisk 1.6.2 to test whispering feature

    [spy]
    exten => 779,1,Macro(user-callerid)
    exten => 779,2,Authenticate(2143)
    exten => 779,3,Read(SPYNUM,,3)
    exten => 779,4,ChanSpy(SIP/${SPYNUM},wv2)
    exten => 779,5,Hangup()




    i added a extension which enable the spying and whispering

    when i call to 555 , i can hear the remote extension
    but with my extension 779 , i get error :



    -- Executing [779@from-internal:1] ResetCDR("SIP/102-00000005", "") in new stack
    -- Executing [779@from-internal:2] NoCDR("SIP/102-00000005", "") in new stack
    -- Executing [779@from-internal:3] Wait("SIP/102-00000005", "1") in new stack
    -- Executing [779@from-internal:4] Playback("SIP/102-00000005", "silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer") in new stack
    -- <SIP/102-00000005> Playing 'silence/1.gsm' (language 'en')
    -- <SIP/102-00000005> Playing 'cannot-complete-as-dialed.gsm' (language 'en')
    -- <SIP/102-00000005> Playing 'check-number-dial-again.gsm' (language 'en')

    any idea?


    -
     
  2. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Hi
    Do you have the same problem with the Alpha 2 and Asterisk 1.6?
     
  3. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Hmmm. I think that your problem must be asked on Beta Tester mailing list instead of this forum.
    The forum is more for the stable version than any pre-realse version.
    And into this mailing list, I think that there's lots of guy that could you give an answer.

    Regards
     
  4. saidmsl

    Joined:
    Nov 20, 2008
    Messages:
    65
    Likes Received:
    0
    Hi,

    i did not test.

    it's a test server inside vmware esx

    what i did :
    i had elastix 1.6 with asterisk 1.4.26 working properly
    in the beta repo, i saw that the 1.4.28 rpm was available
    i installed it.

    whispering is disabled in 1.4.26 but was reenabled in 1.4.27

    i got the error.

    i, then , tried to upgrade to 2.0 (via yum) but same, then i reinstalled a new and clean elastix and add the whispering function

    still same.
     
  5. saidmsl

    Joined:
    Nov 20, 2008
    Messages:
    65
    Likes Received:
    0
    i post it here because i had the same issue with 1.6 and asterisk 1.4.28
     

Share This Page