Appels qui sonnent et qui sonnent ?!!!??

Discussion in 'Elastix 2.x' started by Jaypeto, Sep 13, 2009.

  1. Jaypeto

    Joined:
    Sep 7, 2009
    Messages:
    17
    Likes Received:
    0
    tout marchait bien sur notre PBX alors nous avons déscidés de passer à une phase de test tout nos communications marchaient bien pendant 2 jours aucun problème mais à un moment donner je decide de retester la ligne sonne et sonne sans donner sur notre IVR comme si notre trunk ne menais nulle part, ,mais que je pouvais faire des appels sortant a partir de mon poste sans problème .Alors je me souviens avoir rencontrer le meme problème avant le début de nos tests(que je réglais en rebootant le serveur) mais je decidas de seulement desactiver le trunk et de le réactiver alors comme par magie tout remarche :S alors je me dit que c surement le trunk qui était mort alors je vais voir mes logs sur mon fournisseur et je vois que les appels on bien atteint le trunk mais que c moi qui REFUSAIT les appels. je suis donc aller voir dans mon log FULL et voici c qui c'est passé avant que je désactive le trunk.

    Je me suis rendu compte du probleme à 15:09


    Code:
    [Sep 13 10:42:54] VERBOSE[14625] logger.c:   == Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'Local/450xxxxxxxx@from-internal-f61a,2' in macro 'hangupcall'
    [Sep 13 10:42:54] VERBOSE[14625] logger.c:   == Spawn h extension (macro-dialout-trunk, h, 1) exited non-zero on 'Local/450xxxxxxx@from-internal-f61a,2'
    [Sep 13 10:42:54] VERBOSE[14625] logger.c:   == Spawn extension (macro-dialout-trunk, s, 19) exited non-zero on 'Local/450xxxxxxx@from-internal-f61a,2' in macro 'dialout-trunk'
    [Sep 13 10:42:54] VERBOSE[14625] logger.c:   == Spawn extension (from-internal, 450xxxxxxx, 4) exited non-zero on 'Local/450xxxxxxx@from-internal-f61a,2'
    [Sep 13 10:43:03] VERBOSE[14627] logger.c:     -- <SIP/prosdelinfo01-08c66d38> Playing 'auth-thankyou' (language 'en')
    [Sep 13 10:43:04] VERBOSE[14627] logger.c:     -- Executing [1@disa:2] Set("SIP/xxxxxxx-xxxxxxxx", "_DISA="disa|1|newcall"") in new stack
    [Sep 13 10:43:04] VERBOSE[14627] logger.c:     -- Executing [1@disa:3] Set("SIP/xxxxxxx-xxxxxxxx", "_DISACONTEXT=from-internal") in new stack
    [Sep 13 10:43:04] VERBOSE[14627] logger.c:     -- Executing [1@disa:4] Set("SIP/xxxxxxx-xxxxxxxx", "_KEEPCID=TRUE") in new stack
    [Sep 13 10:43:04] VERBOSE[14627] logger.c:     -- Executing [1@disa:5] Set("SIP/xxxxxxx-xxxxxxxx", "TIMEOUT(digit)=5") in new stack
    [Sep 13 10:43:04] VERBOSE[14627] logger.c:     -- Digit timeout set to 5
    [Sep 13 10:43:04] VERBOSE[14627] logger.c:     -- Executing [1@disa:6] Set("SIP/xxxxxxx-xxxxxxxx", "TIMEOUT(response)=10") in new stack
    [Sep 13 10:43:04] VERBOSE[14627] logger.c:     -- Response timeout set to 10
    [Sep 13 10:43:04] VERBOSE[14627] logger.c:     -- Executing [1@disa:7] DISA("SIP/xxxxxxx-xxxxxxxx", "no-password|disa-dial") in new stack
    [Sep 13 10:43:04] DEBUG[14627] app_disa.c: Digittimeout: 5000
    [Sep 13 10:43:04] DEBUG[14627] app_disa.c: Responsetimeout: 10000
    [Sep 13 10:43:04] DEBUG[14627] app_disa.c: Mailbox: 
    [Sep 13 10:43:04] DEBUG[14627] app_disa.c: Context: disa-dial
    [Sep 13 10:43:04] DEBUG[14627] app_disa.c: DISA no-password login success
    [Sep 13 10:43:14] DEBUG[14627] app_disa.c: DISA extension entry timeout on chan SIP/xxxxxxxxxxx-xxxxxxxxxxxx
    [Sep 13 10:43:22] VERBOSE[14627] logger.c:   == Spawn extension (disa, 1, 7) exited non-zero on 'SIP/xxxxxxxxxxx-xxxxxxxxxxxx
    [Sep 13 10:45:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 10:45:01] VERBOSE[14631] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 10:50:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 10:50:01] VERBOSE[14637] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 10:55:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 10:55:02] VERBOSE[14643] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 11:00:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 11:00:02] VERBOSE[14649] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 11:05:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 11:05:01] VERBOSE[14661] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 11:10:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 11:10:01] VERBOSE[14667] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 11:15:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 11:15:02] VERBOSE[14673] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 11:20:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 11:20:02] VERBOSE[14679] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 11:25:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 11:25:02] VERBOSE[14688] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 11:30:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 11:30:01] VERBOSE[14694] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 11:35:02] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 11:35:02] VERBOSE[14701] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 11:40:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 11:40:02] VERBOSE[14707] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 11:45:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 11:45:02] VERBOSE[14713] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 11:50:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 11:50:01] VERBOSE[14752] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 11:55:02] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 11:55:02] VERBOSE[14758] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 12:00:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 12:00:02] VERBOSE[14765] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 12:05:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 12:05:02] VERBOSE[14777] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 12:10:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 12:10:01] VERBOSE[14783] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 12:15:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 12:15:02] VERBOSE[14789] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 12:20:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 12:20:02] VERBOSE[14795] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 12:25:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 12:25:02] VERBOSE[14804] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 12:30:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 12:30:01] VERBOSE[14810] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 12:35:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 12:35:01] VERBOSE[14817] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 12:40:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 12:40:02] VERBOSE[14823] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 12:45:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 12:45:02] VERBOSE[14829] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 12:50:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 12:50:01] VERBOSE[14835] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 12:55:02] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 12:55:02] VERBOSE[14874] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 13:00:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 13:00:02] VERBOSE[14880] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 13:05:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 13:05:02] VERBOSE[14892] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 13:10:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 13:10:01] VERBOSE[14898] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 13:15:02] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 13:15:02] VERBOSE[14904] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 13:20:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 13:20:02] VERBOSE[14910] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 13:25:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 13:25:02] VERBOSE[14919] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 13:30:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 13:30:01] VERBOSE[14925] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 13:35:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 13:35:01] VERBOSE[14932] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 13:40:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 13:40:02] VERBOSE[14939] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 13:45:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 13:45:02] VERBOSE[14945] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 13:50:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 13:50:01] VERBOSE[14951] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 13:55:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 13:55:01] VERBOSE[14957] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 14:00:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 14:00:02] VERBOSE[14963] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 14:05:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 14:05:02] VERBOSE[14975] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 14:10:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 14:10:01] VERBOSE[14981] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 14:15:02] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 14:15:02] VERBOSE[15020] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 14:20:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 14:20:02] VERBOSE[15026] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 14:25:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 14:25:02] VERBOSE[15035] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 14:30:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 14:30:02] VERBOSE[15041] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 14:35:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 14:35:01] VERBOSE[15048] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 14:40:02] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 14:40:02] VERBOSE[15054] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 14:45:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 14:45:02] VERBOSE[15060] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 14:50:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 14:50:02] VERBOSE[15066] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 14:55:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 14:55:01] VERBOSE[15072] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 15:00:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 15:00:02] VERBOSE[15078] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 15:05:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 15:05:02] VERBOSE[15090] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 15:09:22] VERBOSE[2743] logger.c:     -- Registered SIP '3001' at 192.168.0.105 port 4002
    [Sep 13 15:09:22] NOTICE[2743] chan_sip.c: Peer '3001' is now Reachable. (114ms / 2000ms)
    [Sep 13 15:10:01] VERBOSE[2631] logger.c:     -- Remote UNIX connection
    [Sep 13 15:10:02] VERBOSE[15096] logger.c:     -- Remote UNIX connection disconnected
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [450xxxxxxx@from-internal:1] Macro("SIP/3001-xxxxxxx", "user-callerid|SKIPTTL|") in new stack
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-user-callerid:1] Set("SIP/3001-08c47750", "AMPUSER=xxxx") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: Set
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-user-callerid:2] GotoIf("SIP/3001-xxxxxxxx", "0?report") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: GotoIf
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-user-callerid:3] ExecIf("SIP/3001-xxxxxxxx", "1|Set|REALCALLERIDNUM=xxxx") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: ExecIf
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-user-callerid:4] Set("SIP/3001-xxxxxxxx", "AMPUSER=xxxx") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: Set
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-user-callerid:5] Set("SIP/3001-xxxxxxxxx", "AMPUSERCIDNAME=xxxxxxx") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: Set
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-user-callerid:6] GotoIf("SIP/3001-xxxxxxx", "0?report") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: GotoIf
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-user-callerid:7] Set("SIP/3001-08c47750", "AMPUSERCID=xxxx") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: Set
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-user-callerid:8] Set("SIP/3001-xxxxxxxx", "CALLERID(all)="xxxxxx" <xxxx>") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: Set
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-user-callerid:9] Set("SIP/3001-xxxxxxxxx", "REALCALLERIDNUM=xxxx") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: Set
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-user-callerid:10] ExecIf("SIP/3001-xxxxxxxxx", "0|Set|CHANNEL(language)=") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: ExecIf
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-user-callerid:11] GotoIf("SIP/3001-xxxxxxxx", "1?continue") in new stack
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Goto (macro-user-callerid,s,20)
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: GotoIf
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-user-callerid:20] NoOp("SIP/3001-xxxxxxxx", "Using CallerID "xxxxxxx" <xxxx>") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: Noop
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [450xxxxxxx@from-internal:2] Set("SIP/3001-xxxxxxxxx", "_NODEST=") in new stack
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [450xxxxxxx@from-internal:3] Macro("SIP/3001-xxxxxxxxx", "record-enable|3001|OUT|") in new stack
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-record-enable:1] GotoIf("SIP/3001-xxxxxxxxx", "1?check") in new stack
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Goto (macro-record-enable,s,4)
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: GotoIf
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-record-enable:4] AGI("SIP/3001-xxxxxxxx", "recordingcheck|20090913-151255|1252869175.318") in new stack
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:   recordingcheck|20090913-151255|1252869175.318: Outbound recording not enabled
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- AGI Script recordingcheck completed, returning 0
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: AGI
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-record-enable:5] MacroExit("SIP/3001-xxxxxxxx", "") in new stack
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [450xxxxxxxx@from-internal:4] Macro("SIP/3001-xxxxxxxxx", "dialout-trunk|2|450xxxxxxx||") in new stack
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-dialout-trunk:1] Set("SIP/3001-xxxxxxxxx", "DIAL_TRUNK=2") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: Set
    [Sep 13 15:12:55] DEBUG[15115] func_db.c: DB: AMPUSER/3001/pinless not found in database.
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-dialout-trunk:2] GosubIf("SIP/3001-xxxxxxxx", "0?sub-pincheck|s|1") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: GosubIf
    [Sep 13 15:12:55] DEBUG[15115] func_db.c: DB: AMPUSER/3001/pinless not found in database.
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-dialout-trunk:3] GotoIf("SIP/3001-xxxxxxxx", "0?disabletrunk|1") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: GotoIf
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-dialout-trunk:4] Set("SIP/3001-xxxxxxxx", "DIAL_NUMBER=450xxxxxxxx") in new stack
    [Sep 13 15:12:55] DEBUG[15115] app_macro.c: Executed application: Set
    [Sep 13 15:12:55] VERBOSE[15115] logger.c:     -- Executing [s@macro-dialout-trunk:5] Set("SIP/3001-xxxxxxxx", "DIAL_TRUNK_OPTIONS=tr") in new stack
    
     
  2. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Coucou.

    Tu as le début qui commence avec un raccroché puis ça part sur une DISA et pas de réception Q23 (MF ou FV).
    Tu utilises une DISA?

    Tu peux m'en dire plus sur ton acheminement d'appels? (routes entrante)

    Essayes déjà dans les routes entrantes de mettre DID any et CID any vers une extension.
    Si ça fonctionne, change la cible pour y mettre le SVI (IVR) à la place de ton extension.
    Regardes de nouveau le résultat.

    Mais il doit y avoir autre chose avant la première ligne du debug non?
     
  3. Jaypeto

    Joined:
    Sep 7, 2009
    Messages:
    17
    Likes Received:
    0
    Après avoir bien regarder le log je me suis rendu compte que tout les appels inbound que j'ai fait à partir de ma ligne terrestre vers mon pbx ne sont même pas inscrites sur le log. Aucune traces !!! Alors je commence à croire que c'est soit le trunk ou bien mon routeur qui ne dirige pas bien mes appels entrants vers mon PBX sinon il y aurait des traces de refus mais il n'y a rien mais lorsque j'ai allumé mon extention à 15:09 ma connection au PBX c'est faite. Mon Inbound route de any DID's donne sur un IVR qui lui me donne 4 options:

    -1 mon poste
    -2 le poste de mon pote
    -3 DISA
    -4 callback

    est-il possible que mon PBX rejéte les appels mais qu'il ne laisse aucune trace?

    j'ai vraiment besoin que mon PBX soit stable avant sa mise en dévellopement dans les entreprises que je supporte donc merci de votre aide!!!!;)
     
  4. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Tu n'as pas de trace SIP?

    Si tu fais un:
    CLI> sip debug peer Ton_trunk ou encore
    CLI> sip debug ip adresse_ip

    ça te donne quelque chose?

    Tu as bien vérifié le résultat de :
    sip show peers et de sip show registry ?

    Si ce n'est toujours pas bon, essayes de rajouter des les paramètres de ton trunk:

    type=friend
    context=from-trunk
    host=ton.opertateur.net
    fromdomain=ton.opertateur.net
    fromuser=ton_compte

    username=ton_compte
    secret=ton_mot_de_passe
    nat=yes
    canreinvite=no
    disallow=all
    allow=ulaw
    sendrpid=yes <---je ne pense pas que ça soit utile
    trustrpid=yes <_|
    insecure=very

    Ton opérateur n'a pas besoin du register string?
    Si besoin, renseigner compte:mdp @ ton_operateur.net (sans espace autour du @ )
     
  5. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Heuuu.. je ne sais plus si tu as renseigné le sip_nat.conf?

    Attention au renvoie de port de ton routeur.
     
  6. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Tu t'en sors Jaypeto?
     
  7. Jaypeto

    Joined:
    Sep 7, 2009
    Messages:
    17
    Likes Received:
    0
    mon problème est intermittent mon fichier sip_nat.conf ainsi que mes ports est bien configuré voici mon PEER DETAIL. Me manque t'il quelques choses :

    username=xxxxxxxxxxx
    user=xxxxxxxxxxxx
    type=friend
    trustrpid=yes
    sendrpid=yes
    secret=xxxxxxxx
    nat=yes
    insecure=very
    host=sip-slb.voicemeup.com
    disallow=all
    context=from-trunk
    canreinvite=no
    allow=ulaw

    peut-tu me dire à quoi servent les commandes que voici :

    CLI> sip debug peer Ton_trunk ou encore
    CLI> sip debug ip adresse_ip

    et pardont mais je n'est jamais entendu parler de :

     
  8. Jaypeto

    Joined:
    Sep 7, 2009
    Messages:
    17
    Likes Received:
    0
    résultat de >sip show peers

    Name/username Host Dyn Nat ACL Port Status
    prosdelinfo01/prosdelinfo xx.xx.xxx.xxx N 5060 Unmonitored <--- ici on peu voir que mon trunk est bien là
    3003 (Unspecified) D N 0 UNKNOWN
    3002 (Unspecified) D N 0 UNKNOWN
    3001/3001 192.168.0.105 D N 39586 OK (107 ms) <------ ici on voi mon poste
    3000/3000 (Unspecified) D N 0 UNKNOWN
    5 sip peers [Monitored: 1 online, 3 offline Unmonitored: 1 online, 0 offline]

    j'ai essayé la commande sip debug peer prosdelinfo01 mais sa donne seulement:

    SIP Debugging Enabled for IP: xx.55.158.xxx:5060
     
  9. Jaypeto

    Joined:
    Sep 7, 2009
    Messages:
    17
    Likes Received:
    0
    Voici mon sip nat.conf :
    nat=yes
    externip = xxx.131.59.xxx
    localnet = 192.168.0.0/255.255.255.0

    Voici les informations de sip show peer :

    * Name : prosdelinfo01
    Secret : <Set>
    MD5Secret : <Not set>
    Context : from-trunk
    Subscr.Cont. : <Not set>
    Language :
    AMA flags : Unknown
    Transfer mode: open
    CallingPres : Presentation Allowed, Not Screened
    Callgroup :
    Pickupgroup :
    Mailbox :
    VM Extension : *97
    LastMsgsSent : 32767/65535
    Call limit : 0
    Dynamic : No
    Callerid : "" <>
    MaxCallBR : 384 kbps
    Expire : -1
    Insecure : port,invite
    Nat : Always
    ACL : No
    T38 pt UDPTL : No
    CanReinvite : No
    PromiscRedir : No
    User=Phone : No
    Video Support: No
    Trust RPID : Yes
    Send RPID : Yes
    Subscriptions: Yes
    Overlap dial : Yes
    DTMFmode : rfc2833
    LastMsg : 0
    ToHost : sip-slb.voicemeup.com
    Addr->IP : xxx.55.158.xxx Port 5060
    Defaddr->IP : 0.0.0.0 Port 0
    Def. Username: prosdelinfo01
    SIP Options : replaces replace timer path precondition
    Codecs : 0x4 (ulaw)
    Codec Order : (ulaw:20)
    Auto-Framing: No
    Status : Unmonitored
    Useragent :
    Reg. Contact :






    s.v.p aidez moi je suis perdu !!!!:(

    merci à tout ceux qui pouront m'aidé;)
     
  10. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Oui, mais on ne sais pas s'il est ok!
    Rajoutes un qualify=yes dans le trunk.

    nat=yes inutile dans ce coin de conf.
    Supprimes le de sip_nat.conf vu que tu mes ce paramètres dans les trunks et extensions....

     
  11. Jaypeto

    Joined:
    Sep 7, 2009
    Messages:
    17
    Likes Received:
    0
    Merci beaucoup danardf ton aide m'est précieuse :cheer: je vais essayer tes conseils je pense que c'est exactement ce qui causait mes problèmes je vais testé et je te donne des nouvelles.


    MERCI ENCORE !!!!!:) :) :)
     
  12. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Ha le décalage horaire.. :laugh:

    Ok, tiens moi au courant. :)
     
  13. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Pas de nouvelle, bonne nouvelle?

    Alors ça fonctionne ou pas?
     
  14. Jaypeto

    Joined:
    Sep 7, 2009
    Messages:
    17
    Likes Received:
    0
    Non mon problème ne semble toujours pas régler :S :(

    Mais j'ai un petit doute!!! Il semble que mon adresse I.P. n'était pas static !!! J'ai fowardé les port 5060 et 10 000 - 20 000 sur mon PBX l' I.P. 192.168.0.103 mais ce matin lorque rien semblait fonctionné je me tape un petit ifconfig pour me rendre compte que mon I.P. est 192.168.0.100 donc je redémarre ma machine et je reteste (sans revéfifer mon I.P.). Tout fonctionne alors je regarde mon I.P. et je me rend compte que mon I.P. est encore 192.168.0.100 mais sa fonctionne alors que mes ports sont fowarder sur la machine 192.168.0.103 c'est à ni rien comprendre!!!!!!:blink:

    alors pour la prochaine étape je vais mettre tout mes I.P. statics et je vais voir si par hasard mon problème venait de là mais je crois que c'est fort probable qu'en penses-tu ? Et comment est ce possible que les commucications se fassent enre mon routeur et mon PBX alors que les ports sont fowardés sur une autre machine ???

    Pardonne moi si je ne t'est pas donné de nouvelles plus tôt;)
     
  15. Jaypeto

    Joined:
    Sep 7, 2009
    Messages:
    17
    Likes Received:
    0
    Enfin Victoire j'ai trouvé :) :) :) :woohoo: :woohoo: :woohoo:

    Aprés plusieurs heures de tests nous avons enfin trouvé !!! Le problème venait de notre trop grande confiance en notre fournisseur trunk qui nous assurais d'un sevice à tout épreuve:angry:. Depuis le début nous avions confiance en tout nos réglages mais notre fournisseur de trunk nous disais que le probléme venais de notre coté (mais il semble que leurs ligne sonnaient dans le vide et que le problème venait de leurs coté). Alors j'ai perdu près de une semaine de test plus d'une cinquantaine de dollards pour de belles paroles venant d'une bande de charlatants qui offrent des services de mauvaises qualités. Donc nous allons demandé d'etre rembourser!!!!:angry:

    Merci de l'aide que vous nous avez donné elle fût bien apprécié mais j'ai une derniére question. lorsque je fait un cli> sip debug peer "nomdemonpeer" ou un sip debug ip "monip" rien n'apparait dans la fenêtre lorsque je fais un appel, est ce normal? comment puis-je voir le resultat du debug ?
     
  16. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Quand un opérateur se comporte de la sorte, on le surnomme : le panoupanou. (en se référant à une vieille histoire de chasse en Afrique) :laugh:

    Pour le mode débug quand tu es en mode CLI (# asterisk -rvvvvvvvvvvvv )
    CLI> sip debug peer ou ip ou même rien, doivent donner systématiquement quelque chose, mais il ne faut pas quitter le mode CLI durant ton appel!

    Sinon tu trouveras le résultat dans les log Asterisk.

    Bon en tout cas, c'est une bonne nouvelle. :)
     

Share This Page